Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Secure Connection Failed An error occurred during a connection to www.facebook.com. SSL received a record that exceeded the maximum permissibleerror message:

  • 3 uphendule
  • 26 zinale nkinga
  • 28587 views
  • Igcine ukuphendulwa ngu penneygrylls

more options

have tried any firefox suggested remedies - still no access to facebook or any other search engine to help with problem. Problem appeared yesterday afternoon, this morning following address string appears in history when I try to access facebook: https://www.facebook.com/l.php?u=https%3A%2F%2Fapps.facebook.com%2Fjigsawworld%2F%3Ffb_source%3Dbookmark_apps%26ref%3Dbookmarks%26count%3D0%26fb_bmpos%3D2_0&h=tAQElEECK&s=1 as well as connection error message

Secure Connection Failed

An error occurred during a connection to www.facebook.com. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

Isisombululo esikhethiwe

hello penneygrylls, are you a customer of the canadian ISP shaw? in this case this is a known issue at the moment unfortunately, which is already worked upon.

other affected users have reported that you can temporarily circumvent the issue when you enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.tls.version.max. double-click it and change its value to 0.

once the issue is resolved by shaw or firefox, you should go back and revert security.tls.version.max to 1 again, since it will provide a greater level of security this way.

for updates on the issue you can also follow this thread: https://support.mozilla.org/en-US/questions/976504

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 10

All Replies (3)

more options

Isisombululo Esikhethiwe

hello penneygrylls, are you a customer of the canadian ISP shaw? in this case this is a known issue at the moment unfortunately, which is already worked upon.

other affected users have reported that you can temporarily circumvent the issue when you enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named security.tls.version.max. double-click it and change its value to 0.

once the issue is resolved by shaw or firefox, you should go back and revert security.tls.version.max to 1 again, since it will provide a greater level of security this way.

for updates on the issue you can also follow this thread: https://support.mozilla.org/en-US/questions/976504

more options

I phoned Shaw for help & they have a message saying that if you are using Mozilla, don't...change to Chrome or Explorer. I like using Firefox & hope you can provide a solution. So far I have tried some of the solutions with no success. There is no encryption setting to use so couldn't do try that. Has anyone had success yet?

more options

Thank you philipp, this worked - I have regained access to both facebook and google. I will follow the recommended thread to see if this issue is resolved by shaw or firefox, and return the original value.