X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot show Bookmarks toolbar

Kuphostiwe

I have installed Firefox 24 on a new Win 8-64 laptop. The Bookmarks Toolbar is not visible. I know it is not visible by default, I have checked it, but it still is not visible.

Any suggestions?

I have installed Firefox 24 on a new Win 8-64 laptop. The Bookmarks Toolbar is not visible. I know it is not visible by default, I have checked it, but it still is not visible. Any suggestions?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Foxit Reader Plug-In For Firefox and Netscape
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0

Isisebenziso

  • Firefox 24.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • I-URL Yokweseka: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Izandiso

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16384
  • driverDate: 10-17-2012
  • driverDate2:
  • driverVersion: 9.17.10.2875
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Okuthandwayo Okulungisiwe

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1382796930
  • places.history.expiration.transient_current_max_pages: 104375
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1382711172

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Yebo
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158974 izimpendulo
Kuphostiwe

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar
  • if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup
Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible. *Firefox menu button > Options *View > Toolbars (press F10 to display the menu bar) *Right-click empty toolbar area Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display. *check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar *if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar *if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar *if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup *https://support.mozilla.org/kb/How+to+customize+the+toolbar *https://support.mozilla.org/kb/Back+and+forward+or+other+toolbar+items+are+missing

Umnikazi wombuzo

Thank you for replying. When I right-click on the blank space on the right of the Menu bar I see:

Menu Bar Navigation Toolbar Bookmark Toolbar

These are all checked.

There is also:

Add-on Toolbar Custom

These are not checked, and if I do check them nothing happens. Does that make it clearer?

David

Thank you for replying. When I right-click on the blank space on the right of the Menu bar I see: Menu Bar Navigation Toolbar Bookmark Toolbar These are all checked. There is also: Add-on Toolbar Custom These are not checked, and if I do check them nothing happens. Does that make it clearer? David
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158974 izimpendulo
Kuphostiwe

If the Bookmarks Toolbar is visible, but you do not see bookmarks that show if you inspect the Bookmarks Toolbar folder in the sidebar or Library (Bookmarks Manager) then it is possible that the "Bookmarks Toolbar items" is no longer positioned on the Bookmarks Toolbar.

Did you check that as I posted above?

If the Bookmarks Toolbar is visible, but you do not see bookmarks that show if you inspect the Bookmarks Toolbar folder in the sidebar or Library (Bookmarks Manager) then it is possible that the "Bookmarks Toolbar items" is no longer positioned on the Bookmarks Toolbar. Did you check that as I posted above?

Umnikazi wombuzo

I do not seem to be making myself clear. The suggestions you made do not address the problem so let me state it again.

If I click on View >Toolbars: Menu, Bookmarks and Navigation are all checked. The Menu bar is visible. The Navigation toolbar is visible. The Bookmarks Toolbar is NOT visible. I have bookmarked pages, I can get to those pages by using the Bookmarks menu, but I would like to have the Bookmarks Toolbar which is an easy way to get to those pages.

I do not seem to be making myself clear. The suggestions you made do not address the problem so let me state it again. If I click on View >Toolbars: Menu, Bookmarks and Navigation are all checked. The Menu bar is visible. The Navigation toolbar is visible. The Bookmarks Toolbar is NOT visible. I have bookmarked pages, I can get to those pages by using the Bookmarks menu, but I would like to have the Bookmarks Toolbar which is an easy way to get to those pages.
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158974 izimpendulo
Kuphostiwe

You can only see bookmarks on the Bookmarks Toolbar if those bookmarks are located in the Bookmarks Toolbar folder.
So you may need to move or copy bookmarks to this folder.

I assume that you have confirmed that the "Bookmarks Toolbar items" is positioned on the Bookmarks Toolbar?

This item is customizable and can be placed on toolbars other than the Bookmarks Toolbar.
If this item is not on the Bookmarks Toolbar then you won't see any bookmarks and nor can you drag a tab onto the Bookmarks Toolbar to create a new bookmark or see the bookmarks context menu if you right-click the Bookmarks Toolbar.

You can only see bookmarks on the Bookmarks Toolbar if those bookmarks are located in the Bookmarks Toolbar folder.<br /> So you may need to move or copy bookmarks to this folder. I assume that you have confirmed that the "Bookmarks Toolbar items" is positioned on the Bookmarks Toolbar? This item is customizable and can be placed on toolbars other than the Bookmarks Toolbar.<br /> If this item is not on the Bookmarks Toolbar then you won't see any bookmarks and nor can you drag a tab onto the Bookmarks Toolbar to create a new bookmark or see the bookmarks context menu if you right-click the Bookmarks Toolbar.
the-edmeister
  • Top 25 Contributor
  • Moderator
5411 izisombululo 40301 izimpendulo
Kuphostiwe

The Bookmarks Toolbar is shown by default, and always has been - nothing has changed in regards to that.

Please open the Customize... toolbars palette and use the Restore Default Set button as cor-el mentioned.

The Bookmarks Toolbar is shown by default, and always has been - nothing has changed in regards to that. Please open the Customize... toolbars palette and use the '''Restore Default Set''' button as cor-el mentioned.

Umnikazi wombuzo

I am sure you are all beginning to think that you're dealing with a moron, and indeed that may well be the case. But I copied this Firefox Help:-

"Show or hide the Bookmarks toolbar The Bookmarks toolbar is hidden by default. "

'Hidden by default' That's a pretty clear statement, is it wrong?

View > Toolbars > Customize > Restore Default does nothing.

And this is from Cor-el:-

"You can only see bookmarks on the Bookmarks Toolbar if those bookmarks are located in the Bookmarks Toolbar folder. So you may need to move or copy bookmarks to this folder. and... "I assume that you have confirmed that the "Bookmarks Toolbar items" is positioned on the Bookmarks Toolbar?

So there is, or should be, a "Bookmark Toolbar", a "Bookmark Folder", and "Bookmark Items". I confess I have never heard of a "Bookmark Item" unless that is another term for a Bookmark. I have done a Windows search for a folder named "Bookmarks" and it does not appear to exist.

I am beginning to think that Internet Explorer isn't all that bad.

David

I am sure you are all beginning to think that you're dealing with a moron, and indeed that may well be the case. But I copied this Firefox Help:- "Show or hide the Bookmarks toolbar The Bookmarks toolbar is hidden by default. " 'Hidden by default' That's a pretty clear statement, is it wrong? View > Toolbars > Customize > Restore Default does nothing. And this is from Cor-el:- "You can only see bookmarks on the Bookmarks Toolbar if those bookmarks are located in the Bookmarks Toolbar folder. So you may need to move or copy bookmarks to this folder. and... "I assume that you have confirmed that the "Bookmarks Toolbar items" is positioned on the Bookmarks Toolbar? '' So there is, or should be, a "Bookmark Toolbar", a "Bookmark Folder", and "Bookmark Items". I confess I have never heard of a "Bookmark Item" unless that is another term for a Bookmark. I have done a Windows search for a folder named "Bookmarks" and it does not appear to exist. I am beginning to think that Internet Explorer isn't all that bad. David
bauerh 0 izisombululo 2 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Hey DavidAR,

You are not crazy and you're not alone. I lost the ability to see my bookmarks strung across the top of my screen back along about version 17 and have not been able to regain it except by working in Secure mode with all my addins turned off. Since that is pretty tough I instead live with having to pull the toolbar out of the left hand margin area (i.e. when you hit Control + B).

The answers you have been given almost sound like they think you lost the buttons for a toolbar instead of the bookmarks not displaying. If I have misunderstood your questions, please just ignore me and the rest of this with my apologies.

Yes, when I look at the "View", "Toolbars" , the Bookmark Toolbar is checked and yes I do have an extra horizontal row between my search window/button area and the open tabs area (I kept my tabs below instead of above). What I don't have in that horizontal area are my bookmark icons. It is as if they are invisible. Firefox thinks they are there but they are not.

Believe me I have looked many times for an answer but the solutions always seemed to be too extreme like editing my registry (no way!!) or seemed like I'd lose all my customization, passwords, logins, etc.

I am currently using Windows Vista, 32 bit, and Firefox 24. I have removed almost all my addins except for buttons and a google mail notifier, but still no go.

Good luck to you and if you find something that helps I'd be interested. I have subscribed to this question so I should see any possible solutions.

Hey DavidAR, You are not crazy and you're not alone. I lost the ability to see my bookmarks strung across the top of my screen back along about version 17 and have not been able to regain it except by working in Secure mode with all my addins turned off. Since that is pretty tough I instead live with having to pull the toolbar out of the left hand margin area (i.e. when you hit Control + B). The answers you have been given almost sound like they think you lost the buttons for a toolbar instead of the bookmarks not displaying. If I have misunderstood your questions, please just ignore me and the rest of this with my apologies. Yes, when I look at the "View", "Toolbars" , the Bookmark Toolbar is checked and yes I do have an extra horizontal row between my search window/button area and the open tabs area (I kept my tabs below instead of above). What I don't have in that horizontal area are my bookmark icons. It is as if they are invisible. Firefox thinks they are there but they are not. Believe me I have looked many times for an answer but the solutions always seemed to be too extreme like editing my registry (no way!!) or seemed like I'd lose all my customization, passwords, logins, etc. I am currently using Windows Vista, 32 bit, and Firefox 24. I have removed almost all my addins except for buttons and a google mail notifier, but still no go. Good luck to you and if you find something that helps I'd be interested. I have subscribed to this question so I should see any possible solutions.

Umnikazi wombuzo

Thank you for validating my question. I have the same version of Firefox on a Win 7 laptop, before that on XP, never had this problem. The new Win 8 machine just does not show the Bookmarks Toolbar, not even the blank space that you see, Period. I do not understand how someone can say it is shown by default, always has been, and yet the Help says it is not shown by default.

So I have come up with a solution, it's called Internet Explorer, and the Favorites bar DOES work.

David

Thank you for validating my question. I have the same version of Firefox on a Win 7 laptop, before that on XP, never had this problem. The new Win 8 machine just does not show the Bookmarks Toolbar, not even the blank space that you see, Period. I do not understand how someone can say it is shown by default, always has been, and yet the Help says it is ''not ''shown by default. So I have come up with a solution, it's called Internet Explorer, and the Favorites bar DOES work. David
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158974 izimpendulo
Kuphostiwe

If you open the Customize window then the bookmarks on the Bookmarks Toolbar collapse to a "Bookmarks Toolbar items" label. If this label text doesn't appear on the Bookmarks Toolbar then you won't have the bookmarks visible there as well and you can't drag links on the Bookmarks Toolbar. The Bookmarks Toolbar is known internally as the Personal Toolbar (id: #PersonalToolbar) and the "Bookmarks Toolbar items" have an id: #personal-bookmarks, but the "Bookmarks Toolbar items" can be positioned on any toolbar or can get lost and in that case two fixes are possible: using "Restore Default Set" or deleting localstore.rdf in case the first isn't working or if you otherwise want to reset everything.

See also:

If you open the Customize window then the bookmarks on the Bookmarks Toolbar collapse to a "Bookmarks Toolbar items" label. If this label text doesn't appear on the Bookmarks Toolbar then you won't have the bookmarks visible there as well and you can't drag links on the Bookmarks Toolbar. The Bookmarks Toolbar is known internally as the Personal Toolbar (id: #PersonalToolbar) and the "Bookmarks Toolbar items" have an id: #personal-bookmarks, but the "Bookmarks Toolbar items" can be positioned on any toolbar or can get lost and in that case two fixes are possible: using "Restore Default Set" or deleting localstore.rdf in case the first isn't working or if you otherwise want to reset everything. See also: *http://kb.mozillazine.org/Corrupt_localstore.rdf

Umnikazi wombuzo

Thank you for all your help. I have tried all the suggestions that you and others have made, but nothing has changed, Customize does nothing. Nothing at all. I am not a complete beginner, I've been using computers since DOS 3.0, and Firefox since the beginning. But something is wrong, I can't spend any more time trying to find out just what, so sadly I will use IE.

Thanks again for your help.

David

Thank you for all your help. I have tried all the suggestions that you and others have made, but nothing has changed, Customize does nothing. Nothing at all. I am not a complete beginner, I've been using computers since DOS 3.0, and Firefox since the beginning. But something is wrong, I can't spend any more time trying to find out just what, so sadly I will use IE. Thanks again for your help. David
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158974 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Try to delete the localstore.rdf file in the Firefox profile folder with Firefox closed.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Close Firefox before making changes to files in this folder.

After restarting Firefox you can make the Bookmarks Toolbar visible again.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the menu bar)
  • Right-click empty toolbar area

See also:

Try to delete the localstore.rdf file in the Firefox profile folder with Firefox closed. You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) Close Firefox before making changes to files in this folder. After restarting Firefox you can make the Bookmarks Toolbar visible again. *Firefox menu button > Options *View > Toolbars (press F10 to display the menu bar) *Right-click empty toolbar area See also: *http://kb.mozillazine.org/Corrupt_localstore.rdf

Okulungisiwe ngu cor-el

bauerh 0 izisombululo 2 izimpendulo
Kuphostiwe

Yippie, skippy -i-a, got my holiday present early. Deleting the localstore.rdf file did it. What an easy solution, can't thank you enough for taking the time to put this out for me. Really, I had given up ever seeing my bookmarks across the top of my browser window ever again.

Yippie, skippy -i-a, got my holiday present early. Deleting the localstore.rdf file did it. What an easy solution, can't thank you enough for taking the time to put this out for me. Really, I had given up ever seeing my bookmarks across the top of my browser window ever again.
cynholy 0 izisombululo 3 izimpendulo
Kuphostiwe

David,

I was having the same problem and just figured out a solution that works. Under Bookmarks click on Show All Bookmarks. Click on Bookmarks Menu on the sidebar. You should see a FOLDER called Bookmarks Toolbar. Copy all of the contents in that folder. Then go back up to the the first link under All Bookmarks which is Bookmarks Toolbar and paste them there. Hope it works for you!

David, I was having the same problem and just figured out a solution that works. Under Bookmarks click on Show All Bookmarks. Click on Bookmarks Menu on the sidebar. You should see a '''FOLDER''' called Bookmarks Toolbar. Copy all of the contents in that folder. Then go back up to the the first link under All Bookmarks which is Bookmarks Toolbar and paste them there. Hope it works for you!
cor-el
  • Top 10 Contributor
  • Moderator
17574 izisombululo 158974 izimpendulo
Kuphostiwe

Note that you can end up with a second Bookmarks Toolbar folder in the Bookmarks Menu folder if you have imported an HTML backup file.

Note that you can end up with a second Bookmarks Toolbar folder in the Bookmarks Menu folder if you have imported an HTML backup file. *http://kb.mozillazine.org/Backing_up_and_restoring_bookmarks_-_Firefox
Demetrius 0 izisombululo 6 izimpendulo
Kuphostiwe

My problem went something like this: The toolbar would not appear whenever I started Firefox. It would only show if I customized the toolbar and then exited the customization No changes required. Another way was to turn on the tool bar from "View->Toolbars->Bookmarks Toolbar". Unfortunately both those solutions lasted for as long as the Firefox session. The problem persisted when FIrefox was restarted. Not good enough!

The problem started when I upgraded from Firefox 20 to 21. So I just reverted back to 20.

Then I up graded to 22 when it was released. I stayed on 22 for a while. But when I tried 25 and then 26 I got the same problem. Time to investigate

I got 26 to work by disabling all my add-ons (Tools->Add ons->Extensions). Then I re-enabled them 1 by 1 (restarting Firefox each time) until the problem came back. I found it to be the "Default Zoom Level 5.8" extension. So I reinstalled it with the same version number and the problem was fixed permanently.

Solution: Find the faulty extension and update it - even with the same version

Hope this helps

My problem went something like this: The toolbar would not appear whenever I started Firefox. It would only show if I customized the toolbar and then exited the customization No changes required. Another way was to turn on the tool bar from "View->Toolbars->Bookmarks Toolbar". Unfortunately both those solutions lasted for as long as the Firefox session. The problem persisted when FIrefox was restarted. Not good enough! The problem started when I upgraded from Firefox 20 to 21. So I just reverted back to 20. Then I up graded to 22 when it was released. I stayed on 22 for a while. But when I tried 25 and then 26 I got the same problem. Time to investigate I got 26 to work by disabling all my add-ons (Tools->Add ons->Extensions). Then I re-enabled them 1 by 1 (restarting Firefox each time) until the problem came back. I found it to be the "Default Zoom Level 5.8" extension. So I reinstalled it with the same version number and the problem was fixed permanently. Solution: Find the faulty extension and update it - even with the same version Hope this helps
izzydoesit 0 izisombululo 2 izimpendulo
Kuphostiwe

Thanks so much for this, it was driving me nuts! Deleting the localstore.rdf file did the trick! I now have my bookmarks toolbar functioning again.

Thanks so much for this, it was driving me nuts! Deleting the localstore.rdf file did the trick! I now have my bookmarks toolbar functioning again.