X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The dreaded "an error occurred" message shows on *every* YouTube video

Kuphostiwe

For the past ... I really don't know how long now, most of the time I just gave up, but I'm finally fed up with it ... YouTube has been displaying "An error occurred, please try again later" on any video I try to play; embedded or on YouTube, it doesn't matter.

Safe mode does not resolve the problem.

The only way I can get it to work is by (1) using a separate, clean Firefox profile (-no-remote -profile "x:\path\to\clean\profile"), (2) trying a different browser or (3) completely resetting Firefox (I manually backed up my main profile directory before doing this).

But: copy pasting the URL into a different profile or browser for every video is a pain in the arse and resetting Firefox is not an acceptable solution. I have a ton of customized extensions that would take hours to reconfigure. And, as I mentioned, safe mode (ie.: disabling the extensions) does not fix the problem.

Has anyone actually got to the root cause of this ridiculous error?

For the past ... I really don't know how long now, most of the time I just gave up, but I'm finally fed up with it ... YouTube has been displaying "An error occurred, please try again later" on any video I try to play; embedded or on YouTube, it doesn't matter. Safe mode does not resolve the problem. The only way I can get it to work is by (1) using a separate, clean Firefox profile (-no-remote -profile "x:\path\to\clean\profile"), (2) trying a different browser or (3) completely resetting Firefox (I manually backed up my main profile directory before doing this). But: copy pasting the URL into a different profile or browser for every video is a pain in the arse and resetting Firefox is not an acceptable solution. I have a ton of customized extensions that would take hours to reconfigure. And, as I mentioned, safe mode (ie.: disabling the extensions) does not fix the problem. Has anyone actually got to the root cause of this ridiculous error?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • VLC media player Web Plugin 2.0.6
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Eminye Imininingwane

Firefox 24.0 / Windows 7 x64 SP1 / Flash Player 11.9.900.117

Wesley Branton
  • Top 10 Contributor
573 izisombululo 4884 izimpendulo
Kuphostiwe

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Please check if all your plugins are up-to-date. To do this, go to the [http://mozilla.com/plugincheck Mozilla Plugin Check site]. Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow ''Update'' button or a red ''Update now'' button, please update these immediately. To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.
Wesley Branton
  • Top 10 Contributor
573 izisombululo 4884 izimpendulo
Kuphostiwe

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back soon.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back soon.

Umnikazi wombuzo

@ComputerWhiz: checked my plugins, everything's up to date.

Disabled hardware acceleration in both Firefox and Flash options dialogs, no dice.

I doubt it's a driver-related issue as YouTube videos play without error in a different profile or browser.

@ComputerWhiz: checked my plugins, everything's up to date. Disabled hardware acceleration in both Firefox and Flash options dialogs, no dice. I doubt it's a driver-related issue as YouTube videos play without error in a different profile or browser.
Wesley Branton
  • Top 10 Contributor
573 izisombululo 4884 izimpendulo
Kuphostiwe

When you say: "...YouTube videos play without error in a different profile or browser." Do you mean a different Firefox profile on that computer or a different Windows user on that computer?

When you say: "...YouTube videos play without error in a different profile or browser." Do you mean a different Firefox profile on that computer or a different Windows user on that computer?

Umnikazi wombuzo

Sorry, I should have been more clear.

On the same computer, I can play YouTube videos without error using IE or a different (clean) Firefox profile.

Sorry, I should have been more clear. On the same computer, I can play YouTube videos without error using IE or a different (clean) Firefox profile.
Wesley Branton
  • Top 10 Contributor
573 izisombululo 4884 izimpendulo
Kuphostiwe

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back soon.


I'm afraid that this is all that I can help you with tonight. We will resume tomorrow.
Sorry for any inconvenience.

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article. Did this fix your problems? Please report back soon. ---------------- I'm afraid that this is all that I can help you with tonight. We will resume tomorrow.<br> Sorry for any inconvenience.

Umnikazi wombuzo

Nope, cleared absolutely everything, still doesn't work.

Nope, cleared absolutely everything, still doesn't work.

Umnikazi wombuzo

Well, I can tell you this much: it has something to do with configuration.

I restored prefs.js from a clean Firefox profile to my regular profile and YouTube worked. Exactly what configuration variable made the difference, though, I have no idea.

Does anyone have some ideas to point me in the right direction?

Well, I can tell you this much: it has something to do with configuration. I restored prefs.js from a clean Firefox profile to my regular profile and YouTube worked. Exactly what configuration variable made the difference, though, I have no idea. Does anyone have some ideas to point me in the right direction?

Impendulo Ewusizo

OK, now I'm getting somewhere...

I disabled youtube.com in the HTTPS Everywhere rules and I can watch YouTube videos in this Firefox profile as long as it's not over SSL.

Would still like to know why it doesn't with with HTTPS though...

OK, now I'm getting somewhere... I disabled youtube.com in the HTTPS Everywhere rules and I can watch YouTube videos in this Firefox profile as long as it's not over SSL. Would still like to know why it doesn't with with HTTPS though...
bobsleftnut 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

This had been happening to me too for ages and nothing made a difference... until I read a few lines on a forum somewhere that solved it in an instant...

YT started using Dynamic Adaptive Streaming over HTTP (dash) a few years ago and this is what's causing the problems. You can download a script called Youtube Center that allows you to turn off dash : https://github.com/YePpHa/YouTubeCenter/wiki

Or, as I found, you can simply plug in a set of headphones into your pc (or use a set of speakers) and that ever present and hugely annoying "an error occurred" message will be gone from your life forever.

-)
This had been happening to me too for ages and nothing made a difference... until I read a few lines on a forum somewhere that solved it in an instant... YT started using Dynamic Adaptive Streaming over HTTP (dash) a few years ago and this is what's causing the problems. You can download a script called Youtube Center that allows you to turn off dash : https://github.com/YePpHa/YouTubeCenter/wiki Or, as I found, you can simply plug in a set of headphones into your pc (or use a set of speakers) and that ever present and hugely annoying "an error occurred" message will be gone from your life forever. ;-)
Wesley Branton
  • Top 10 Contributor
573 izisombululo 4884 izimpendulo
Kuphostiwe

Are you running the computer as an administrator?
Do you own your internet connection or are you connection, via WiFi to a network?

Some networks/computers have a filter that can disable YouTube videos.
This mostly occurs on school computers.
If you are not the computer/network administrator, please contact them and report your problem.

Are you running the computer as an administrator?<br> Do you own your internet connection or are you connection, via WiFi to a network? Some networks/computers have a filter that can disable YouTube videos.<br> This mostly occurs on school computers.<br> If you are not the computer/network administrator, please contact them and report your problem.
nocturn444 0 izisombululo 4 izimpendulo
Kuphostiwe

Yes Sir You Da Man bobsleftnut ! I Downloaded the YouTubeCenter add-on for Firefox and there I go !!! F*ck Dash !!!

Directly is there : https://addons.mozilla.org/en-us/firefox/addon/youtube-center/

Disable Dash and Disable SPF too, it helped me.

Yes Sir You Da Man bobsleftnut ! I Downloaded the YouTubeCenter add-on for Firefox and there I go !!! F*ck Dash !!! Directly is there : https://addons.mozilla.org/en-us/firefox/addon/youtube-center/ Disable Dash and Disable SPF too, it helped me.

Okulungisiwe ngu nocturn444