Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Selectively usage of Java Runtime Environment per site.

  • 3 uphendule
  • 36 zinale nkinga
  • 4492 views
  • Igcine ukuphendulwa ngu cor-el

more options

Dear Sir's. I'm working as an IT support for a company. We use the latest (until updated) Mozilla Firefox 24.0 in order to run the financial program of our company. This requires Java Runtime Environment 1.6.0.25 in order to run.

The problem starts when a user needs to access another site and this site requires Java Runtime Environment 1.7.0.45. As an example: The users log in a banks site to make money transfers to another bank site. The site asks them to use Java Runtime Environment 1.7.0.45 and won't let you complete the transaction unless you have the latest JRE.

I would like to know if there is a way to install both Runtime Environments and selectively use what you need for each site. The point is Using ALWAYS and for ALL sites the latest Java Runtime Enviroment. But for some specific sites (like internal one's or whatever) to have the option of choosing which Runtime to use for a site. Somehow to edit something in the about:config and make something like : If you see the address bar containing "a specific word, or Ip address, of the site" use the jre_1.6.0.25 ONLY. Of course one thing that needs to be changed, is in the about:config to make the extensions.blocklist.enable --> false

Please everyone. Is there a way to make this applicable? Any help will be greatly appreciated !

P.S. Just to answer to a question the is already in your minds. No the internal financial program/site cannot use Jre_1.7.0.45 and nothing above 1.6.0.25. The reasons i could give if asked, but i guess it's not important.

Please help !!!

All Replies (3)

more options

hello Mcasim, if and how it is possible to install two versions of java on a computer is rather a question for java's support and beyond the scope of this forum.

if you manage to install two versions somehow, it should be possible to achieve the rest in firefox. go to firefox > addons > plugins and set the older one to "never activate" and the newer one to "always ask". then on site of your financial program, right-click somewhere on the page, go to view page info > permissions, where you can disable java 7 and enable java 6 for this page only...

more options

Hello Phillip and Thank you very much for your answer. It was very helpfull indeed :)

But again i have to spoil your time ... If i go to Tools--> Add Ons --> Plugins i see only Java (TM) Platform SE7 U45 10.45.2.18 The previous ones are gone.

In my Control Panel --> Java --> java tab --> View I see the 1.6.0_02 1.6.0_25 1.7.0_25 1.7.0_45

Any way that i can bring back/add to the Mozilla Tools--> Add Ons --> Plugins the Plugins that are missing. I have tried going to Tools-->Addons --> plugins and click on the wrench (left to the Search all add-ons) and tried to install Addon from file. I clicked the Files of Type -->>All files Then i went to C:\program Files\java\jre6\bin\new_plugin\ npjp2.dll pressed open but an error cames up saing "This add on could not be installed because it appears to be corrupt"

How could it be possible to allow both 6.0.25 and the latest one to exist in the plugins container ??? :) :D I think this might solve the problem :)

And thank you once more for your time !

Okulungisiwe ngu Mcasim

more options