Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why won't Firefox let me access Google when it is in the tool bar anyway?

  • 49 uphendule
  • 25 zinale nkinga
  • Igcine ukuphendulwa ngu chriskeys

more options

I set the browser to open at Google and at first, I had no problem, but now Firefox is blocking me accessing the site, saying it is unsafe and will cause harm to my computer. I have used this site for years and had no problem, so why is this happening, please. Chris Keys

Isisombululo esikhethiwe

Hi jscher and cor-el - the problem with Firefox has now been solved. My son who looks after the schools computers visited yesterday and said that BrowserSafe was something that had probably attached itself to something I had downloaded. He has uninstalled it and now everything works perfectly.

I checked again with the shop this morning and they said I had been misinformed last time I rang them and that they don't install BrowserSafe, only Bullguard, so if I had been told that in the first place, we might have got there sooner. Nevertheless, all is well now and thank you very much for your assistance. It was very comprehensive and you were both very patient. Kind regards Chris

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (20)

more options

What antivirus / firewall you are using?

more options

Hi - It's Firefox that is saying Google is an unsafe site. I can access other websites via Firefox, just not Google, which is featured on the Firefox browser. This has only happened within the last week or so. It was fine before that.

more options

You don't answer to my question.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.


Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Okulungisiwe ngu user693271

more options

Hi Chris, which warning are you getting? Firefox uses a service from Google to provide the warning screen with the red box. When Firefox says the security certificate is not valid, it is checking that itself.

If you are getting an invalid certificate error, can you expand the "technical details" section and post what Firefox is saying about the certificate?

Regarding your home page, can you check the URL and make sure you use a "complete" URL such as

If you use a partial URL, then Firefox will need to redirect, which is a waste of time and bandwidth, as well as possibly creating a redirect warning in some cases.

This article shows the location in the dialogs: How to set the home page

more options

Thank you for coming back to me. The warning I am getting is as beneath my reply. It is surrounded by an orange box, rather than red. When I downloaded Firefox, it already had Google as the search engine and I had been using it without problem for a week or so then, suddenly, got this message. I contacted the place where I bought the computer and the technicians hadn't heard of this happening before!!

Thanks again for your response. Chris


This Connection is Untrusted

You have asked Firefox to connect securely to, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified. What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.

more options

Thanks, Chris. The next section of the page is called Technical Details and can be expanded by clicking either the triangle to the left of it or those words. Here Firefox should explain why the certificate is not passing muster. What does that part say?

more options

Hi and thanks for coming back to me. The Technical Details part is as follows: uses an invalid security certificate. The certificate is not trusted because no issuer chain was provided. (Error code: sec_error_unknown_issuer)

Kind regards Chris

more options

Hi Chris, if you have never seen that error before, the issuer chain is what connects the site's SSL certificate with a globally trusted certificate. Typically one or more "intermediate" certificates are involved and the server needs to send those to the browser. Novice webmasters sometimes forget, but with Google, that seems unlikely. We should consider other possibilities.

(1) Cache mismatch

You can clear Firefox's cache of previously retrieved pages (not history but the files themselves) using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes. When you revisit Google, Firefox should retrieve all the files fresh and hopefully this will clear up the issue.

(2) DNS hijack

Firefox usually relies on Windows to look up the true internet addresses of servers, but this can be overridden by a proxy setting or by an extension, and you might do this if you have signed up with a private VPN service (for anonymous browsing) or are using a TOR add-on.

(A) Proxy setting

You can review/modify your setting here:

orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > Settings button

The default setting is "Use system proxy settings" which should cause Firefox to use the same connection settings as IE.

(B) Extensions

You can review, configure, disable, and often remove extensions here:

orange Firefox button (or Tools menu) > Add-ons > in the left column click Extensions

Any that specifically target Google, such as privacy-related extensions, would be worth checking and possibly disabling.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

(C) External software

Other software on your computer can change how Windows finds site, including malware. If you are inclined to run a few supplemental scans, this support article recommends some free tools for that: Troubleshoot Firefox issues caused by malware.

(D) Router settings

Often your DNS servers are actually set in your router, either one supplied by your internet service provider or one you've added on yourself to share your connection locally. If you find that you have the same problem in IE, then this definitely is worth checking.

more options

Hi Chris, so far we've only discussed Google, but if you notice this problem with lots of secure sites, that could be a different issue. For example, one of the features of the ESET and BitDefender security suites is the ability to "filter" your web traffic. For secure sites, this requires intercepting the traffic and decrypting/re-encrypting it. You can disable this feature so your secure connections are directly with the site, or you can coax Firefox to let your software be the man in the middle. Let us know if this sounds relevant.

more options

Can you check who is the issuer of this certificate?

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer of the certificate.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

more options

Okay, the certificate signature is Algorithm - It is Version 3 - serial No is 70:DA:CF:17:D7:F5:8B:BE:48:E8:22:46:18:0D:10:02 - Issuer is FiddlerRoot - does that help?

more options

You're using the Fiddler proxy from

I see steps for Windows (meaning, I think, IE) here: However, extra steps might be required for Firefox.

more options

Thank you for all the info. I will have to read and absorb tomorrow properly and take things step by step. It is kind of you to look into all this for me. Will be in touch when I have tried a few things you have suggested. Thanks again. Chris

more options

jscher - many thanks for your detailed solutions. When I went to clear the cache, there was 0% there (this is a new computer - approx 2 weeks). The system proxy setting is already set to default.

Regarding the Extensions, the only two that appeared in there were Bullguard, the security I have on here at the moment and a tool bar for a craft site I use. The Bullguard was disabled and I disabled the craft site and restarted and there was the same message, so obviously that wasn't causing the problem.

Regarding External Software any malware should have been stopped by Bullguard, but I will runs some scans to check that out.

With regard to router settings, if I was getting no problem at first with Firefox and haven't had anything changed on the router since I started using Firefox, could this still have caused a problem.

Sorry to be dim, but what is "IE" ?

Thanks again for all your help.

Kind regards Chris

more options

IE = Internet Explorer

more options

Doh!!! Thanks.

more options

Hi Chris, does the problem only occur when you are running Fiddler? Are you intentionally running the Fiddler program?

more options

Yes, it does seem to be just Google that is the problem. I had no idea it was running the Fiddler program until I followed instructions to find out. There is no problem with Google on IE.

more options

Hi Chris, Fiddler is a program used by web developers that runs on Windows outside of Firefox. It allows a developer to capture and record all web browser traffic to help resolve connection and display problems. However, if you are not doing that intentionally, this could indicate a privacy problem on your computer.

Could you check the Windows Task Manager for Fiddler.exe. To open the Task Manager, press Ctrl+Shift+Esc. Then click the Processes tab. If Fiddler.exe does not appear on the initial list, try expanding the list using the button at the bottom to show processes from all users. Is it there anywhere??

I should add that occasionally weird/inexplicable issues can be resolved by shutting down and restarting Windows, so if you haven't done that since this problem began, it might be something to consider.

more options

Hi - I have just checked the taskbar and there is no mention of fiddler.exe in the list, nor the expanded list. When you say shut Windows down, do you mean turn the computer on and off or something else? If the former, I turn the computer off every night and restart again in the morning.

Once again thank you for your really clear and easy to follow instructions. Chris

  1. 1
  2. 2
  3. 3