Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

google translate

  • 41 uphendule
  • 9 zinale nkinga
  • 355 views
  • Igcine ukuphendulwa ngu cor-el

more options

Google Translate stopped working in Firefox 23.0.1.

I can type into the translate panel, but when I push the translate button, nothing happens.

Isisombululo esikhethiwe

All Replies (20)

more options

Thanks to everyone for your help.

Yes, the button issue for google translation seems to be a Firefox issue. But aren't they interested in fixing it???

more options

updated to Firefox 24.0, still have the same issue

more options

Yes, me too.

I doubt if we are the only two in the world with this problem and am surprised that Firefox hasn't gotten on to it.

For now, thanks to the advice of someone on this thread, I'm using the Addon, ImTranslator, which is working fine.

But of course, who knows what else is not working in the latest version of Firefox

more options

I don't know why the blue button isn't working. If you inject another submit button into the form, the form submits without a problem. There appears to be an event handler attached to the blue button which is preventing the form from being submitted. Because Google applications tend to be complex, this might be very time-consuming to chase down. I assume (?!) someone has reported this problem to Google?

This was my test button. Open the web console using Ctrl+Shift+k, then paste the following long line of script next to the caret (>) and press Enter to run it.

var cdiv=document.getElementById("gt-langs"); var s=document.createElement("input"); s.type="submit"; s.value="Submit"; cdiv.appendChild(s);

For now, I'm going back to instant translation.

more options

I think google blocked the google translation from Firefox or IE users. I can't get it work on either browser. What I got is the promotion to install Chrome. The instant translation is also not working. It just show "Translating..."

Okulungisiwe ngu JJ121

more options

Or replace the exiting button.

var csub=document.getElementById("gt-submit"); var s=document.createElement("input"); s.type="submit"; s.value="Submit"; csub.parentNode.replaceChild(s,csub);
more options

There is now a Greasemonkey UserScript that fixes this issue:

http://userscripts.org/scripts/show/178431

more options

Enabled Greasemonkey and this script and nothing changed- still doesn't work.

Thanks for trying!

more options

I am start to use different translation tool like imTranslator. It's not as good as google translator but it works.

more options

That's exactly what I am doing.

It seems Google has blocked translator from Firefox because they want all of us to use Chrome.

Will they eventually shut down gmail from firefox for this reason??

more options

That's not good.

Now it does sound like something is messed up with your Firefox installation and/or profile and/or maybe your operating system.

You could try installing Portable Firefox and see if that works. If it doesn't, install Greasemonkey and the UserScript for it to see if that works.

I'm using Win 7 Home Premium 64bit (SP1).

      • What's your OS?

Also, if you can do fairly simple JavaScript, you could use JavaScript Shell as a BOOKMARKLET and execute the code in the UserScript (or the last example above) and see what results you're getting.

http://www.squarefree.com/shell/

At this point, something is SO WRONG with your "computer" (?), it's not a simple thing to diagnose remotely. You need to take it in somewhere and let someone who knows what they're doing look at it, or find a friend who knows a lot about computers and can help you with it.

more options

Hi OldManRivuh, does the blue button work for you if you turn off instant translation? Since Google is constantly tinkering with its UI, it's possible that different users could get different results...

Edit: I didn't realize you were referring to a problem running the userscript. Please see my reply below about issues with the HTTPS page (need another @include).

Okulungisiwe ngu jscher2000

more options

That what I thought initially. I have three computers. Two of them are running win7 one of them run xp. The xp machine with me for years. None of them is working now. I got a yellow text box said "Try a new browser with automatic translation. Donwload Google Chrome" on top of the Translate button.

more options

Hi stu2929, if you use a secure connection for translation (HTTPS) you need to add that domain to the script so it runs on the secure version. You can do that immediately in the options (add your own included site URL) or wait for the author to update it.

more options

I just modified the script to load for https: too. You should click on the Greasemonkey drop-down arrow and make sure the script is being loaded and run for that page.

I do already have instant translation turned off, which is why I need the button to work.

I didn't try to turn instant translation back on. But people have said that that will also "fix the problem".

I did just notice that my "fix" seems to make the drop-down boxes not work in the "pretty" way that they normally do, and they turn into standard drop-down boxes, and the "Exchange" languages button also does not work.

I think part of the problem is that they are using a lot of fancy code to make the interface "cool", and that can cause issues. Especially if it's not done "correctly".

I've also had the on-screen keyboard (for Russian) quit working, as well, and had a hard time getting it to start working again.

Basically, the page just has some MAJOR issues and someone isn't doing a good enough job their with cross-browser development and testing and quality control.

It's probably one of those "well, it works for me, so it must be you", issues that programmers and developers who are not quite up to snuff sometimes erroneously fall back on.

I may or may not work more on it. Actually getting in there and looking at their crapped-up code and trying to figure out what they're doing and fix their BS is not easy. Hopefully they will get their act together and fix it sometime when enough people complain.

I'm not paranoid enough to thing that "they" are trying to 'force' people to convert to Google Chrome. No one in their right mind is going to do that, anyway, because GC is FAR from "being there" at this point. Although Firefox is starting to irritate me, and I would change to another browser if there was a decent one available.

Okulungisiwe ngu OldManRivuh

more options

I use this script with the Scriptish extension:

// ==UserScript==
// @id             google-translate
// @name           Fix Firefox Google Translate Button
// @version        1.0
// @namespace      https://support.mozilla.org
// @author         cor-el
// @description    Replaces broken Translate submit button
// @include        http*://translate.google.com/*
// @run-at         document-end
// ==/UserScript==

var csub=document.getElementById("gt-submit");
var s=document.createElement("input");
s.type="submit"; 
s.value="Translate";
s.className="jfk-button jfk-button-action"; 
csub.parentNode.replaceChild(s,csub);

Okulungisiwe ngu cor-el

more options

I didn't do anything but it's working now. I think google translate just blocked it and then reopen it from Firefox and IE user.

more options

I didn't do anything but it's working now. I think google translate just blocked it and then reopen it from Firefox and IE user.

more options

Isisombululo Esikhethiwe

Work again for me too

more options

Well, this turned out to be "much ado about almost nothing". Just took a few days for someone at either Google, Microsoft and/or Mozilla to get things back the way they should be.

Thanks for all the help form everybody along the way. I learned a lot of good things for the next time something like this may happen!

  1. 1
  2. 2
  3. 3