Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cursor will not stay in address bar even once I've started typing

  • 2 uphendule
  • 2 zinale nkinga
  • 714 views
  • Igcine ukuphendulwa ngu jb84

more options

When I initially start FF I am able to click into the address bar and type a URL without problem. A few minutes later if I open a new tab or try and click into the url bar, the cursor jumps to any available text box on the page and refuses to stay in the url bar. Sometimes I manage to write the first letter in the bar then the cursor immediately jumps, and continues to happen each time I click back into the bar, so I can never type anything in it. The problem is solved if I restart FF but then starts again at soon after. I've tried disabling all my add-ons/extensions but this hasn't worked. I'm using FF 12 on a MacBook Pro. Any help appreciated, thanks.

All Replies (2)

more options

Any new tab (e.g., Ctrl+clicking a link), or a new tab containing your new tab page (e.g., Ctrtl+t)?

There have been many threads about where the cursor should be after opening a new tab to the new tab page. Many users complained that after Firefox 17, instead of the cursor moving to the Google search box, it stayed in the address bar (e.g., Cursor focus is changed to address bar instead of google search box on new tabs in FF 17). Recently a user complained about the opposite starting in Firefox 23 (Firefox update 23.0.1, no longer automatically highlights the address bar content when I open a new tab).

One complication is that "new tab" add-ons often have a feature to change Firefox's normal behavior and it's easy to forget about them and sometimes difficult to understand the description. In NewTabURL, look at the last checkbox in its options dialog.

I could go on, but if you could clarify the scenario a bit more, I think that would be more efficient.

more options

I've now checked the last checkbox in the NewTabURL options and that's worked! The cursor now actually stays in the address bar so I can type instead of jumping to the body of the page and refusing to stay in the address bar. Thanks very much!