Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't view a website, issue related to mixed content blocking

  • 5 uphendule
  • 3 zinale nkinga
  • 42 views
  • Igcine ukuphendulwa ngu sr_holmes2

more options

Hello,

I am having trouble viewing the website below in Firefox. This is Basic Talk, which is basically internet phone service, similar to Vonage. But it's cheaper and sold at Walmart. Was wondering why I could pull up their website just fine on my cell phone, but couldn't get it up on Firefox (or IE for that manner). In order to set up my account with them, I had to do it completely online via my cell phone. But after doing some research I came across some info in the Firefox Bugzilla support forums. And it appears this issue is related to the "Mixed Content Blocking" issues. I've tried viewing the site via "http" and "https" and neither way works in Firefox. But again, via my cellphone, just fine. If you all could please look into this and provide me further details with how I can view and access this site. I would greatly appreciate it.

https://www.basictalk.com

Thanks

Shirley

All Replies (5)

more options

You are using an extremely out-dated version of Firefox. Please update as soon as possible to the most recent version of Firefox.

This will most likely solve your issue.

more options

Beyond using an old version of Firefox (3.6.27), your user agent is corrupted by something from Comcast / Xfinity (XF_mmhpset) and your UA shows an even older version of Firefox (3.5.17) is being used. So updating Firefox may not completely solve your issue.


http://en.wikipedia.org/wiki/User_Agent

type about:config in the URL bar and hit Enter
If you see the warning, you can confirm that you want to access that page.
Filter = general.useragent.
Right-click the preferences that are bold, one line at a time, and select Reset.
Then restart Firefox

more options

Ways to fix MCB problems.

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: Mixed content blocking in Firefox

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.
    Disable protection

To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:

security.mixed_content.block_active_content

You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

more options

Firefox 3 versions do not have mixed content blocking features, so if this happens with the 3.6.27 version that shows in the System Details List and also in other browsers like IE then something else is wrong.

You can try to reset (power off/on) the router.

more options

I've updated my version of Firefox to the 23.0.1 version, but still can't get anything to come up. I can get a "cached" version of the page to come up, but that's it. And it's not giving me a option to "block or disable blocking" of secure pages.