Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox won't ask to save tabs on quit.

  • 5 uphendule
  • 50 zinale nkinga
  • 22133 views
  • Igcine ukuphendulwa ngu cor-el

more options

Whenever I close Firefox, I'm not given the dialogue to save my tabs. I've tried opening about:config and setting browser.showQuitWarning to true, and it still isn't working.

All Replies (5)

more options

hello SGainor, firefox should save your tabs automatically whenever you close the session.

more options

Hello, if you set to show windows and tabs from last session in Firefox button > options > options > general > startup > When Firefox starts > Show my windows and tabs from last time, then the warning not shown , because tabs/windows will be restored at startup anyway.


thank you

more options

The asking was an old feature. Now they are normally saved anyhow.

You wil be able to get them by using the startup option ideato describes. You my also look in your History. You should have a restore previous session unless it has already been used.

If you wish to save information do not use Private Browsing,or options to delete History.

more options

It's really inconsistent though. Sometimes it saves them, and other times, I just get my homepage tabs.

more options

Make sure that Firefox closes properly.

  • Use "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit) to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

See also: