Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

On Fox News site some images do not load, others do.

  • 2 uphendule
  • 7 zinale nkinga
  • 1100 views
  • Igcine ukuphendulwa ngu cor-el

more options

It appears that the gif images are not loading but other formats such as jpg are fine.

Isisombululo esikhethiwe

If images are missing then check that you aren't blocking images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
  • Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"
  • Check "Tools > Page Info > Media" for blocked images
  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

I just loaded version 23.0 Initially they did load but on restart they (gif images) are no longer visible.

more options

Isisombululo Esikhethiwe

If images are missing then check that you aren't blocking images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
  • Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"
  • Check "Tools > Page Info > Media" for blocked images
  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Firefox > Preferences > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also: