Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why does Firefox 23 keeps freezing briefly all the time?

  • 10 uphendule
  • 108 zinale nkinga
  • 21204 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Firefox suddenly started freezing briefly for something like 3 seconds all the time when it updated to 23. It does it something like every 10 seconds. How do I stop the really annoying brief freezing?

Isisombululo esikhethiwe

I found that the Skype Click to Call add-on was causing the freezing. The only reason updating to 24 stopped the freezing is because the add-on wasn't compatible. It started freezing again as soon as it became compatible so disabing the add-on solved the problem.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 5

All Replies (10)

more options

We are sorry to here that Firefox is freezing.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • Open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back soon.

more options

I couldn't find what was causing the freezing so I updated it to 24 beta and the freezing seems to have stopped. There seems to be some bug in 23 that was causing the freezing.

more options

For now you can see if disabling HWA in firefox 23 helps.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

more options

I had already tried disabling HWA before updating to 24 beta but it didn't make any difference. Still kept freezing. At least the problem appears to be fixed in 24 beta. I haven't yet had any more regular freezing problems after updating.

more options

Just a note for anyone who hasn't solved this problem: recurring freezing also has been attributed to:

(1) frequent session saves (it's possible to switch this from every 15 seconds to every minute); and

(2) certain Logitech pointing devices when using Microsoft drivers instead of Logitech drivers.

more options

FTR, I still have this problem with FF 24, most particularly on an old XP system; every day, I have to come in and kill the running browser, which becomes completely non-responsive. On starting a new one, after a couple of hours, the program exhibits intermittent unresponsiveness, getting worse and worse over time.

more options

Hi wsadkin, I think you might have a different issue, for example, memory usage increasing over time, or problems related to particular website content that causes Firefox to use increasing resources for scripts or plugins, or problems with an extension. It might be best to start a new question:

You need to scroll down past the suggestions to continue the process and get to the page where you enter the details.

more options

Isisombululo Esikhethiwe

I found that the Skype Click to Call add-on was causing the freezing. The only reason updating to 24 stopped the freezing is because the add-on wasn't compatible. It started freezing again as soon as it became compatible so disabing the add-on solved the problem.

more options

jscher2000 - what is/are "(1) frequent session saves" ?

more options

Hi petesimon, Firefox saves information about your current windows/tabs every 15 seconds. This information is used to restore your session if Firefox crashes (or if you have Firefox set to restore your last session when you start up). Please see this thread for more information: Freezing for a few seconds after switching tabs, freezing for a second without doing anything.