X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Ver 23 is not displaying CSS

Kuphostiwe

I just installed Firefox ver. 23 on both my Mac and PC and now CSS is not rendering on webpages. I have verified that "Allow pages to choose their own colors, instead of my selections above" is selected and CSS is not disabled. It was working find in ver. 22.

I just installed Firefox ver. 23 on both my Mac and PC and now CSS is not rendering on webpages. I have verified that "Allow pages to choose their own colors, instead of my selections above" is selected and CSS is not disabled. It was working find in ver. 22.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Version 4.4.2.14502
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Shockwave Flash 11.7 r700
  • Simple plug-in that handles Citrix connection files
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Office Live Update v1.0
  • WebEx64 General Plugin Container Version 205
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8
  • Juniper Networks Safari Extensions
  • npmnqmp 071706000001
  • Testgen plugin
  • iPhoto6
  • RealPlayer Plugin

Isisebenziso

  • Firefox 23.0
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0
  • I-URL Yokweseka: http://support.mozilla.org/1/firefox/23.0/Darwin/en-US/

Izandiso

  • ColorZilla 2.8.1 ({6AC85730-7D0F-4de0-B3FA-21142DD85326})
  • Fangs 1.0.8 ({21D01944-2878-4eb3-A72A-83E8D1E6D4A6})
  • HTML5 Notifications 1.2.2 (html5notifications@paxal.net)
  • Omnibar 0.7.19.20130418 (omnibar@ajitk.com)
  • Snagit Autoscroll Helper 1.95 (autoscrollhelper@techsmith.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WAVE Toolbar 1.1.8 (wavetoolbar@webaim.org)
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Akusebenzi)
  • Adobe Contribute Toolbar 6.1 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Akusebenzi)
  • CLC-4-TTS 3.6 ({7529D455-3392-4a17-A489-0C737D1DBAC0}) (Akusebenzi)
  • CLC-FireVox 6.1 ({054E9BDD-6287-44da-B3B3-B5D3D24407C0}) (Akusebenzi)
  • CLC-Utilities 4.5 ({C12D2FDC-2ECA-42a5-BA3C-DB93E0E8B70A}) (Akusebenzi)
  • Firefox PDF Plugin for Mac OS X 1.1.3 (colesbury@gmail.com) (Akusebenzi)
  • WeatherBug 2.0.0.4 ({3EC9C995-8072-4fc0-953E-4F30620D17F3}) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription:
  • adapterDeviceID: 0x fd5
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 2
  • numTotalWindows: 3
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1000
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.history_expire_days.mirror: 180
  • browser.places.importDefaults: False
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.startup.homepage: https://ccco.desire2learn.com/
  • browser.startup.homepage_override.buildID: 20130730113002
  • browser.startup.homepage_override.mstone: 23.0
  • browser.tabs.warnOnClose: False
  • dom.disable_open_during_load: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0
  • font.internaluseonly.changed: True
  • gfx.blacklist.webgl.msaa: 4
  • javascript.options.strict: True
  • network.cookie.prefsMigrated: True
  • network.image.imageBehavior: 0
  • places.database.lastMaintenance: 1376579966
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 161061272
  • places.last_vacuum: 1326138792
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.adobepdfviewernpapi: 0
  • plugin.state.scorch: 0
  • plugin.state.silverlight: 0
  • privacy.item.cache: False
  • privacy.item.downloads: False
  • privacy.item.formdata: False
  • privacy.item.history: False
  • privacy.item.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1376066728

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158596 izimpendulo
Kuphostiwe

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

See also:

Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot. ----- Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings. *http://support.apple.com/kb/HT1343#odd10 See also: *http://kb.mozillazine.org/Website_colors_are_wrong *http://kb.mozillazine.org/Websites_look_wrong
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Umnikazi wombuzo

Starting in Safe Mode did not help. The CSS is still not showing.

Starting in Safe Mode did not help. The CSS is still not showing.

Umnikazi wombuzo

I have tried all of the suggestions you listed. High Contrast is not enabled, it's set to allow pages to choose own colors, etc. I also made sure the CSS was validated for W3C. I did not have this problem in ver 22, it happened when a number of us updated to ver 23. We are seeing it on all computers that updated to ver 23. It is happening on both Mac and PC.

I have tried all of the suggestions you listed. High Contrast is not enabled, it's set to allow pages to choose own colors, etc. I also made sure the CSS was validated for W3C. I did not have this problem in ver 22, it happened when a number of us updated to ver 23. We are seeing it on all computers that updated to ver 23. It is happening on both Mac and PC.
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158596 izimpendulo
Kuphostiwe

Is this via a secure https connection?

If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked.


These prefs are used to control this behavior:

  • security.mixed_content.block_active_content
  • security.mixed_content.block_display_content
Is this via a secure https connection? If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked. *https://support.mozilla.org/kb/how-does-content-isnt-secure-affect-my-safety *https://developer.mozilla.org/en/Security/MixedContent ---- These prefs are used to control this behavior: *security.mixed_content.block_active_content *security.mixed_content.block_display_content *http://kb.mozillazine.org/about:config
rats 1 izisombululo 16 izimpendulo
Kuphostiwe

Firefox 26 OS X10.9.1

After browsing a few minutes, FF seems to forget to load CSS from several pages. This keeps happening. I delete the cache, page is back to normal, wait 2 min, start from top. Am I the only one or is this known? http://cl.ly/image/1G1V2G2w1x03

This is not on https as well as http.

Should I be posting this in a new thread? This looks like a serious issue since 33 other people claim to have the exact same problem.

Here's an UNCONFIRMED ticket from 2010describing the same behavior on Windows7 so issue seems to be cross-platform: https://bugzilla.mozilla.org/show_bug.cgi?id=585489

Firefox 26 OS X10.9.1 After browsing a few minutes, FF seems to forget to load CSS from several pages. This keeps happening. I delete the cache, page is back to normal, wait 2 min, start from top. Am I the only one or is this known? http://cl.ly/image/1G1V2G2w1x03 This is not on https as well as http. Should I be posting this in a new thread? This looks like a serious issue since 33 other people claim to have the exact same problem. Here's an UNCONFIRMED ticket from 2010describing the same behavior on Windows7 so issue seems to be cross-platform: https://bugzilla.mozilla.org/show_bug.cgi?id=585489

Okulungisiwe ngu rats

cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158596 izimpendulo
Kuphostiwe

You can try these steps in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
You can try these steps in case of issues with web pages: Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and cookies only from websites that cause problems. "Clear the Cache": *Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox > Preferences > Privacy > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
rats 1 izisombululo 16 izimpendulo
Kuphostiwe

Hi cor-el,

reload does not solve the CSS issue.

Clearing cookies does not resolve the CSS issue.

Clearing the cache does resolve the CSS issue: BUT, after 3mins the issue returns. This is not limited to a single site but happens to all site all over the web and keeps returning after working for a few minutes after resetting the cache.

This should really be addressed since it has happened for a very long time with several FF versions on OSX.

I tried FF27beta, same behavior. Guess I'll open a new ticket.

Hi cor-el, reload does not solve the CSS issue. Clearing cookies does not resolve the CSS issue. Clearing the cache does resolve the CSS issue: BUT, after 3mins the issue returns. This is not limited to a single site but happens to all site all over the web and keeps returning after working for a few minutes after resetting the cache. This should really be addressed since it has happened for a very long time with several FF versions on OSX. I tried FF27beta, same behavior. Guess I'll open a new ticket.
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158596 izimpendulo
Kuphostiwe

Did you try to reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files?

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

That is usually sufficient in case of such issues.

Did you try to reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files? *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) That is usually sufficient in case of such issues.
rats 1 izisombululo 16 izimpendulo
Kuphostiwe

True indeed. I experimented and on OS X Shift + CMD + R to reload the page fixes those RSS glitches. What I wonder is, why Safari and Chrome do not at all have any CSS issues that are similar.

So cor-el should I file a bug (it's still buggy behavior) or just move to another bug? Would be great to really address this problem.

True indeed. I experimented and on OS X Shift + CMD + R to reload the page fixes those RSS glitches. What I wonder is, why Safari and Chrome do not at all have any CSS issues that are similar. So cor-el should I file a bug (it's still buggy behavior) or just move to another bug? Would be great to really address this problem.
cor-el
  • Top 10 Contributor
  • Moderator
17540 izisombululo 158596 izimpendulo
Kuphostiwe

Files should get corrupted or missing to make it necessary to refresh pages frequently.
It can happen occasionally in case something went wrong, either on the server or on its way to Firefox.
If it happens often then there is usually some security software involved or possible malware.

Files should get corrupted or missing to make it necessary to refresh pages frequently.<br /> It can happen occasionally in case something went wrong, either on the server or on its way to Firefox.<br /> If it happens often then there is usually some security software involved or possible malware.
rats 1 izisombululo 16 izimpendulo
Kuphostiwe

Well since that issue is not happening with webkit not chromium I assume it's due to Firefox.

But good news is: 28.0a2 (2013-12-28) works fine without having this CSS issue.

So I assume let's wait for FF28 to become a stable release and than switch back to that channel.

So funny: I experienced this with several software projects: the so-called unstable nightly aka developer-build works much better than the "stable" release.

Well since that issue is not happening with webkit not chromium I assume it's due to Firefox. But good news is: 28.0a2 (2013-12-28) works fine without having this CSS issue. So I assume let's wait for FF28 to become a stable release and than switch back to that channel. So funny: I experienced this with several software projects: the so-called unstable nightly aka developer-build works much better than the "stable" release.
muhidins 0 izisombululo 1 izimpendulo
Kuphostiwe

For me, just add a line in your apache configuration file AddType text/css .css at file /etc/httpd/conf/httpd.conf

after that restart apache

service httpd restart

Thats work for me

For me, just add a line in your apache configuration file '''AddType text/css .css''' at file /etc/httpd/conf/httpd.conf after that restart apache service httpd restart Thats work for me

Okulungisiwe ngu muhidins