Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox do not play sound in any HTML5 player.

  • 21 uphendule
  • 34 zinale nkinga
  • 42387 views
  • Igcine ukuphendulwa ngu pigtripper

more options

When trying to play any sample from any album sold in Bandcamp.com the player starts playing, but there is no sound. Meanwhile other browsers plays it fine.

I use latest FF, I tried disabling various addons and plugins but it didn't help (they are not sound related anyway).

I run on Win8x64.

Update: The sound plays fine everywhere else on Firefox. YouTube etc. It plays everywhere except Bandcamp.

And the Bandcamp player is not Flash, it has nothing Flash related. It is HTML5 player.

Okulungisiwe ngu rhazor

Isisombululo esikhethiwe

SOLVED

Finally, after hundreds of hours I fixed it and Firefox plays sound in HTML5 in everywhere, YouTube (HTML5 mode), SoundCloud, Bandcamp and etc.

You have to: Right-click on your sound/speakers icon in the system tray and select Playback Devices, go to Speakers properties (the one which is green-ticked, also disable the red ones, if any), then go to Enhancements and tick Disable all sound effects. And that's it, restart the browser and enjoy.

In short: Volume mixer -> Playback devices -> Playback tab -> Speakers properties -> Enhancements -> Disable all sound effects -> Restart browser.

I use latest stable Firefox 23.0.1 on Windows 8 x64 (but Firefox is 32-bit).

Also, if didn't help, make sure you have media.windows-media-foundation.enabled set to 'true' in about:config.

You should also have some decent codecs installed in your machine, I have VLC Player and it comes with lots of in-built codecs. Also make sure you have VLC Web Plugin enabled in Add-ons -> Extensions (Always activate)

So the unanswered is who's problem is that? Is it Firefox? Or Windows 8? Or my Realtek audio drivers fault? (Anyway without disabling sound effects, HTML5 works fine in any other browser, so I blame Firefox for this nonsense for extra configurations in Windows audio settings)

So, pretty much it.

Cheers, rhazor

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 12

All Replies (1)

more options

Thank you, thank you, thank you!!!

Disabling all sound effects fixed the problem for me!!

  1. 1
  2. 2