Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I want new links to open in main window and not open a new browser or tab. What happened to the "open new links in..." option?

  • 6 uphendule
  • 42 zinale nkinga
  • 16269 views
  • Igcine ukuphendulwa ngu lau_ren6890

more options

And when you right click on a link, the only options are "open link in new tab" or "open link in new window". I want to open the link in the same tab, I don't need 16 tabs opened at the same time.

All Replies (6)

more options

Is there any reason that you need to right-click to open a link in the same tab?

Just left-click on links if you want them to open in the current tab.

more options

The option is still there as long as you left click. Go into your firefox menu and click options and then go to the tabs section - it should be the first option. You can set it to open in current tab, new tab or new window. Also Tab Mix Plus is an addon that allows you to customize further settings regarding how tabs open

more options

Yes, it should be the first option but it is not, look: I am using 22.0.

more options

You can override how links are opened via the browser.link.open_newwindow pref.

  • 1:current tab; 2:new window; 3:new tab;
more options

To clarify - are you trying to force links that normally open in a new window (via JavaScript or the HTML TARGET attribute) to open in the current tab instead?

more options

I fixed this problem. It was pretty easy. First, in the address bar, type in " about:config " . When it asks if you are sure about making changes & it may void the warranty, click "yes--I promise I'll be careful" or something along those lines. (I heard there is no warranty, & it's just a joke)

Once you get to the new screen, find " browser.link.open_newwindow " You will see the # 3 on the same line. Change that value to 1.

Wah-la! :)

http://kb.mozillazine.org/Editing_configuration

http://kb.mozillazine.org/Browser.link.open_newwindow

Okulungisiwe ngu lau_ren6890