X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Saved username and passwords no longer works on Yahoo Mail

Kuphostiwe

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin.

I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers.

This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Ever since Yahoo changed their login screen a few days ago the username and password fill has not worked correctly for me. I deleted the old entry and tried to reenter it but it would not show up on firefox. I had to use a booklet to get rid of the autocomplete=false tags in order for login manager to ask to save the password. However it does not fill it in when I try to relogin. I really enjoy this feature since I use a long Yahoo password and Firefox stores them better then most other browsers. This is the booklet I used. javascript:(function(){var%20c=0;function%20R(w){try{var%20a,df,dfe,i,j,x,y,r=1;df=w.document.forms;for(i=0;x=df[i];++i){dfe=x.elements;if(a=x.onsubmit){a=""}if(a=x.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}for(j=0;y=dfe[j];++j){if(a=y.attributes["autocomplete"]){if(a.value=="on"){c++}a.value="on"}}}}catch(E){r=0}return%20r}R(self);var%20i,x;for(i=0;x=frames[i];++i)R(x);if(c){alert("Found:%20"+c)}})();

Isisombululo esikhethiwe

A few days after my original post, I typed in my username and the password appeared. This is different from the usual behavior where both the username and the password was inputted... which is fine on my home computer. This was using that little scriptlet to make sure Firefox actually asked to save it.

Funda le mpendulo ngokuhambisana nalesi sihloko 1

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Unity Player 4.0.1f2
  • VLC media player Web Plugin 2.0.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • NPWLPG

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

Eminye Imininingwane

kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17468 izisombululo 157853 izimpendulo
Kuphostiwe

Still works for me with my currently saved name and password:

You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data.

You can use Inspect Element in the right-click context menu to confirm that the autocomplete="off" attribute gets removed.


Still works for me with my currently saved name and password: *https://login.yahoo.com/ You can remove autocomplete=off with a bookmarklet to make Firefox save names and passwords and other form data. *http://kb.mozillazine.org/User_name_and_password_not_remembered You can use Inspect Element in the right-click context menu to confirm that the autocomplete="off" attribute gets removed. ----- *Saved Password Editor: https://addons.mozilla.org/firefox/addon/saved-password-editor/
Jer 1 izisombululo 31 izimpendulo
Kuphostiwe

I have same problem, but only with a new yahoo user. My old yahoo user ids work fine in, but one Yahoo user I added will not prompt to save password. Other sites will prompt to save password, the Mozilla site did fine. I have run in safe mode and the results were the same. Autofillforms is True. I am on version 22 of Firefox. I did just update to Ver 22, So the problem, with me, is just new Yahoo users and also when I change a Yahoo user password, it doesn't prompt me anymore if I want to update. I guess you could say it is a Yahoo problem, but then again i didn't have the problem prior to Ver 22. This all started because I like to change passwords every 30 - 60 days.

I should add, password changes made to Gmail and Facebook did get prompted to update new password. So I guess we know where the problem is?

I have same problem, but only with a new yahoo user. My old yahoo user ids work fine in, but one Yahoo user I added will not prompt to save password. Other sites will prompt to save password, the Mozilla site did fine. I have run in safe mode and the results were the same. Autofillforms is True. I am on version 22 of Firefox. I did just update to Ver 22, So the problem, with me, is just new Yahoo users and also when I change a Yahoo user password, it doesn't prompt me anymore if I want to update. I guess you could say it is a Yahoo problem, but then again i didn't have the problem prior to Ver 22. This all started because I like to change passwords every 30 - 60 days. I should add, password changes made to Gmail and Facebook did get prompted to update new password. So I guess we know where the problem is?
Mari123 0 izisombululo 3 izimpendulo
Kuphostiwe

Yes, same problem here. Upgraded to Ver 22 last week and there is no prompt for Yahoo passwords now. I had no problems before and all other websites seem to site provide a prompt. So, I've just tried to using other browers - and they have same problem with Yahoo while other websites seem okay. So I guess that shows the issue is with Yahoo (...why does that not surprise me...)

Yes, same problem here. Upgraded to Ver 22 last week and there is no prompt for Yahoo passwords now. I had no problems before and all other websites seem to site provide a prompt. So, I've just tried to using other browers - and they have same problem with Yahoo while other websites seem okay. So I guess that shows the issue is with Yahoo (...why does that not surprise me...)
jude23 0 izisombululo 24 izimpendulo
Kuphostiwe

I tried this, and the problem goes away in safe mode-- Yahoo no longer asks for a password every time. However, when I go back to regular mode with all add-ons and extensions disabled, the problem returns. What to do??

I tried this, and the problem goes away in safe mode-- Yahoo no longer asks for a password every time. However, when I go back to regular mode with all add-ons and extensions disabled, the problem returns. What to do??
cor-el
  • Top 10 Contributor
  • Moderator
17468 izisombululo 157853 izimpendulo
Kuphostiwe

This can be caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page).

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

This can be caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page). *https://support.mozilla.org/kb/fix-login-issues-on-websites-require-passwords Clear the cache and the cookies from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > Cookies: "Show Cookies" If clearing cookies doesn't work then it is possible that the <i>cookies.sqlite</i> file that stores the cookies is corrupted. Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookie files like <b>cookies.sqlite-journal</b> in the Firefox profile folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies
sherylsr 0 izisombululo 15 izimpendulo
Kuphostiwe

I can't get Firefox to remember my user name/password, and I've done EVERYTHING!!!

I can't get Firefox to remember my user name/password, and I've done EVERYTHING!!!
jude23 0 izisombululo 24 izimpendulo
Kuphostiwe

Thank you for the reply. Actually I tried all that with clearing cache and cookies long before coming here to pose the question. It was no help at all.

I have not tried the cookies.sqlite strategy. To clarify--I only have this issue with Yahoo mail, all other passwords work fine. If that is the case, does it still make sense to delete the cookies.sqlite file?

Thank you for the reply. Actually I tried all that with clearing cache and cookies long before coming here to pose the question. It was no help at all. I have not tried the cookies.sqlite strategy. To clarify--I only have this issue with Yahoo mail, all other passwords work fine. If that is the case, does it still make sense to delete the cookies.sqlite file?
sherylsr 0 izisombululo 15 izimpendulo
Kuphostiwe

I just tried the cookies.sqlite thing. Didn't do a thing for me.

I just tried the cookies.sqlite thing. Didn't do a thing for me.
jscher2000
  • Top 10 Contributor
8688 izisombululo 71030 izimpendulo
Kuphostiwe

Hi jude23, you can rename the cookies.sqlite file and test. If it doesn't make a difference, reverse the process so you can get your old cookies back. Otherwise... how will we ever know whether that was the problem?

In case it's not covered in the above article, you want to close Firefox when doing that:

  • Open your current Firefox settings (AKA Firefox profile) folder using

    Help > Troubleshooting Information > "Show Folder" button
    (Mac: "Show in Finder" button)
  • Switch back to Firefox and Exit
  • Pause while Firefox finishes its cleanup, then rename the files as described above
  • Restart Firefox and test Yahoo (can you save the password and then, after logging out, are you logged back in)

Note: to undo the change, delete the newly created cookies.sqlite and rename the old file back.

Hi jude23, you can rename the cookies.sqlite file and test. If it doesn't make a difference, reverse the process so you can get your old cookies back. Otherwise... how will we ever know whether that was the problem? In case it's not covered in the above article, you want to close Firefox when doing that: * Open your current Firefox settings (AKA Firefox profile) folder using<br><br>Help > Troubleshooting Information > "Show Folder" button<br>(Mac: "Show in Finder" button) * Switch back to Firefox and Exit * Pause while Firefox finishes its cleanup, then rename the files as described above * Restart Firefox and test Yahoo (can you save the password and then, after logging out, are you logged back in) Note: to undo the change, delete the newly created cookies.sqlite and rename the old file back.
jscher2000
  • Top 10 Contributor
8688 izisombululo 71030 izimpendulo
Kuphostiwe

Hi sherylsr, are you only having this problem on Yahoo?

If you are having more general issues with saved passwords, please start a new question so we don't end up crossing up all the suggestions. You can use the "Ask a question" link at the top of the page for that.

Hi sherylsr, are you only having this problem on Yahoo? If you are having more general issues with saved passwords, please start a new question so we don't end up crossing up all the suggestions. You can use the "Ask a question" link at the top of the page for that.
sherylsr 0 izisombululo 15 izimpendulo
Kuphostiwe

Yes, just Yahoo. It's been bugging me for a while and decided to start Googling for more things to try. Found this discussion.

Yes, just Yahoo. It's been bugging me for a while and decided to start Googling for more things to try. Found this discussion.

Okulungisiwe ngu sherylsr

jude23 0 izisombululo 24 izimpendulo
Kuphostiwe

Cor-el, Okay, I found the cookies.sqlite and did the procedure. Made no difference at all.

Cor-el, Okay, I found the cookies.sqlite and did the procedure. Made no difference at all.

Okulungisiwe ngu jude23

cor-el
  • Top 10 Contributor
  • Moderator
17468 izisombululo 157853 izimpendulo
Kuphostiwe

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox
jude23 0 izisombululo 24 izimpendulo
Kuphostiwe

Thanks Cor-el. Our comments crossed. I did do it, but to no avail I'm afraid. Back at square 1.

Thanks Cor-el. Our comments crossed. I did do it, but to no avail I'm afraid. Back at square 1.
Jer 1 izisombululo 31 izimpendulo
Kuphostiwe

Impendulo Ewusizo

It is a problem with Yahoo, but it just started with FF V22. But I don't think it is V22 that is causing the problem. After going to FF V22, my old usernames work in Yahoo mail just fine, but when I tried adding a new Yahoo mail user it would not ask me if I wanted to save info, also if I change a password in Yahoo mail it will not ask me if I want to update password. Note** Yahoo passwords fill in fine on old ones I did not change.

Now other areas like Gmail etc work fine, I can add new or change old passwords. I did look at the Yahoo mail source and they do have autocomplete=off and they have done a lot of signon scree changes and have been hacked.

So I would chalk this up as a Yahoo issue. I am not going to use bookmarklete or how ever you spell that. Don't trust them. Also I tried safe mode................ and none of them made a bit of difference.

It is a problem with Yahoo, but it just started with FF V22. But I don't think it is V22 that is causing the problem. After going to FF V22, my old usernames work in Yahoo mail just fine, but when I tried adding a new Yahoo mail user it would not ask me if I wanted to save info, also if I change a password in Yahoo mail it will not ask me if I want to update password. Note** Yahoo passwords fill in fine on old ones I did not change. Now other areas like Gmail etc work fine, I can add new or change old passwords. I did look at the Yahoo mail source and they do have autocomplete=off and they have done a lot of signon scree changes and have been hacked. So I would chalk this up as a Yahoo issue. I am not going to use bookmarklete or how ever you spell that. Don't trust them. Also I tried safe mode................ and none of them made a bit of difference.
sherylsr 0 izisombululo 15 izimpendulo
Kuphostiwe

I'm going to try an uninstall-reinstall of Firefox.

I'm going to try an uninstall-reinstall of Firefox.
jude23 0 izisombululo 24 izimpendulo
Kuphostiwe

sherylsr, I thought of a reinstall, but stopped short of that. Since your and my issues sound pretty identical, can you report back on how that goes? thanks!

sherylsr, I thought of a reinstall, but stopped short of that. Since your and my issues sound pretty identical, can you report back on how that goes? thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17468 izisombululo 157853 izimpendulo
Kuphostiwe

Did you try Safe Mode?

You can also try if it works in a Private Browsing mode window (tab).

Did you try Safe Mode? You can also try if it works in a Private Browsing mode window (tab).
jude23 0 izisombululo 24 izimpendulo
Kuphostiwe

As I mentioned above, I tried Safe mode and it the problem does not occur there. However when I disable all add-ons in regular mode the problem continues.

As I mentioned above, I tried Safe mode and it the problem does not occur there. However when I disable all add-ons in regular mode the problem continues.