X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to disable hidpi on FireFox 22

Kuphostiwe

I whish to know how to disable hidpi

I whish to know how to disable hidpi

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Unity Player 4.1.2f1
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • nphardwaredetection
  • Panda TotalScan Plugin for Firefox
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1739

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0

Eminye Imininingwane

cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157344 izimpendulo
Kuphostiwe

The current Firefox release is Firefox 24.0, so make usre that you have the latest version.

You can find the full version of the latest Firefox 24.0 release in all languages and for all Operating Systems here:


Set the layout.css.devPixelsPerPx pref on the about:config page to 1.0 or on Windows 8 to 1.25 and if necessary, adjust layout.css.devPixelsPerPx starting with 1.0 in 0.1 or 0.05 steps (1.0 or 0.9) to make icons show correctly.

See also:

Use an extension to adjust the text size in the user interface and the page zoom in the browser window.

Use this extension to adjust the font size for the user interface.

You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx.

The current Firefox release is Firefox 24.0, so make usre that you have the latest version. You can find the full version of the latest Firefox 24.0 release in all languages and for all Operating Systems here: *http://www.mozilla.org/en-US/firefox/all.html ----- *http://kb.mozillazine.org/about:config Set the layout.css.devPixelsPerPx pref on the <b>about:config</b> page to 1.0 or on Windows 8 to 1.25 and if necessary, adjust layout.css.devPixelsPerPx starting with 1.0 in 0.1 or 0.05 steps (1.0 or 0.9) to make icons show correctly. *http://kb.mozillazine.org/about:config See also: *https://support.mozilla.org/kb/forum-response-Zoom-feature-on-Firefox-22 Use an extension to adjust the text size in the user interface and the page zoom in the browser window. Use this extension to adjust the font size for the user interface. *Theme Font & Size Changer: https://addons.mozilla.org/firefox/addon/theme-font-size-changer/ You can look at the Default FullZoom Level or NoScript extension if web pages need to be adjusted after changing layout.css.devPixelsPerPx. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi jalle007, what techniques did you use for tuning your toolbars and text sizes? Do you mean text sizes in the UI area of Firefox or in the content area?

Hi jalle007, what techniques did you use for tuning your toolbars and text sizes? Do you mean text sizes in the UI area of Firefox or in the content area?
jalle007 0 izisombululo 8 izimpendulo
Kuphostiwe

HI

I use default zoom ext and its working fine . MY bookmark toolbar was arranged to have all icons in one line. Now after this change they simply not fit. If I leave layout.css.devPixelsPerPx to -1 they simply dont fit as expected . I If I set layout.css.devPixelsPerPx to 1 then they are too small.

I simply can't get same arrangement as I had on v21.

Can we have simply option in about:config to turn off this feature compeltely ?

HI I use default zoom ext and its working fine . MY bookmark toolbar was arranged to have all icons in one line. Now after this change they simply not fit. If I leave layout.css.devPixelsPerPx to -1 they simply dont fit as expected . I If I set layout.css.devPixelsPerPx to 1 then they are too small. I simply can't get same arrangement as I had on v21. Can we have simply option in about:config to turn off this feature compeltely ?
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi jalle007, I don't think there is any about:config option to turn off DPI scaling. Perhaps that will be added in a future version, or I would personally prefer to have two different DPI settings: one for the UI and one for the content.

With layout.css.devPixelsPerPx set to -1 your Bookmarks Toolbar icons will be zoomed according to your Windows zoom level. With layout.css.devPixelsPerPx set to 1 they should be at 100% (native image size). If that makes the icons too small, I wonder how you enlarged them before? What if you try an intermediate setting such as 1.1 (110% zoom)?

Hi jalle007, I don't think there is any about:config option to turn off DPI scaling. Perhaps that will be added in a future version, or I would personally prefer to have two different DPI settings: one for the UI and one for the content. With layout.css.devPixelsPerPx set to -1 your Bookmarks Toolbar icons will be zoomed according to your Windows zoom level. With layout.css.devPixelsPerPx set to 1 they should be at 100% (native image size). If that makes the icons too small, I wonder how you enlarged them before? What if you try an intermediate setting such as 1.1 (110% zoom)?
jalle007 0 izisombululo 8 izimpendulo
Kuphostiwe

I tried entering values like 1.1 or 0-9 but none of them has no effect except 1 & -1. Now I noticed that many sites do not look right.

This is a real step backwards for FF users

I tried entering values like 1.1 or 0-9 but none of them has no effect except 1 & -1. Now I noticed that many sites do not look right. This is a real step backwards for FF users
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe

I assume when Chrome 30/31 and IE 11 come, they will also be a big step backwards too. It should of had been like this anyways.

Set your DPI on windows to 1.0 or pixelsperpx to 1.0

I assume when Chrome 30/31 and IE 11 come, they will also be a big step backwards too. It should of had been like this anyways. '''Set your DPI on windows to 1.0 or pixelsperpx to 1.0'''
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi jalle007, using 1.1 should have a small effect (+10%) on all UI and context text and images. If you see no change at all, I wonder whether you might have another extension or userChrome.css/userContent.css rule that is conflicting?

There are some sites that sense your browser's reported resolution and resize things. The Facebook login page, for example, expands the logo hugely if you aren't using 100% zoom. But most sites should be easily fixable with the zoom feature.

Hi jalle007, using 1.1 should have a small effect (+10%) on all UI and context text and images. If you see no change at all, I wonder whether you might have another extension or userChrome.css/userContent.css rule that is conflicting? There are some sites that sense your browser's reported resolution and resize things. The Facebook login page, for example, expands the logo hugely if you aren't using 100% zoom. But most sites should be easily fixable with the zoom feature.
jalle007 0 izisombululo 8 izimpendulo
Kuphostiwe

Look I would go back to FF v21 but I can't - only because Flash plugin is crashing all the time

Now I am on v23 but I can't use it because all of the pages I open are distorted.

you should fix this FF or we all go to Chrome or other browser

Look I would go back to FF v21 but I can't - only because Flash plugin is crashing all the time Now I am on v23 but I can't use it because all of the pages I open are distorted. you should fix this FF or we all go to Chrome or other browser
jalle007 0 izisombululo 8 izimpendulo
Kuphostiwe

this is crazy.

One think that worked since v1 - ACTUAL DISPLAYING THE PAGES now doesn't work in v23

Maybe v25 will bring us FF who doesn't support links, who knows :-/

this is crazy. One think that worked since v1 - ACTUAL DISPLAYING THE PAGES now doesn't work in v23 Maybe v25 will bring us FF who doesn't support links, who knows :-/
jscher2000
  • Top 10 Contributor
8637 izisombululo 70648 izimpendulo
Kuphostiwe

Hi jalle007, the change in Firefox 22 should be consistent from site to site, i.e., larger text and images. Some issues that may cause distortions are:

  • Using Text-only zoom. From the View menu make sure you don't have "Zoom Text Only" selected. (If you use the compact menu and orange Firefox button, tap the Alt key to display the classic menu bar temporarily so you can check the Zoom setting.)
  • Old site-specific zoom levels saved by NoSquint. If you used the NoSquint extension to alter page zoom levels on a site-by-site basis prior to Firefox 22, those saved corrections may "overcorrect" in Firefox 23 and later.

If there are particular sites that can't be helped with zoom adjustments, could you mention a few URLs?

Hi jalle007, the change in Firefox 22 should be consistent from site to site, i.e., larger text and images. Some issues that may cause distortions are: * Using Text-only zoom. From the View menu make sure you don't have "Zoom Text Only" selected. (If you use the compact menu and orange Firefox button, tap the Alt key to display the classic menu bar temporarily so you can check the Zoom setting.) * Old site-specific zoom levels saved by NoSquint. If you used the NoSquint extension to alter page zoom levels on a site-by-site basis prior to Firefox 22, those saved corrections may "overcorrect" in Firefox 23 and later. If there are particular sites that can't be helped with zoom adjustments, could you mention a few URLs?
cor-el
  • Top 10 Contributor
  • Moderator
17416 izisombululo 157344 izimpendulo
Kuphostiwe

You can rename the content-prefs.sqlite file to content-prefs.sqlite.old (or delete the file) in the Firefox profile folder to reset the page zoom for all websites.

Note that this will remove other site specific settings.


You can use this button to go to the Firefox profile folder:

You can rename the content-prefs.sqlite file to content-prefs.sqlite.old (or delete the file) in the Firefox profile folder to reset the page zoom for all websites. Note that this will remove other site specific settings. ---- You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox

Okulungisiwe ngu cor-el