Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 21 is not reading my user.js file.

  • 3 uphendule
  • 6 zinale nkinga
  • 100 views
  • Igcine ukuphendulwa ngu cor-el

more options

FF 21 does not appear to be reading or applying my user.js file to the user's prefs.js file. I have installed FF 21, went into about:config, made the changes I wanted so they would appear in the prefs.js file. I then saved that file as user.js and removed all the settings I did not care about. I then reset my virtual machine, installed FF 21 again and saved the file in C:\Program Files (x86)\Mozilla Firefox\defaults\profile. When I started FF 21 it did not apply any of the settings and behaved as if there was no user.js file. Here is a copy of my user.js file:


  1. Mozilla User Preferences

/* Do not edit this file.

*
* If you make changes to this file while the application is running,
* the changes will be overwritten when the application exits.
*
* To make a manual change to preferences, you can visit the URL about:config
*/

user_pref("app.update.auto", false); user_pref("app.update.enabled", false); user_pref("browser.bookmarks.restore_default_bookmarks", false); user_pref("browser.shell.checkDefaultBrowser", false); user_pref("browser.startup.homepage", "http://intranet.cdc.gov"); user_pref("browser.startup.homepage_override.mstone", "ignore"); user_pref("network.automatic-ntlm-auth.allow-proxies", true); user_pref("network.automatic-ntlm-auth.trusted-uris", "http://intranet.cdc.gov"); user_pref("browser.rights.3.shown", true);


This same exact file works just fine with FF 20.0.1. I have also tried this file with FF 21 with the comments at the beginning of the file removed.

Any help would be great appreciated.

Isisombululo esikhethiwe

hello swahl, the problem probably isn't within the user.js file itself - see http://mike.kaply.com/2013/05/13/more-major-changes-coming-in-firefox-21/

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

hello swahl, the problem probably isn't within the user.js file itself - see http://mike.kaply.com/2013/05/13/more-major-changes-coming-in-firefox-21/

more options

Did you try creating a new Profile?
browser/defaults/profile applies to newly created Profiles, or upon installation of Firefox if you're building your own "package"

With an existing Profile, place the user.js file in the Profile folder directly.
C:\Users\<user name>\AppData\Roaming\\Mozilla\Firefox\Profiles\<profile folder>

http://kb.mozillazine.org/User.js_file


You should remove all this - not needed in user,js:

      #Mozilla User Preferences 

/* Do not edit this file.

*
* If you make changes to this file while the application is running,
* the changes will be overwritten when the application exits.
*
* To make a manual change to preferences, you can visit the URL about:config
*/
 
more options

Only newly created profiles are initialized via files in the defaults\profile folder.
This doesn't affect profiles that already exist.

Existing profile can only be affected via a mozilla.cfg autoconfiguration file.


You can use a mozilla.cfg file in the Firefox program folder to lock prefs or specify new (default) values.

Place a file local-settings.js in the defaults\pref folder where you also find the file channel-prefs.js to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0); // use this to disable the byte-shift

See:

These functions can be used in the mozilla.cfg file:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes