Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How to turn off Java version check

  • 2 uphendule
  • 10 zinale nkinga
  • 29691 views
  • Igcine ukuphendulwa ngu systeemgod

more options

I have a small Linux based pc running Firefox in kiosk mode. The pc is not connected to the Internet and only has acess to a dedicated server under my control, serving a few webpages and a java applet. Suddenly the system started complaining java my java version is outdated messing up the kiosk display.

- how did firefox figure out the java version is outdated if neither the frond end pc nor the back end server have access to the Internet - is there a way to turn off java security checking in one of the firefox config files? The kiosk pc boots from the network, the firefox profile is automatically generated, so I need a way to change this in the config files, not through the GUI as I won't be there every time the kiosk boots.

I'm running Firefox 13.0.1, I know this is old but security isn't an issue as I'm only accessing my own server and updating the firefox version on the PXE image is a pain.

Isisombululo esikhethiwe

Turns out the 9Oracle) Java installation has a built-in expiration date. So it was Java blocking itself, not firefox blocking Java.

To disable the Java version check, start the Java control panel ('jcontrol'), in the 'Security' tab turn the security level to 'low'. This will disable all version checks and allow Java to run.

Needless to say this should only be applied when running in a completely controlled environment where you control the client and server (as is the case in my setup).

More information available at: http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/client-security.html

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 9

All Replies (2)

more options

hello, please see http://kb.mozillazine.org/Extensions.blocklist.enabled (the blocklist now also holds the information for crashy drivers and old plugins)

more options

Isisombululo Esikhethiwe

Turns out the 9Oracle) Java installation has a built-in expiration date. So it was Java blocking itself, not firefox blocking Java.

To disable the Java version check, start the Java control panel ('jcontrol'), in the 'Security' tab turn the security level to 'low'. This will disable all version checks and allow Java to run.

Needless to say this should only be applied when running in a completely controlled environment where you control the client and server (as is the case in my setup).

More information available at: http://docs.oracle.com/javase/7/docs/technotes/guides/jweb/client-security.html

Okulungisiwe ngu systeemgod