X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Mozilla.cfg file is not loading in my 21.0 version; how can I customize deployment?

JB
Kuphostiwe

I need to deploy a customized configuration for a limited access network, and have created a custom mozilla.cfg file. It appears as though mozilla.cfg is not being read. I have intentionally created errors in the local-settings.js file, and it will throw errors (even when it cannot find the mozilla.cfg file). When I create errors in the mozilla.cfg file, however, no errors are thrown and no changes are made to the applications configuration.

I need to deploy a customized configuration for a limited access network, and have created a custom mozilla.cfg file. It appears as though mozilla.cfg is not being read. I have intentionally created errors in the local-settings.js file, and it will throw errors (even when it cannot find the mozilla.cfg file). When I create errors in the mozilla.cfg file, however, no errors are thrown and no changes are made to the applications configuration.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Box Edit
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Citrix Online App Detector Plugin
  • 4.0.50401.0

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

Eminye Imininingwane

Umnikazi wombuzo

cor-el,

 Yes, all settings appear to be taking effect.  Taking your advice, I simplified the mozilla.cfg file to a very basic one liner that would be obvious (see below).

The change did not make any difference. When I review the about:config the below value is true.

"pref("browser.shell.checkdefaultBrowser", false);

cor-el, Yes, all settings appear to be taking effect. Taking your advice, I simplified the mozilla.cfg file to a very basic one liner that would be obvious (see below). The change did not make any difference. When I review the about:config the below value is true. "pref("browser.shell.checkdefaultBrowser", false);

Umnikazi wombuzo

I wanted to add, I know that FF is looking for mozilla.cfg. When I change the name or remove the file, FF does give me an error that the file could not be found.

I wanted to add, I know that FF is looking for mozilla.cfg. When I change the name or remove the file, FF does give me an error that the file could not be found.

Umnikazi wombuzo

I am ready am back in the office and ready to try and solve this issue. Does anyone have a solution for settings in the mozilla.cfg not taking effect?

I am ready am back in the office and ready to try and solve this issue. Does anyone have a solution for settings in the mozilla.cfg not taking effect?
cor-el
  • Top 10 Contributor
  • Moderator
17482 izisombululo 158025 izimpendulo
Kuphostiwe

There is a leading quote in that line:

"pref("browser.shell.checkdefaultBrowser", false);

Is that quote in the real file as well or is this a typo?

See also:

There is a leading quote in that line: <pre><nowiki>"pref("browser.shell.checkdefaultBrowser", false);</nowiki></pre> Is that quote in the real file as well or is this a typo? See also: *http://www.mockbox.net/server-stuff/configmgr-sccm/174-install-and-configure-firefox-silently

Umnikazi wombuzo

The leading quote is not in the file, it is a typo in the reply. Since I am able to control the home page with the local-settings.js file, my next items to address are locking the proxy settings, remove the default browser check, and prevent update checks.

The leading quote is not in the file, it is a typo in the reply. Since I am able to control the home page with the local-settings.js file, my next items to address are locking the proxy settings, remove the default browser check, and prevent update checks.
JFurmanek 0 izisombululo 1 izimpendulo
Kuphostiwe

I'm having the same exact problem, were you ever able to get this working?

EDIT: okay at least for mine I am finally able to apply the info into firefox however I had to change my lockpref to just pref. so that's progress for me but I still need to lock it down so users can modify the settings.

maybe ill just remove the button and hope they don't know about about:config, lol.

I'm having the same exact problem, were you ever able to get this working? EDIT: okay at least for mine I am finally able to apply the info into firefox however I had to change my lockpref to just pref. so that's progress for me but I still need to lock it down so users can modify the settings. maybe ill just remove the button and hope they don't know about about:config, lol.

Okulungisiwe ngu JFurmanek

cor-el
  • Top 10 Contributor
  • Moderator
17482 izisombululo 158025 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The correct name is lockPref() (case sensitive).
The mzoilla.cfg file is run a JavaScript code, so any errors in the file will throw an exception and abort the execution.

The correct name is lockPref() (case sensitive).<br /> The mzoilla.cfg file is run a JavaScript code, so any errors in the file will throw an exception and abort the execution.
daniphp 0 izisombululo 1 izimpendulo
Kuphostiwe

pref('general.config.obscure_value', 0); inside the js file is MANDATORY

add this and the pref/prefLock will work

pref('general.config.obscure_value', 0); inside the js file is MANDATORY add this and the pref/prefLock will work
cor-el
  • Top 10 Contributor
  • Moderator
17482 izisombululo 158025 izimpendulo
Kuphostiwe

The default value of the general.config.obscure_value is 0 in current Firefox versions, so omitting this line shouldn't be a problem.

The default value of the general.config.obscure_value is 0 in current Firefox versions, so omitting this line shouldn't be a problem. *http://mxr.mozilla.org/mozilla-release/source/extensions/pref/autoconfig/src/nsReadConfig.cpp
hkv-helpdesk 0 izisombululo 1 izimpendulo
Kuphostiwe

We run firefox in an enterprise environment. lockdown of firefox was working fine in firefox 24. upgraded the installation to v25 for testing and lockdown is broken. get error loading configuration, problem seems to reside in local-settings.js

pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg");

when i remove first line firefox loads but no mozilla.cfg is loaded.

anyone any ideas? Why does mozilla change te way configs are passed without notice (or am i reading the wrong changelogs?)

We run firefox in an enterprise environment. lockdown of firefox was working fine in firefox 24. upgraded the installation to v25 for testing and lockdown is broken. get error loading configuration, problem seems to reside in local-settings.js pref("general.config.obscure_value", 0); pref("general.config.filename", "mozilla.cfg"); when i remove first line firefox loads but no mozilla.cfg is loaded. anyone any ideas? Why does mozilla change te way configs are passed without notice (or am i reading the wrong changelogs?)

Okulungisiwe ngu hkv-helpdesk

cor-el
  • Top 10 Contributor
  • Moderator
17482 izisombululo 158025 izimpendulo
Kuphostiwe

If there is a problem with the mozilla.cfg file then you usually get a warning pop-up.

Did you check for problems with the mozilla.cfg file and only tried a files with the few safe lines that should work?

Which calls do you use in the mozilla.cfg file?

If there is a problem with the mozilla.cfg file then you usually get a warning pop-up. Did you check for problems with the mozilla.cfg file and only tried a files with the few safe lines that should work? Which calls do you use in the mozilla.cfg file?