X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Problem with entering URL

Kuphostiwe

Ever since the last update or two I seem to have an irritating problem with entering URLs. If I'm navigating a site and modify the URL manually in the address field and hit enter, the URL reverts back automatically to the previous one instead of accepting the new modified entry.

For example if I'm on www.site.com/path/path and go to the URL bar and remove the last '/path' and hit enter, the browser seems to 'remember' and take me to the previous URL path, i.e. www.site.com/path/path. It doesn't matter whether the deleted text forms part of the URL path or whether its parameters after the path, or even if I modify the URL to something like www.site.com/path/anotherpath.

Once it starts 'remembering' there seems to be no way of getting around this except to close the browser down and start again. I've noticed this behavior on FF20.0.1 and also on FF21. It happens on all 3 of the PCs I use (2 at home, one at work). I'n not sure if its being caused directly by FF or the NoScript plugin (the latter seems unlikely).

Is there a setting somewhere to modify this behavior, or is it a bug?

Ever since the last update or two I seem to have an irritating problem with entering URLs. If I'm navigating a site and modify the URL manually in the address field and hit enter, the URL reverts back automatically to the previous one instead of accepting the new modified entry. For example if I'm on www.site.com/path/path and go to the URL bar and remove the last '/path' and hit enter, the browser seems to 'remember' and take me to the previous URL path, i.e. www.site.com/path/path. It doesn't matter whether the deleted text forms part of the URL path or whether its parameters after the path, or even if I modify the URL to something like www.site.com/path/anotherpath. Once it starts 'remembering' there seems to be no way of getting around this except to close the browser down and start again. I've noticed this behavior on FF20.0.1 and also on FF21. It happens on all 3 of the PCs I use (2 at home, one at work). I'n not sure if its being caused directly by FF or the NoScript plugin (the latter seems unlikely). Is there a setting somewhere to modify this behavior, or is it a bug?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Office Plugin for Netscape Navigator

Isisebenziso

  • Firefox 20.0.1
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • I-URL Yokweseka: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Izandiso

  • NoScript 2.6.6.2 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Anti-Banner 12.0.1.511 (KavAntiBanner@Kaspersky.ru) (Akusebenzi)
  • Kaspersky URL Advisor 12.0.1.511 (linkfilter@kaspersky.ru) (Akusebenzi)
  • Kaspersky Virtual Keyboard 12.0.1.511 (virtualKeyboard@kaspersky.ru) (Akusebenzi)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: Mobile Intel(R) 965 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a02
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 9-23-2009
  • driverDate2:
  • driverVersion: 8.15.10.1930
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 965 Express Chipset Family)
  • windowLayerManagerType: Direct3D 9

Okuthandwayo Okulungisiwe

  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 921600
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1369167663
  • places.history.expiration.transient_current_max_pages: 53437
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
philipp
  • Top 25 Contributor
  • Moderator
5346 izisombululo 23604 izimpendulo
Kuphostiwe

hello forumposter, maybe try this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named browser.urlbar.autoFill. double-click it and change its value to false.

hello forumposter, maybe try this: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''browser.urlbar.autoFill'''. double-click it and change its value to '''false'''.

Umnikazi wombuzo

Can anyone tell me the difference between browser.urlbar.autoFill and browser.urlbar.autoFill.typed and whether I need to set both to false or just one or both of them?

Haven't been able to find a definitive meaning of the second parameter.

Can anyone tell me the difference between browser.urlbar.autoFill and browser.urlbar.autoFill.typed and whether I need to set both to false or just one or both of them? Haven't been able to find a definitive meaning of the second parameter.
philipp
  • Top 25 Contributor
  • Moderator
5346 izisombululo 23604 izimpendulo
Kuphostiwe

Impendulo Ewusizo

i couldn't find any documentation for it either, however after testing it, it appears that when browser.urlbar.autoFill.typed is set to true it means that only addresses you've once typed into the url-bar manually get autofilled, when browser.urlbar.autoFill.typed is set to false then all addresses that are stored in your history no matter if you have typed them in once manually or visited them through a link on a website.

browser.urlbar.autoFill will generally switch the autocomplete feature in the address bar on or off.

i couldn't find any documentation for it either, however after testing it, it appears that when browser.urlbar.autoFill.typed is set to '''true''' it means that only addresses you've once typed into the url-bar manually get autofilled, when browser.urlbar.autoFill.typed is set to '''false''' then all addresses that are stored in your history no matter if you have typed them in once manually or visited them through a link on a website. browser.urlbar.autoFill will generally switch the autocomplete feature in the address bar on or off.

Impendulo Ewusizo

Since the issue generally relates to addresses that have been added automatically but then manually altered, I guess browser.urlbar.autoFill.typed won't cover it. I will set browser.urlbar.autoFill to false and see how it goes. I have seen a post that suggested setting both to false but I can experiment with that.

Since the issue generally relates to addresses that have been added automatically but then manually altered, I guess browser.urlbar.autoFill.typed won't cover it. I will set browser.urlbar.autoFill to false and see how it goes. I have seen a post that suggested setting both to false but I can experiment with that.
cor-el
  • Top 10 Contributor
  • Moderator
17775 izisombululo 160795 izimpendulo
Kuphostiwe
See also: *http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/nsPlacesAutoComplete.js#71
blue1x 0 izisombululo 1 izimpendulo
Kuphostiwe

When I try to enter an address, any address in the URL line I get this message:

The address isn't valid

         The URL is not valid and cannot be loaded.
     
 Web addresses are usually written like
   http://www.example.com/
 Make sure that you're using forward slashes (i.e.
   /).

The http appears as https;///, yes three forward slashes. How do I correct this problem?

When I try to enter an address, any address in the URL line I get this message: The address isn't valid The URL is not valid and cannot be loaded. Web addresses are usually written like http://www.example.com/ Make sure that you're using forward slashes (i.e. /). The http appears as https;///, yes three forward slashes. How do I correct this problem?
cor-el
  • Top 10 Contributor
  • Moderator
17775 izisombululo 160795 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
kobe 441 izisombululo 5048 izimpendulo
Kuphostiwe
Also see: [[Reset Firefox preferences to troubleshoot and fix problems]]