Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't update-says system does't meet requirement to run firefox

  • 4 uphendule
  • 3 zinale nkinga
  • 1141 views
  • Igcine ukuphendulwa ngu nole62

more options

I'm using Mac os X 10.5.8

Isisombululo esikhethiwe

If you can update to OSX 10.6 (can be cheap) then that is a good option also.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options
more options

Current Firefox versions need OS X 10.6 or later.

Firefox 16.0.2 is the last version that works on an Intel Mac with the OS X 10.5 operating system.

Another option to consider is to install the last Firefox 10.0.x ESR version as that version is more recent than the Firefox 16.0.2 version.

Firefox 17.0.x ESR has replaced the Firefox 10 ESR version, so you don't update.

more options

Isisombululo Esikhethiwe

If you can update to OSX 10.6 (can be cheap) then that is a good option also.

more options

I am running OS 10.8.4 with an Intel Core i3. This is really too old? Also FF 23.0.1

Okulungisiwe ngu nole62