Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Linux, Firefox 21.0 and the latest flash FOR LINUX (11.2). I can't view youtube videos because firefox has disabled the plugin. Help!

  • 15 uphendule
  • 30 zinale nkinga
  • 29196 views
  • Igcine ukuphendulwa ngu jscher2000

more options

One hour ago I was happily watching youtube videos under Linux using Firefox 20.0 and flash 11.2. I just updated firefox and it is now blocking my flash and prompting me to update. The problem is I can't update because 11.2 is the LAST flash plugin for firefox, there won't be any other version.

Is there a way to prevent firefox from disabling my plugin?

Isisombululo esikhethiwe

The directory structure, at least for linux, seems to have changed for version 21. I have my firefox distribution in /opt/firefox/, and up to now I've keep the flash plugin in /opt/firefox/plugins/. With vers 21, the plugin directory should be /opt/firefox/browser/plugins/ This directory doesn't exist by default. You can create it or just mv the old plugin directory to the new location

$ cd /opt/firefox/ #(or wherever your firefox is installed) $ mv plugins/ browser/

The icons/ directory has also been moved into this sub-directory, which is why my firefox desktop button was not displayed correctly after the update.


Really - the main thing that firefox should be doing is to archive the previous version of firefox whenever it does an update. It is ridiculous to have to deal with this sort of issue immediately after an update when you might have important work to get done in a timely manner!! There needs to be a simple option to temporarily revert to the previous version of firefox. This would be trivial to implement, and could be used when a new version breaks something.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 8

All Replies (15)

more options

Will Firefox let you re-enable Flash here:

Tools menu > Add-ons > Plugins category

When I look at this morning's blocklist.xml for libflashplayer.so (on a Windows 7 system with Firefox 21 beta), I'll admit I don't read regular expressions well enough to know for sure whether Flash 11.2 is targeted here, but I don't think so. Your blocklist.xml may vary:

<pluginItem  blockID="p330">
  <match name="description" exp="^Shockwave Flash (([1-9]\.[0-9]+)|(10\.([0-2]|(3 r(([0-9][0-9]?)|1(([0-7][0-9])|8[0-2]))))))( |$)" />
  <match name="filename" exp="libflashplayer\.so" />
  <versionRange  severity="0" vulnerabilitystatus="1">
    <targetApplication  id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
      <versionRange  minVersion="19.0a1" maxVersion="*" />
    </targetApplication>
  </versionRange>
</pluginItem>
<pluginItem  blockID="p332">
  <match name="description" exp="^Shockwave Flash 11.(0|1) r[0-9]{1,3}$" />
  <match name="filename" exp="libflashplayer\.so" />
  <versionRange  severity="0" vulnerabilitystatus="1">
    <targetApplication  id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}">
      <versionRange  minVersion="19.0a1" maxVersion="*" />
    </targetApplication>
  </versionRange>
</pluginItem>
more options

I'm not aware of any blocking of 11.2 Flash Player plugin versions.

Blocked 10.3 versions should be possible to enable via click-to-play.

Did you already update to the latest 11.2.202.285 version?

more options

Thanks for your quick reply.

More information:

If the flash plugin is placed in "/usr/lib/mozilla/plugins", flash runs and the annoying message goes away. Also, I can see the plugin in about:plugins and in tools>add-ons>plugins.

If the flash plugin is in "/usr/local/firefox/plugins" (which is where I placed my custom firefox installation) I can't see it neither in about:plugins nor in tools>add-ons>plug-ins

Did the latest firefox change the directory where it looks for plugins?

Is there a way of preventing firefox from disabling outdated plugins?

more options
more options

I see. But, is this new? I have been working with Linux for almost 10 years and my flash plugin has always been in /usr/local/firefox/plugins. I thought firefox first searched foir that directory.

Also, I just upgraded the Firefox installation on my other 2 computers (they both had Linux and version 20.0). This same issue occurred there. I moved the plugins and that was it, they are fixed now.

Also, one remaining issue: can I disable Firefox's function to disable outdated plugins, Flash is not "at risk" and it will eventually becaome outdates, but Adobe won't be releasing more versions. Also, shouldn't the Linux version of Firefox know that 11.2 is and will be the latest for ever and evermore instead of just labelling it old?

more options

Flash isn't blocked now. Since the blocklist may protect you from other problems, I think it would be premature to try to disable it. (As for how to do that, I imagine there are past threads on that.)

more options

Isisombululo Esikhethiwe

The directory structure, at least for linux, seems to have changed for version 21. I have my firefox distribution in /opt/firefox/, and up to now I've keep the flash plugin in /opt/firefox/plugins/. With vers 21, the plugin directory should be /opt/firefox/browser/plugins/ This directory doesn't exist by default. You can create it or just mv the old plugin directory to the new location

$ cd /opt/firefox/ #(or wherever your firefox is installed) $ mv plugins/ browser/

The icons/ directory has also been moved into this sub-directory, which is why my firefox desktop button was not displayed correctly after the update.


Really - the main thing that firefox should be doing is to archive the previous version of firefox whenever it does an update. It is ridiculous to have to deal with this sort of issue immediately after an update when you might have important work to get done in a timely manner!! There needs to be a simple option to temporarily revert to the previous version of firefox. This would be trivial to implement, and could be used when a new version breaks something.

more options

Since I am the only user I put my plugins in plugins folder located at /home/username/.mozilla/pugins/ and have not had any issues with Firefox not detecting Flash or other Plugins in Firefox 21.0 or new development builds.

Okulungisiwe ngu James

more options

Hi James.

I assume that you mean: ~/.mozilla/plugins/ (/home/<user>/.mozilla/plugins/)

I place as well symlinks to plugins in this folder, but there are more location that are scanned for plugins by some versions of Firefox.

more options

Thank you very much everyone. The problem was actually the new directory structure. All my computers are working now with Firefox as usual. The solution is to move the plugins folder to any of the standard locations mentioned here.

more options

Definitely!! I totally agree with this, there should be an option to revert back to the previous version instead of having to suffer (instead of enjoying) the new feature/changes. This should be proposed as a feature or something.

more options

Yet another solution for this is to go to the about:config page and change the option "plugins.load_appdir_plugins" from false (default) to true. This will cause firefox to find plugins in the old location. This is not a great solution for me. The reason that I don't put plugins in ~/.mozilla/ is that my kids also use this computer with their own accounts and I don't want to have to update the plugins multiple times, and I also don't want to bother with setting an about:config option for each of them. It would also mean that plugins would not work for a guest login without tweaking the setup.

more options

Under Fedora, plugins are in the directory /usr/lib64/mozilla/plugins on a 64-bit machine, or /usr/lib/mozilla/plugins for 32-bit. I found the above advice helpful and it led me to the solution for me.

Under previous versions, the flash plugin was in a separate directory and a soft link was put in the mozilla/plugins directory. With version 21, a soft link no longer works. The libflashplayer.so file itself must be placed in the plugins directory. Flash is now working for me fine.

more options

Strangely enough it isn't a firefox blocking issue here:

Some youtube videos play fine, some say i have to update to the latest flash player. The latter keep increasing.

Running Firefox 21.0 and Adobe flash test reports: "You have version 11,2,202,285 installed", which is the latest flash for linux. Works fine at Adobes site.

Anyone have an explanation for this behaviour?

more options

Hi WPlinge, are you enrolled in the HTML5 trial (http://www.youtube.com/html5)? This might explain why some videos play normally and others do not (the ones that do not have an HTML5 version).

Also, how is the "you need to update" message displayed? Does it appear to be from YouTube or the video itself?