Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot clear data from Tools menu with FF 21

  • 6 uphendule
  • 10 zinale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu cor-el

more options

I just installed Firefox 21. I do not see the Clear History item in the Tools menu any more. Is there any way to get that back? I prefer to have easy voluntary control over clearing the history and other data. Why did the developers not set the item in the Privacy panel to ask first before clearing anything, the way it did before?

Isisombululo esikhethiwe

You can find this item now in the History menu, just like others as Restore Previous Session and Recently Closed Tabs/Windows

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 13

All Replies (6)

more options

Isisombululo Esikhethiwe

You can find this item now in the History menu, just like others as Restore Previous Session and Recently Closed Tabs/Windows

Okulungisiwe ngu cor-el

more options

Thanks. I found it by reading a description on a Mozilla addons page. Why did nobody mention that something was moved from one menu to another in the release notes? I actually read the release notes page for FF 21 and there is not a word about that there. I rarely open the History menu, which is why I did not notice that item in there. I'll be opening that menu a lot more now.

more options

Can`t finde Clear private data in Firefox 21

more options

Hi terrace

Don't you see History > Clear Recent History?

more options

Thank You, My main problem is>Usually when I click on “clear search history” at the bottom of the drop down in Google search bar it clears everything as well as what`s in the search bar, but it`s not happening. Terry

more options

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

You can also try to uninstall Windows update KB2670838 if you have this update.