Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Image path displays instead of image

  • 25 uphendule
  • 3 zinale nkinga
  • 497 views
  • Igcine ukuphendulwa ngu Techie

more options

Firefox v20.0.1, Win7 32 bit. This web page ( http://zone.ni.com/devzone/cda/epd/p/id/5336 ) does not display the "flowchart"image at the bottom of the page immediately following the text "The following is a map of other documents..." On a correctly working page, the image is a flowchart "navigation" image that opens new pages depending on where you click on it. In firefox only a box with an ftp path to the image is displayed in its place. I have seen the problem on other web pages as well.

Actions taken: The pages displays correctly in IE v10. This problem happens on one computer. Different computer, same firefox version displays correctly. Different computer older firefox version (v17?) displays correctly.

  • I have tried disabling all plug-ins and extensions.
  • I have created a new profile. Seems like the first time I did this, the page displayed correctly, but when I refreshed (F5) the image is gone and the ftp path box is displayed. Subsequently created new profiles do not display the page correctly.
  • I have tried resetting Firefox and the page still is not displayed correctly.

Troubleshooting: Ctrl-shif-K, opened the Web Console, cleared the console output, refreshed the page by pressing Ctrl-F5. The following is several lines following the first error on the console:

[09:12:29.360] Unknown property '-moz-border-radius'. Declaration dropped. @ http://zone.ni.com/widgets/share/addthis/1.0/css/share.css:11

[09:12:29.360] Expected declaration but found '*'. Skipped to next declaration. @ http://zone.ni.com/widgets/share/addthis/1.0/css/share.css:13

[09:12:29.406] GET http://ct1.addthis.com/static/r07/core076.js [HTTP/1.1 200 OK 167ms]

[09:12:29.392] Unknown property 'size'. Declaration dropped. @ http://zone.ni.com/css/global/us/zoneprint.css:15

[09:12:29.392] Expected declaration but found '@bottom-center'. Skipped to next declaration. @ http://zone.ni.com/css/global/us/zoneprint.css:17

[09:12:29.497] GET http://zone.ni.com/css/global/us/thecore.css [HTTP/1.1 200 OK 26ms] [09:12:29.452] Expected identifier for class selector but found ' '. Ruleset ignored due to bad selector. @ http://zone.ni.com/css/global/us/thecore.css:115 [09:12:29.453] Error in parsing value for 'filter'. Declaration dropped. @ http://zone.ni.com/css/global/us/thecore.css:259

[09:12:29.453] Error in parsing value for 'cursor'. Declaration dropped. @ http://zone.ni.com/css/global/us/thecore.css:259

Any help is greatly appreciated.

Okulungisiwe ngu Techie

All Replies (20)

more options

It's not just an image, it's an image in a framed document where the iframe src is on an FTP server. So the issue is that for some reason the framed document is not loading for you at all.

I can't think of a reason for Firefox not to load the framed document.

Have you noticed issues with frames on other sites?

Have you saved a login for this FTP server in Firefox's saved passwords? You can check for (and delete) those here:

orange Firefox button (or Tools menu) > Options > Security > "Saved Passwords" button

more options

Actually, I could well be wrong that the framed document is not loading for you.

If you right-click in the document area > This Frame > Open frame in new tab, does that make any difference in whether the image displays?

Does Ctrl+Shift+r in that new tab make any difference?

more options

I don't think it is a password issue. On the other "test" computers, it is a brand new firefox install and I am not logged into the NI site and the page still displays correctly.

Right-click in the area >this frame> Open frame in new tab I get an Alert dialog box with message "550 That is not a directory".

Thanks.

more options

... but yes, I deleted any password even remotely related to any NI site. None of them were for ftp.

more options

If the new tab opens, do you notice any problems with the path in the URL bar, especially strange characters?

If the new tab doesn't open, if you copy the path from right-click > This Frame > View Frame Info, does it vary from this:

ftp://ftp.ni.com/pub/devzone/tut/mca_navigation1.html

more options

Sorry, yes the tab open before getting the Alert dialog, with the following in the url bar: ftp://ftp.ni.com/pub/devzone/tut/mca_navigation1.html/

Looks to be the same.

more options

It's the same except there should not be a slash at the end, because the document name is not a directory name. I wonder what is causing that???

more options

Yes, but if I remove the slash, and hit enter it does go to the ftp page, but then the url bar has a slash again. If you look at the source in a browser (IE) that works, the iframe url does not have the slash at the end. Also the page source at the location of the image says the following but yet still displays correctly : [Your user agent does not support frames or is currently configured not to display frames. However, you may visit <a href="ftp://ftp.ni.com/pub/devzone/tut/mca_navigation1.html">the related document.]" Also, if I click on the image itself and click view source, it shows that the image is an html map.

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Thanks cor-el & jscher2000 for your input. I have lots and lots of bookmarks to that site. I don't want to loose them all. I sometimes use the history too. Cookies and cache I have tried clearing. I have also created a new profile as well as performed a firefox reset. Remember also, if I create a new profile visit the page, it displays correctly the first time. It may be totally unrelated. IDK.

more options

You may only need to remove data from the ftp.ni.com domain.

Does this still happen if you open this file from the containing directory?

more options

The link ftp://ftp.ni.com/pub/devzone/tut/ opens fine when pasted in the url box. Also, when the image is not being display, the box contains "Index of ftp://ftp.ni.com/pub/devzone/tut/mca_navigation1.html/" then a link below it that says "Up to higher level directory" and with that same link. When I click on that the same box that should contain the image now "becomes" an ftp folder browser.

I did the forget about this site on the ftp.ni.com. Reloaded the page with Ctrl-F5. Still does not display correctly.

Wouldn't all this be cleared when starting fresh with a new profile and/or reset anyways?

more options

You can try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

cor-el: already tried that. See initial posting. Creating a new profile, the first time I visit the site it displays correctly. Refresh then the page is never displayed correctly again.

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

Having trouble with boot to safe mode. After windows login screen displays it reboots itself. Tried Flashed something about a profile the first time but have not seen the message again... in issue for another day.

An interesting thing: Created a new firefox profile. Launched into it. History is empty as expected. Visit the site 1st time, displayed fine. Visit 2nd time, does not display correctly. Clear the history by selecting the site in history and clicking forget about this site. Visit the site again - now displays fine.... but only the first time when it has no history. Odd

more options

Does clearing the cache has this same effect?

more options

Oops. I did a windows safe mode boot.... Firefox -safe-mode behave exactly like normal mode with my default profile. Regarding my interesting observation above with the new profile: Clearing the cache has no effect, i.e. the page is not displayed correctly the second time. Another note, simply clearing the history does not "fix" the issue. Only if I click "forget about this site" will the page display correctly the first time after doing so. What does "forget about this site" do that deleting the history entry does not? Remember, that this a brand new clean profile, with nothing else in the history, or cache for that matter. Thanks again.

more options

Clarification: I tested the same "forget about this site" (on ftp.ni.com) in my default profile. This has not effect, i.e. the page is still never displayed correctly. Forget about this site only "fixes" the issue with my new, test profile.

more options

Now my second test computer with brand new firefox install is exhibiting the same problem. Doing a "forget about this site" does not remedy the problem, ie. it will no longer display the page correctly.

  1. 1
  2. 2