Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Very slow page loading (30 sec - 1 min) after installing FF 18+

  • 5 uphendule
  • 2 zinale nkinga
  • 1 view
  • Igcine ukuphendulwa ngu cor-el

more options

Every FF after 17 has this effect of slowness for me. I have tried it on different sites with no great difference except that the more the content in a site the longer it will take to load. I have tried to:

1. Change profile 2. Turn off AV 3. Remove Addons / Extensions 4. Disable Javascript 5. Disable Hardware Acceleration 6. Run it on Safe Mode and other things suggested in here.

Nothing changed. This is strange because I've never had problems with FF.

The only thing that comes in my mind and something for the Developers to pay attention to, might be the new Javascript engine IonMonkey, the only major change that happened on FF, between version 17 and 18 may be responsible for the slowness!

All Replies (5)

more options

hello, such issues are sometimes caused by a firewall/security software which doesn't recognize a new firefox version properly: Fix problems connecting to websites after updating Firefox

more options

Do you have that problem with Firefox 20??

http://www.mozilla.org/en-US/firefox/fx/#desktop

more options

How much physical memory do you have?

If you run out of physical memory and the OS starts swapping to the page file then this will seriously impact performance.

more options

Thank you all for your suggestions. But I've tried all these things already.

@philipp it's not a firewall or AV issue. As I mentioned before, I've tested it out many times turning the AV off completely.

@the-edmeister yes FF 20 has the same problem for me. I've just tried it: version 12 to 17 work fine, while 18 to 20 generate the problem I've said.

@cor-el I have 2GB, but rarely exceeds 400M, and FF isn't using more than 160M memory while having this issue.

more options

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Sometimes you only disable the user interface of security software, but the firewall or anti-virus services are still running in the background.