X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 19 does not honor lockPref settings

Kuphostiwe

Since several months I have successfully used "lockPref" to lock settings (specifically, proxy settings) on Firefox 17 and Firefox 18.
I am running Ubuntu 10.04, and I have used the file:
/etc/firefox/pref/firefox.js.
Firefox 17 did not always honor those settings. Often it did, sometimes it did'nt. I also found that there is another file location some people are using (?), and this is:

usr/lib/firefox/defaults/preferences/vendor-firefox.js 

To be sure, I put my settings into both of them. With Firefox 18, it did honor those settings. So this was working well.
(Note - I have NOT used any byteshifting or anything, as one can read was necessary for old versions of Firefox. There being no clear documentation by version, I feel I have no way to tell if this is actually still required or not. It was working without any byteshifting on Firefox 17 and 18.)

I just upgraded to Firefox 19 - and voila (of course, I might say) again the settings are not being honored. This time they are NEVER honored. They are JUST IGNORED, EVERY TIME.

This is very upsetting - can someone please point out what is now changed?
Do I now need to use yet another configuration locking file location?
Or do I suddenly need to do this byteshifting thing - if so what is the procedure right now for this?

Settings I am trying to lock are:

//set proxy server settings
lockPref("network.proxy.http", "a.b.c.d");
lockPref("network.proxy.http_port", yy);
lockPref("network.proxy.https", "a.b.c.d");
lockPref("network.proxy.https_port", yy);
lockPref("network.proxy.no_proxies_on", "localhost, 127.0.0.1");
lockPref("network.proxy.type", 1);

Since several months I have successfully used "lockPref" to lock settings (specifically, proxy settings) on Firefox 17 and Firefox 18.<br /> I am running Ubuntu 10.04, and I have used the file:<br /> /etc/firefox/pref/firefox.js. <br /> Firefox 17 did not always honor those settings. Often it did, sometimes it did'nt. I also found that there is another file location some people are using (?), and this is:<br /> usr/lib/firefox/defaults/preferences/vendor-firefox.js <br /> To be sure, I put my settings into both of them. With Firefox 18, it did honor those settings. So this was working well.<br /> (Note - I have NOT used any byteshifting or anything, as one can read was necessary for old versions of Firefox. There being no clear documentation by version, I feel I have no way to tell if this is actually still required or not. It was working without any byteshifting on Firefox 17 and 18.)<br /> <br /> I just upgraded to Firefox 19 - and voila (of course, I might say) again the settings are not being honored. This time they are NEVER honored. They are JUST IGNORED, EVERY TIME.<br /> <br /> This is very upsetting - can someone please point out what is now changed? <br /> Do I now need to use yet another configuration locking file location?<br /> Or do I suddenly need to do this byteshifting thing - if so what is the procedure right now for this?<br /> <br /> Settings I am trying to lock are:<br /> <br /> //set proxy server settings<br /> lockPref("network.proxy.http", "a.b.c.d");<br /> lockPref("network.proxy.http_port", yy);<br /> lockPref("network.proxy.https", "a.b.c.d");<br /> lockPref("network.proxy.https_port", yy);<br /> lockPref("network.proxy.no_proxies_on", "localhost, 127.0.0.1");<br /> lockPref("network.proxy.type", 1);

Okulungisiwe ngu cor-el

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • The Adobe Reader plugin is used to enable viewing of PDF and FDF files from within the browser.
  • Shockwave Flash 11.2 r202
  • The next generation Java plug-in for Mozilla browsers.

Isisebenziso

  • Firefox 19.0.2
  • Umsebenzisi oyi-ejenti: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
  • I-URL Yokweseka: http://support.mozilla.org/1/firefox/19.0.2/Linux/en-US/

Izandiso

  • 1-Click YouTube Video Downloader 2.0.4 (YoutubeDownloader@PeterOlayev.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Ubuntu Firefox Modifications 2.6 (ubufox@ubuntu.com)

I-Javascript

  • incrementalGCEnabled: True

Imidwebo

  • adapterDescription: GLXtest process failed (exited with status 1): GLX extension missing
  • adapterDeviceID:
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID:
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'<Anything with EXT_texture_from_pixmap support>']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerType: Basic

Okuthandwayo Okulungisiwe

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 25600
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 348160
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: www.google.com
  • browser.startup.homepage_override.buildID: 20130307164200
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364424493
  • places.history.expiration.transient_current_max_pages: 22125
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False

Misc

  • Umsebenzisi JS: Cha
  • Ukufinyeleleka: Cha
cor-el
  • Top 10 Contributor
  • Moderator
17764 izisombululo 160655 izimpendulo
Kuphostiwe

Use a mozilla.cfg file in the Firefox program folder to lock prefs or specify new (default) values.

Place a file local-settings.js in the defaults\pref folder where you also find the file channel-prefs.js to specify using mozilla.cfg.

pref("general.config.filename", "mozilla.cfg");
pref("general.config.obscure_value", 0); // use this to disable the byte-shift

See:

These functions can be used in the mozilla.cfg file:

defaultPref();  // set new default value
pref();         // set pref, but allow changes in current session
lockPref();     // lock pref, disallow changes

See also:

Use a mozilla.cfg file in the Firefox program folder to lock prefs or specify new (default) values. Place a file local-settings.js in the defaults\pref folder where you also find the file channel-prefs.js to specify using mozilla.cfg. pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 0); // use this to disable the byte-shift See: *http://kb.mozillazine.org/Locking_preferences These functions can be used in the mozilla.cfg file: defaultPref(); // set new default value pref(); // set pref, but allow changes in current session lockPref(); // lock pref, disallow changes See also: *http://mike.kaply.com/2012/03/16/customizing-firefox-autoconfig-files/ *http://mike.kaply.com/2012/03/22/customizing-firefox-advanced-autoconfig-files/

Umnikazi wombuzo

Did not work for me - I need the DEFAULT settings for ALL USERS. So when a new user account gets created, then it should take the defaults from there. As mentioned above, it does "mostly" files you put into etc-firefox-pref- folders.

Did not work for me - I need the DEFAULT settings for ALL USERS. So when a new user account gets created, then it should take the defaults from there. As mentioned above, it does "mostly" files you put into etc-firefox-pref- folders.
cor-el
  • Top 10 Contributor
  • Moderator
17764 izisombululo 160655 izimpendulo
Kuphostiwe

Maybe it is best to continue the conversation in your other thread about locking prefs, so I'm closing this thread.

Please continue here:

Maybe it is best to continue the conversation in your other thread about locking prefs, so I'm closing this thread. Please continue here: *[[/questions/962844]]