Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The context menu is HUGE!

  • 9 uphendule
  • 51 zinale nkinga
  • 8002 views
  • Igcine ukuphendulwa ngu gsravan4

more options

I was just auto-upgraded to Firefox 20.0, and what had been an orderly, cascading context menu is now a flat, broken menu that's so big it scrolls off the top and bottom of my screen. The cascading submenus have been crammed into the top layer, and many of those options are now broken. Furthermore, options/menus that had been, well, context-sensitive (that is, they only appeared in certain circumstances) are now always-on. For instance, right-clicking on a link gives me the link-related options I'd expect, but it also gives me irrelevant media-control (Play, Pause, etc.) and image-related (View, Reload, Copy location) options.

Isisombululo esikhethiwe

Here's what DID work:

1. Disabled all of my extensions, in small batches. Turned out Firebug was at least one of the culprits. 2. Searched for updated versions of all extensions, installing those updates before enabling them again. 3. Enabled the extensions, again in small batches. Problem resolved.

Now my question is, why is there no easy/automatic way to accomplish step 2? Firefox can update itself, but it can't tell me there's a new version of one of my addons?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 25

All Replies (9)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Isisombululo Esikhethiwe

Here's what DID work:

1. Disabled all of my extensions, in small batches. Turned out Firebug was at least one of the culprits. 2. Searched for updated versions of all extensions, installing those updates before enabling them again. 3. Enabled the extensions, again in small batches. Problem resolved.

Now my question is, why is there no easy/automatic way to accomplish step 2? Firefox can update itself, but it can't tell me there's a new version of one of my addons?

more options

For extensions like Firebug that are installed from the Mozilla add-ons site, Firefox can check for updates. The option to do that automatically has moved from the Options dialog to the Add-ons page, "gear" menu.

But there are some extensions that are installed through third party software, or from other sites, and I suspect Firefox doesn't have a built-in mechanism to find updates for those.

more options

Oddly enough, I already had that option selected...and yet, about half of my add-ons were still out of date. All the updates I found came from the Add-ons site, too.

more options

I had the same issue, and the only thing that fixed it for me was upgrading firebug. I disabled, it made the menu small again, re-enabled, re-made the menu big, so ended up upgrading firebug from 1.10 to 1.11.2 (or something). As RevBob said, I too seem to have had the option 'check for updates' enabled but didn't get my firebug automatically updated.

Thanks for the solution, it was a really annoying issue.

more options

You can install the "Menu Editor addon" to view and show the items of the context menu. here is the link https://addons.mozilla.org/en-US/firefox/addon/menu-editor/

more options

nasir8891, this extension would not help fixing a context menu that was made broken by a older version of Firebug extension.

more options

This worked for me - thanks!

FWIW, the only difference was that I disabled each of my firebug-related extensions (tools > add-ons > extensions), then restarted FF and re-enabled them each, one by one, restarting after each one. Fixed it in under a minute :)

more options

The Solution is here...i tired it out successfully

https://addons.mozilla.org/en-US/firefox/addon/menu-editor/