X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I turn off Private Browsing?

Kuphostiwe

I turned on my notebook this morning to find Private Browsing on and Firefox reset to the default appearance. I can't find out how to turn this browsing feature off! Read the articles, looked at Community forum ... nada. Please help! I want my own Firefox back!

I turned on my notebook this morning to find Private Browsing on and Firefox reset to the default appearance. I can't find out how to turn this browsing feature off! Read the articles, looked at Community forum ... nada. Please help! I want my own Firefox back!

Isisombululo esikhethiwe

Firefox 20 has made some major changes in this area. If you are automatically in private browsing mode, it could be related to your history setting.

purple Firefox button (or Tools menu) > Options > Privacy

If you have Firefox will "Never remember history" that could cause this problem. Change to "Use custom settings for history" and uncheck the box for "Always use private browsing mode".

Does that work? You might need to restart Firefox in order to escape, as I don't see a way to change a private window into a regular window.

Note that I'm just exploring this change right now, and there's a good chance more knowledgeable people will chime in!

Funda le mpendulo ngokuhambisana nalesi sihloko 19

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • SiteAdvisor
  • McAfee MSC FF plugin DLL
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

Eminye Imininingwane

jscher2000
  • Top 10 Contributor
8758 izisombululo 71655 izimpendulo
Kuphostiwe

Hi zakinbristol,

If you switch to "Use custom settings" and uncheck "Always use private browsing mode" that should work. If that doesn't stick, could you check this article: How to fix preferences that won't save.

Hi zakinbristol, If you switch to "Use custom settings" and ''uncheck'' "Always use private browsing mode" that should work. If that doesn't stick, could you check this article: [[How to fix preferences that won't save]].
dc1313 0 izisombululo 2 izimpendulo
Kuphostiwe

Thanks for this answer it helped turn off private browsing. This oddly allowed by graphic theme to show up as well as soon as I was able to turn off private browsing. Also after the fact my history was stuck in "remember my history." This was until I selected "Custom, unchecked a pre-selected box (which did not prompt me to restart) but I did anyway. That finally allowed me to keep my history setting in custom mode.

Thanks for this answer it helped turn off private browsing. This oddly allowed by graphic theme to show up as well as soon as I was able to turn off private browsing. Also after the fact my history was stuck in "remember my history." This was until I selected "Custom, unchecked a pre-selected box (which did not prompt me to restart) but I did anyway. That finally allowed me to keep my history setting in custom mode.
cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

The "Use custom settings for history" choice allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.
Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.
If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".

The "Use custom settings for history" choice allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings.<br /> Firefox shows the "Use custom settings for history" selection as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.<br /> If all History settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History".
ariel 0 izisombululo 46 izimpendulo
Kuphostiwe

hi, jscher2000,

this is in response to Kpka's questions and your's relating to private browsing. earlier today, i commented in the help section/private browsing about why firefox 20.0.1 provides a helpful response about how to turn on pvt. browsing, but fails to inform users how to turn it off--and does't tell us that pvt. browsing no longer is accessed with "tools," but with the "file" tab.

hard to believe that mozilla, which nicely explains its unresolved bugs, ignores something as important as turning off a long-standing feature.

as i recall, in earlier versions, like 19xxx and before, a user easily could delete prvt. browsing with "non-private" browsing still intact.

let us know if you discover the answer.

thanks to you and Kpka.

have a good weekend.

hi, jscher2000, this is in response to Kpka's questions and your's relating to private browsing. earlier today, i commented in the help section/private browsing about why firefox 20.0.1 provides a helpful response about how to turn on pvt. browsing, but fails to inform users how to turn it off--and does't tell us that pvt. browsing no longer is accessed with "tools," but with the "file" tab. hard to believe that mozilla, which nicely explains its unresolved bugs, ignores something as important as turning off a long-standing feature. as i recall, in earlier versions, like 19xxx and before, a user easily could delete prvt. browsing with "non-private" browsing still intact. let us know if you discover the answer. thanks to you and Kpka. have a good weekend.
ariel 0 izisombululo 46 izimpendulo
Kuphostiwe

should read yours'.

should read yours'.
cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

Did you look at this knowledge base article?

Make sure that you select the correct Firefox version and Operating System.

Did you look at this knowledge base article? *https://support.mozilla.org/kb/Private+Browsing Make sure that you select the correct Firefox version and Operating System.
ariel 0 izisombululo 46 izimpendulo
Kuphostiwe

hi, cor-el, thanks for your good work in keeping an eye on what mozilla is up to with firefox.

i always use the latest version. whenever it's announced, i download it when ever it's announced [which may be stupid, given this example]. and i have read, and still read the appropriate kbase articles.

but, i cannot fathom why you and your colleagues either refuse to answer my--and others'--question about why users cannot turn off private browsing. do you remember that ff 19 allowed us to leave p.browsing by a mouse click?.

if you don't know, please tell us. if ff screwed up, please tell us.if you're aware of what, if anything, firefox is doiing to resolve this issue. and if you know that ffox is not addressing this, please tell us.

turning anything on or off shouldn't be an alien principle. .

now, i must revert to v.19, despite firefox warnings about doing so.

thanx firefox for continuing to make simple tasks so difficult.

have a weekend, cor-el

hi, cor-el, thanks for your good work in keeping an eye on what mozilla is up to with firefox. i always use the latest version. whenever it's announced, i download it when ever it's announced [which may be stupid, given this example]. and i have read, and still read the appropriate kbase articles. but, i cannot fathom why you and your colleagues either refuse to answer my--and others'--question about why users cannot turn off private browsing. do you remember that ff 19 allowed us to leave p.browsing by a mouse click?. if you don't know, please tell us. if ff screwed up, please tell us.if you're aware of what, if anything, firefox is doiing to resolve this issue. and if you know that ffox is not addressing this, please tell us. turning anything on or off shouldn't be an alien principle. . now, i must revert to v.19, despite firefox warnings about doing so. thanx firefox for continuing to make simple tasks so difficult. have a weekend, cor-el
MISTERAMD 1 izisombululo 15 izimpendulo
Kuphostiwe

Maybe try editing the userChrome.css file.

# context-openlinkprivate {
	display: none !important;
}

Than save and restart Firefox / Cyberfox. (Make sure to remove the + next to #, as it was autoturning the text into a numbered list somehow)

(fixed code - c)

Maybe try editing the userChrome.css file. <pre><nowiki># context-openlinkprivate { display: none !important; }</nowiki></pre> Than save and restart Firefox / Cyberfox. (Make sure to remove the + next to #, as it was autoturning the text into a numbered list somehow) ''(fixed code - c)''

Okulungisiwe ngu cor-el

ariel 0 izisombululo 46 izimpendulo
Kuphostiwe

hi, have read and learned from your forum posts. but...i just switched to firefox 21, and, like ff20 before it, no simple way exists to close private browsing mode when you're in it. i still cannot fathom why the ff staff will not publish a simple "how-to." [it already shows users how to engagage private browsing; why not how to close it?]

i've always selected "use custom settings to history," without any affect. and i've never selected, "always use private browsing mode."

by any chance, do you have a definitive answer?

thanx!

hi, have read and learned from your forum posts. but...i just switched to firefox 21, and, like ff20 before it, no simple way exists to close private browsing mode when you're in it. i still cannot fathom why the ff staff will not publish a simple "how-to." [it already shows users how to engagage private browsing; why not how to close it?] i've always selected "use custom settings to history," without any affect. and i've never selected, "always use private browsing mode." by any chance, do you have a definitive answer? thanx!
cor-el
  • Top 10 Contributor
  • Moderator
17521 izisombululo 158427 izimpendulo
Kuphostiwe

You will have to close all Private Browsing mode windows to leave Private Browsing mode because now PB is entered on a window base and you can have both normal and PB windows open at the same time.
This also makes it possible to quickly check another email account while leaving the main account open.

Future Firefox versions will support Private Browsing per tab, this is already available as an extension.

The Firefox menu button gets purple or you get a purple PB mask on the menu bar or tab bar (Linux) if you are in a PB tab and all Private Browsing mode tabs get a dashed underlining unless you are in permanent PB mode.

You will have to close all Private Browsing mode windows to leave Private Browsing mode because now PB is entered on a window base and you can have both normal and PB windows open at the same time.<br /> This also makes it possible to quickly check another email account while leaving the main account open. Future Firefox versions will support Private Browsing per tab, this is already available as an extension. *Private Tab: https://addons.mozilla.org/firefox/addon/private-tab/ The Firefox menu button gets purple or you get a purple PB mask on the menu bar or tab bar (Linux) if you are in a PB tab and all Private Browsing mode tabs get a dashed underlining unless you are in permanent PB mode.