X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox is unable to load Mega?

Kuphostiwe

ok, this is my problem. i want to load some files to the Mega filesystem (mega.co.nz) but the page doesn't load (Timeout error), sometimes it loads but when i want to upload files, a pop-up appears telling me that my web browser is outdated, and i should try using chrome, ok, i have installed chrome, and the upload works perfectly, but i dislike chrome because some of it functions, there is any way to load files to Mega using firefox?

ok, this is my problem. i want to load some files to the Mega filesystem (mega.co.nz) but the page doesn't load (Timeout error), sometimes it loads but when i want to upload files, a pop-up appears telling me that my web browser is outdated, and i should try using chrome, ok, i have installed chrome, and the upload works perfectly, but i dislike chrome because some of it functions, there is any way to load files to Mega using firefox?

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • Unity Player 3.5.6f4
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Battlefield Play4Free Updater
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • np-mswmp

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

Eminye Imininingwane

ideato 893 izisombululo 6250 izimpendulo
Kuphostiwe

Hello UMadMan, try https://mega.co.nz/


thank you

Hello UMadMan, try https://mega.co.nz/ thank you
chiaroscuro 1 izisombululo 6 izimpendulo
Kuphostiwe

I have the same problem - Firefox 18.0.1 - Windows 7 pro. I try https://mega.co.nz/ , and it loads most of the page (I can see the source) but it never renders the page - just a white screen with a grey horizontal (progress?) bar. No error messages, I tried it in "safe" mode, cleared my cache, - nothing. At the bottom bar it says "transferring data from mega.co.nz ..."

Chrome loads the page fine, but I don't like chrome.

I have the same problem - Firefox 18.0.1 - Windows 7 pro. I try https://mega.co.nz/ , and it loads most of the page (I can see the source) but it never renders the page - just a white screen with a grey horizontal (progress?) bar. No error messages, I tried it in "safe" mode, cleared my cache, - nothing. At the bottom bar it says "transferring data from mega.co.nz ..." Chrome loads the page fine, but I don't like chrome.
chiaroscuro 1 izisombululo 6 izimpendulo
Kuphostiwe

Can you post it to a site that doesn't make me take a marketing survey to download the file? I'm not giving spammers my email address.


EDIT* Since it seems like I can't delete this post, it was in answer to some "top 10 contributor" who posted a link to a .pdf file on a site that wants you to take a survey and give your email address to download a file! He then deleted the post.

Can you post it to a site that doesn't make me take a marketing survey to download the file? I'm not giving spammers my email address. EDIT* Since it seems like I can't delete this post, it was in answer to some "top 10 contributor" who posted a link to a .pdf file on a site that wants you to take a survey and give your email address to download a file! He then deleted the post.

Okulungisiwe ngu chiaroscuro

odradek2298 0 izisombululo 1 izimpendulo
Kuphostiwe

The same problem. Use Firefox 18.0.1

https://mega.co.nz/#blog_1 Mozilla Firefox 18: Carefully avoids providing any API that would allow writing files from JavaScript.

The same problem. Use Firefox 18.0.1 https://mega.co.nz/#blog_1 ''Mozilla Firefox 18: Carefully avoids providing any API that would allow writing files from JavaScript.''
wheng 0 izisombululo 2 izimpendulo
Kuphostiwe

I have the same problem as chiaroscuro has (just a white screen with a grey horizontal (progress?) bar)

I have the same problem as chiaroscuro has (just a white screen with a grey horizontal (progress?) bar)
user847169 0 izisombululo 22 izimpendulo
Kuphostiwe

Do not know if that is the reason, but it is said Mega Site creators have made the site mostly compatible with google chrome...

There is a firefox mega plugin available, take a look :)

Do not know if that is the reason, but it is said Mega Site creators have made the site mostly compatible with google chrome... There is a firefox mega plugin available, take a look :)
wheng 0 izisombululo 2 izimpendulo
Kuphostiwe

Thx for the reply SaphirJD.

There idd is a problem it seems with uploading and downloading files from Mega with Firefox, but the problem stated here is that the site just won't open. I have the plugin but the plugin won't work if the site does not even open :)

Thx for the reply SaphirJD. There idd is a problem it seems with uploading and downloading files from Mega with Firefox, but the problem stated here is that the site just won't open. I have the plugin but the plugin won't work if the site does not even open :)
SebastianA 0 izisombululo 1 izimpendulo
Kuphostiwe

I'm getting a similar issue, but in the last day or two an error (of some sort) has started appearing when I try to access mega.co.nz.

"Your browser does not allow data to be written. Please make sure you use default browser settings."

Clicking OK on that comes up with a big "Download Chrome!" prompt so yeah no.

Firefox 18.0, tried disabling addons like greasemonkey and adblock, and enabled flash and java, no difference.

I do like to mess around in about:config but not without valid reasons, so I have no idea which (if any) of the things I've changed cause this. It's happening on my work laptop and home desktop so it's not something random, it's some intentional change it's not liking.

Is it possible that it's due to disabling or blocking flash supercookies?

edit: Just tried allowing sites to store data in Flash but no change.

I'm getting a similar issue, but in the last day or two an error (of some sort) has started appearing when I try to access mega.co.nz. "Your browser does not allow data to be written. Please make sure you use default browser settings." Clicking OK on that comes up with a big "Download Chrome!" prompt so yeah no. Firefox 18.0, tried disabling addons like greasemonkey and adblock, and enabled flash and java, no difference. I do like to mess around in about:config but not without valid reasons, so I have no idea which (if any) of the things I've changed cause this. It's happening on my work laptop and home desktop so it's not something random, it's some intentional change it's not liking. Is it possible that it's due to disabling or blocking flash supercookies? edit: Just tried allowing sites to store data in Flash but no change.

Okulungisiwe ngu SebastianA

chiaroscuro 1 izisombululo 6 izimpendulo
Kuphostiwe

SebastianA, I just retried it, and got the same message as you described. Previously I got the blank screen (see above). Maybe Mega has added an error msg. for the problem I was having before? Can anyone here access the site with FF 18.0.2?

I'd switch to Chrome in a minute, if their handling of bookmarks wasn't so wonky.

SebastianA, I just retried it, and got the same message as you described. Previously I got the blank screen (see above). Maybe Mega has added an error msg. for the problem I was having before? Can anyone here access the site with FF 18.0.2? I'd switch to Chrome in a minute, if their handling of bookmarks wasn't so wonky.
chiaroscuro 1 izisombululo 6 izimpendulo
Kuphostiwe

OK, I figured it out - at least on my system, which is Win7 Pro, Firefox 18.0.2.

I went in and initialized the config file by renaming 'prefs.js', which starts out like a first time install of FF. It did reload all my plugins though, which was nice. Lo and behold, Mega loaded just like in Chrome - I was able to sign in to my account, upload and download files. Then I went into the FF preferences and set everything the way I like it, and I broke it again. I tried again with prefs.js.

Getting to the point, I determined that the problem was that under the 'privacy' panel in 'tools/options' I had third party cookies set to 'ask me every time', which is how I have had it set for years. I set it to clear them when FF closes and it worked again.

This setting also made it impossible to play videos on vimeo.com.

Also if you are running the 'noscript' plugin, you should allow the whole site.

I hope this works for some of you others.

OK, I figured it out - at least on my system, which is Win7 Pro, Firefox 18.0.2. I went in and initialized the config file by renaming 'prefs.js', which starts out like a first time install of FF. It did reload all my plugins though, which was nice. Lo and behold, Mega loaded just like in Chrome - I was able to sign in to my account, upload and download files. Then I went into the FF preferences and set everything the way I like it, and I broke it again. I tried again with prefs.js. Getting to the point, I determined that the problem was that under the 'privacy' panel in 'tools/options' I had third party cookies set to 'ask me every time', which is how I have had it set for years. I set it to clear them when FF closes and it worked again. This setting also made it impossible to play videos on vimeo.com. Also if you are running the 'noscript' plugin, you should allow the whole site. I hope this works for some of you others.

Okulungisiwe ngu chiaroscuro

cor-el
  • Top 10 Contributor
  • Moderator
17687 izisombululo 160003 izimpendulo
Kuphostiwe

Note that such cookie issues can be caused because Firefox created an allow exception for a sub domain (xxx.mega.co.nz) of the website instead of for the main domain (mega.co.nz).
The solution in such a case is to create an allow exception yourself for the main domain.

The mega.co.nz server also makes use of a 128 bit RC4 cipher to connect securely instead of a 256 bit connection and doesn't work with all 128 bit ciphers disabled, so the server software could benefit from an update.

Note that such cookie issues can be caused because Firefox created an allow exception for a sub domain (xxx.mega.co.nz) of the website instead of for the main domain (mega.co.nz).<br /> The solution in such a case is to create an allow exception yourself for the main domain. The mega.co.nz server also makes use of a 128 bit RC4 cipher to connect securely instead of a 256 bit connection and doesn't work with all 128 bit ciphers disabled, so the server software could benefit from an update.
qwerty123456 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

The "Your browser does not allow data to be written. Please make sure you use default browser settings." error can be solved. Go to about:config and change dom.storage.enabled to true. https://mega.co.nz use supercookies.

The "Your browser does not allow data to be written. Please make sure you use default browser settings." error can be solved. Go to about:config and change dom.storage.enabled to true. https://mega.co.nz use supercookies.

Okulungisiwe ngu qwerty123456