Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

clear recent history tool is not working

  • 6 uphendule
  • 53 zinale nkinga
  • 10344 views
  • Igcine ukuphendulwa ngu bosshog25

more options

the clear recent history button does not work when clicked on

All Replies (6)

more options

Try switching to another persona. In order to switch to another persona that you had previously installed, do the following:

  1. Go to Tools and click Add-ons (or click the Firefox button at the top left and click Add-ons).
  2. Switch to the Appearance tab. You should find your previously used personas in the list.
  3. Find the one you want to use and click the Enable button.

To uninstall the other ones you can click the Remove button on them and they'll be uninstalled instantly.

more options

Hello caandrews, try to delete places.sqlite file (including "places.sqlite-journal" and any "places.sqlite.corrupt" files, if found) in profile folder and check it again.

see for more information : Locked or damaged places.sqlite


thank you

more options

I fixed this by moving from FF17 to 18. Nothing else seemed to work. I had to go to the Firefox download site - the automated updater failed too. I think the problem was caused by a failed update.

more options

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"
more options

I also recently had this problem. I discovered that the issue was related to computer issues corrupting my most recent update from Firefox. Re-downloading Firefox 19 got rid of the problem.

more options

In the Clear Recent History window, at the top, Make sure Time Range to Clear is set to Everything. After the update it must have set it to Last Hour Only automatically.