Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Java installed but not working

  • 45 uphendule
  • 364 zinale nkinga
  • Igcine ukuphendulwa ngu ChickenPants

more options

Hi, after updating to Java 7 update 10 Java stopped working. Plug in checker indicates Java Deployment Toolkit is installed correctly, but Java test page says plugin needed and Java Runtime Environment 1.7 u10 is available. Install fails. Uninstalled Java and tried manual install (including as administrator) but no resolution. All old Java versions have been uninstalled. Thank you for your time.

All Replies (20)

more options

Mega dittos to your comment...nothing is suggestion was Pale Moon browser for 64 bit, problem is just as bad or may be worse, does not look for plugin at all...

more options
more options

@nuwon - I was suspecting this may be the root of it. In my case I cannot use the workaround found here:

It's not installed as a plugin, so I cannot allow it. I can't install it.

ETA: This site indicates that JavaFX may be the root of the issue:

I have managed to get it installed, but it seems so far not be be operating like it should - and, unfortunately, I run applications which make it necessary to use this Java Junk.

2nd Edit - ok - the issue is resolved. I removed JavaFX as instructed in the link above and then removed all instances of Java. Then I reinstalled both the 32bit and 64bit versions of the latest Java found on their site. From there I have allow each site wanting to use Java to access the plugin, the instructions for which are found here:

I have spent the better part of a day looking for a fix. The registry stuff is nonsense. Get rid of JavaFX, uninstall all your installations of Java, reinstall the latest version of this cursed program and then you will be good.


ChickenPants is not so angry now.

Okulungisiwe ngu ChickenPants

more options

Chickenpants - I recognize an immense amount of work in order to "tip-toe thru the tulips" in Java. There has to be an easier, more universal fix to get Java to work. We both know that there are many more frustrated Java users (like us) out there frantically searching for a fix..

Oracle - time to get engage as owners of Java & present the community with a Java fix.

more options

Hi Stocktic,

Java seems like some ancient monster no one can really tame or kill off for good! I'd not waste my time with it but I use online shipping software daily and it's forced on me.  :(

Java likes to say "3 billion devices run Java"...I'd bet many don't do it well or really piss off their operators.

For software in 2013 to be a pain like this should be an embarrassment to Oracle. Maybe one day they will listen to the user base. The irony is that I found the workaround on a site unrelated to both Oracle and Mozilla O.o - what's that about?

more options

Guys, Mozilla has automatically disabled all versions of Java 7 for safety reasons after the recent vulnerability discovery. You should either downgrade to Java 6 or wait for Oracle to fix it.

more options

The problems started in Java 6.

more options

This worked for me (32-bit WinXp) : I just uninstalled JavaFX and didn't even need to reinstall the jdk.

Java is still globally disabled, but you can enable it on a site-by-site basis: cf.

Hope this helps...

Okulungisiwe ngu flavier

more options

deleted FX java files, and I can now run my java apps...

more options

Wait, you guys were running the JDK?

more options

Yes - Java has been disabled globally. However, the issue with the J7-10 update is related to JavaFX. I'm not running Java SDK - just plain old Java for consumers.

It's still necessary to enable the plugin to work with each site, but the trouble wasn't related to that. The trouble was with the fact that Java Runtime was not being seen by Firefox as an installed plugin. Removing JavaFX clears the roadblock.

Do what I've outlined in my solution, and the problem goes away.

more options

I do need the JDK sometimes, but if necessary, I will use a different computer for that. Where I am using the JDK, I do not use the latest JRE or JDK and I have no current problems...

Oracle, get these problems fixed or Java will be dropped by a lot of users...

more options

Well, at least until the vulnerability is patched, it might be better to uninstall the JDK and load the standard JRE. It will still be Click to Play blocked, though.

more options

More strangeness. I run the latest version of Thunderbird (updated today) and the latest version of Firefox (update yesterday). Firefox gives me a warning, but Thunderbird doesn't.

more options

Oracle has released a Java 7 Update 11 to address security vulnerabilities and you should update to that version.

See also:

You can find the latest Java version on the Oracle website.

See Java Platform > Java SE 7U11

more options

I think I will wait a little while...I do not believe this is a fix yet...I have heard the update to 12 is in beta and it has the problems as well...

more options

@Cor-El - thank you for the update information.

ChickenPants doesn't press his luck - he may be a birdbrain, but he has enough to sense to stop when he's ahead :) No V11 for him! In fact, no more Java updates at all!

Okulungisiwe ngu ChickenPants

more options

Installed Java 7 update 10 today (13th Jan 2013). Firefox reports no Java installed (grey box where Java content should be) and clicking on install text results in a failed automatic installation. Manual install of online or offline JRE fails. Looking at Add-ons does not include Java (™) Platform. Probable cause: Java plugins are blocked see list at: Solution: Navigate to C:/Program Files/Mozilla Firefox/ and locate blocklist.xml Rename to blocklist.old Return to non-functioning webpage and click install text in greyed out area. Java should now work (may need to reboot Firefox). Reame blocklist.old to blocklist.xml

Okulungisiwe ngu sheaton

more options

Sheraton - appreciate the Firefox work-around so as to gain access to Java apps thru Mozilla's browser. However, tweaking does not negate the security issue inherent in the Java code which is why Firefox is blocking Java's update.

I think it is inherent on Oracle (Java's parent) to act quickly. I have my Java turned off and only turn it on when I trust a site which I need access to.

more options

I have only two sites for which Java is required. Those are trusted sites. I haven't needed it otherwise.

  1. 1
  2. 2
  3. 3