Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

is there a Firefox version capable of supporting my MAC 10.4.11?

  • 2 uphendule
  • 25 zinale nkinga
  • 9328 views
  • Igcine ukuphendulwa ngu James

more options

I need a version of Firefox for my MAC 10.4.11 (which works - your forum replies indicate the suggested version does not) which I can then download. Thank you.

All Replies (2)

more options
more options

As of Firefox 4.0 and newer one needed Mac OSX 10.5+ and Intel. As of Firefox 17.0 and newer one needs OSX 10.6+

https://support.mozilla.org/en-US/kb/firefox-no-longer-works-mac-os-10-4-or-powerpc

Also not that the tenfourfox mentioned does not support Plugins due to being old/insecure on PPC Mac.


Okulungisiwe ngu cor-el