Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Latest Java update

  • 119 uphendule
  • 167 zinale nkinga
  • Igcine ukuphendulwa ngu Mr. News

more options

Hi, My Firefox plug-in check is telling me that there is an update for Java, but when I visit the link it's still taking me to the old update (the Java 7 update 9). Also, according to the Java test page, Java 7u9 is still showing that it's the says I have the recommended version.

Is there an newer update somewhere?


Hi, My Firefox plug-in check is telling me that there is an update for Java, but when I visit the link it's still taking me to the old update (the Java 7 update 9). Also, according to the Java test page, Java 7u9 is still showing that it's the says I have the recommended version. Is there an newer update somewhere? Thanks.

Isisombululo esikhethiwe

  • update*

It looks as though the issue has been fixed. When checked my plug-ins this evening, the 7u9 had corrected itself and is now displaying the actual update (7u10).

I've uninstalled the 7u9 completely and everything is checking out on FF! :)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 9

All Replies (20)

more options

See Java Platform > Java SE 7U10 or Java 6U38 (Download JRE)

more options

Thanks for the link, cor-el

     My Windows Vista is 32-bit. And the only Windows download that's available in the provided link says  "Windows x64." Is that referring to only those with 64-bit?


more options

These are the 32-bit download links on the download page.

Windows x86 Online 0.85 MB jre-7u10-windows-i586-iftw.exe
Windows x86 Offline 29.99 MB jre-7u10-windows-i586.exe

Okulungisiwe ngu the-edmeister

more options

Did you visit the download page?

It is best to download the full Windows x86 Offline version.

more options

Thanks, the-edmeister!

I have it saved and ready to install, but why are they making this update so complicated and difficult to find? Their test page is still telling me that I have the recommended version...this latest update has been tested, right?

more options

I have been on their download page, it's just extremely confusing for those of us who don't know what they're doing. :)

Cor-el, you mentioned the Offline version for download...I always though it was better to opt for the Online links?

Okulungisiwe ngu Alice_85

more options

I just tried to install the offline version of update 10. It looked as though it was successful, but when I checked it on Java's test page, it told me that I was missing a plug-in and it took me to a link for installing the update 9.

Should I try the offline version of 10?

more options

Try to uninstall the current Java 7U9 version if you have problems with updating.
That is probably also a lot faster and should install the new version in a few seconds..

more options

That's what I initially tried...

This is where I am right now. (Hopefully it's okay.)

I have installed the latest Java update (10). My plug-ins are now all up to date when checked on the Firefox plug-in page, and Java's test page shows that I have the latest version.

My only concern is that I had to reinstall Java 7 update 9 in order for it to work on Firefox. When I only had Java 7 update 10, Java's test page did not detect the Java prompted me to install Java 7 update 9. (Which I had previously uninstalled.)

Is it okay to have both? It was only Firefox that didn't seem to like the update 10. Safari and IE were fine.

{Based on the screenshot, it looks like we still need the SE 7 U 9.}

more options

Try to delete the pluginreg.dat file in the Firefox Profile Folder and maybe addons.sqlite as well to reset the plugin registry databases.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
more options

Okay, I deleted both (the pluginreg.dat file, and addons.sqlite).

I'm still seeing the same results as the screenshot above. As long as everything is telling me that I'm up to date, am I ok?

Thanks for helping me with this, cor-el. :)

more options


You may need to exit then restart your browser after updating Java in order for the correct Java version to show on the Plugin Check page. I found it necessary to do that. The only place that I found that advice is at the bottom of the following page (next the the "light bulb" icon) -

more options

TheOldFox, Thanks for the tip. I think that was one of the first things I tried this morning but it still kept taking me to update 9.

According to the Java test link you provided, I'm currently on version 1.7.0_10. I'm just confused as to why I had to reinstall update 9 in order for the Java plug-in to be detected.

Also, I looked at the link you provided in another thread and found some disturbing results. What are all those "Could Not Read's?"

Should I just unistall all Java downloads and start over?

more options

I am not familiar with or the tests that they run. I keep Java disabled in the Firefox instance that I use daily as I do not have a need for it. In another instance of Firefox on my system, I get the same errors as you are showing. You would need to inquire at that site about the meaning of those errors.

I have also noticed that not all of the Java/Oracle pages have been changed to point to the new Java 7u10 version as of a couple of hours ago. That may be leading to a lot of confusion for users. Maybe the folks at Oracle are just not quite "on the ball" with this update and the changes that they need to make on their website pages.

I did notice on your report from that it seems you have both Java 7u9 and Java 7u10 installed; shown on the "Java version" line on that report. You did not need to reinstall 7u9 if you downloaded the full JRE installer for Java 7u10 suggested by cor-el earlier -

  • Check in Windows Control Panel > Add or Remove Programs (or Programs and Features) to see if you have both versions installed. That should not be the case, but if you do try to remove Java 7u9.
  • Or, to get a clean start, try downloading and running JavaRa to remove all Java from your system, then install the JRE for Java 7u10 that cor-el suggested earlier. JavaRa download -

Okulungisiwe ngu TheOldFox

more options

Thanks @TheOldFox,

   I don't know if you read my previous posts, but when I uninstalled the 7u9, and installed the 7u10, Java's test site could not pick up on any Java plug-in. It kept asking me to install Java and would take me to a 7u9 update link.

It's only with both installs that it's detecting Java. (The odd thing is that Safari and IE were fine with just the 7u10.)

I'm terribly confused and befuddled. :P Am I okay as long as the Firefox plug-in check says that I'm up-to date?

more options

Download and run (with all browsers closed) JavaRa as I mentioned earlier. Restart your system. Then download and install the JRE for Java 7u10 as I mentioned earlier. Close all browsers before installing the new JRE. Restart your system after the install. Then test the Java version at both:


This Java update is not going smoothly for many users and I do not know the reason(s) for that. At this point, for you I think that best course of action would be to use JavaRa to remove all Java from your system and install the JRE for Java 7u10.

Okulungisiwe ngu TheOldFox

more options

I'll give it a go.  :) When I'm ready to reinstall the 7u10, should I opt for the offline version? (I think I chose the online version earlier.)

more options

Yes. The offline version is a full installer package. and be sure that you download the "i586" version, that is the 32-bit version needed by Firefox.

Okulungisiwe ngu TheOldFox

more options

I think Java 7u10 is seriously messed up. I was able to install it so it appears in Add/Remove Programs in the Control Panel, but no plugin appears in Firefox. The "Deployment Toolkit" plugin appears, but not the actual plugin.

I also download JavaRa 1.16 to uninstall 7u10 and try installing it again = it couldn't find the new version to remove it.

more options

Looks like the Firefox Plugin is missing, Java appears in IE8 and Opera 12.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5
  6. 6