Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When I click a known, working, link, why do I end up with a failed google search insgteaD OF GOING TO THE LINK ?

  • 13 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu wallyWEE

more options

For past 8 weeks or so, when I click on known links, bookmearks, even emails in my InBox, Firefox does not take me there. Instead I end up on a Google search page that says my question is too long - tough luck. Why ? How to stop it ? Rgds, Richard

All Replies (13)

more options


The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Do a malware check with some malware scanning programs on the Windows computer.
You need to scan with all programs because each program detects different malware.
Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Sorry, was posting my reply to wrong place. What I tried to say was :- Thanks cor-el and dumdidadida Unfortunately, neither provide the solution.

Below is what comes up when, by way of a single example out of many, I click on a mail in my In Box preview plane. NOT the mail opening for reading but a totally different Google web page which I have tried to copy below :-

(OF COURSE THE SEARCH REQUEST WAS TOO LONG - it was NOT a search request !) Google

413. That’s an error.

Your client issued a request that was too large. That’s all we know. Emacs! (PICTURE OF A BROKEN ROBOT)

I now THINK I know the cause. It happens always when internet connection is slow and never when on a fast connection. What I think is happening is that the secure google search from the address box is somehow being activated (instead of the usual - "page not found" dialogue).

I am now running with the search from address box feature disabled. RESULT It happens less often but has not stopped completely. Even on things like buying an on-line ticket can lead to the broken robot when clicking the pay now link !!!!!! QUESTION = HOW TO TURN OFF THE SECRET GOOGLE SEARCH IN FIREFOX ? Richard

more options

This can be caused by corrupted cookies.

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Okulungisiwe ngu cor-el

more options

Thanks again but it's not a problem relating to any specific sites. It can happen when opening Firefox on my home page or when clicking on any link (within Firefox or external). Because the link is a KNOWN, trusted, often used CORRECT, working link - it is often quite long

would be typical a typical example

3 things can then happen (A) I get to this page (B) I get the "Problem loading page" / "the connection has timed out message" This (B) can be annoying but is clear.

The problem is (C) the stupid broken robot telling me that is too long a search string for Google to find.

How to turn off these unwanted Google searches ? Richard

more options

You can disable keyword search by setting the keyword.enabled pref to false on the about:config page.

more options


more options

If you do not keep changes after a restart then see:

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
more options

We seem to be getting away from the question. Which is - Why, when totally uninvited does Google Search cut in when clicking links, bookmarks, even submit buttons on internet banking ?

more options

This could also be indicative of deep-rooted OS malware activity. If scanning with two or more different scanners didn't uncover anything you could also try the dedicated security forums:

more options

You seem to ignore what I now believe is the problem - which is a deep rooted uncontrollable function of Firefox. In so much as it appears to be impossible to completely switch off the Google Search function. Handy if you deliberately want to search directly from the Navigation Toolbar but a pain in the butt when it does it unasked. Richard

more options

What happens if you directly enter e.g. google search redirect in the location (address) bar, or the Search bar?

more options

When I enter google search redirect it opens a google search results page (even though searching that way is disabled).

BUT, the problem is NOT about what happens when I type something into the address bar (nor the search bar for that matter)

The problem IS when I have NOT typed anything anywhere. EG I compose a gmail and click "SEND" only to get directed to the broken google robot.