Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't open PDF files in Firefox 16.0.1

  • 5 uphendule
  • 57 zinale nkinga
  • 37556 views
  • Igcine ukuphendulwa ngu romad

more options

Mac OS 10.6.8, Firefox 16.0.1, PDF Viewer 0.6.39 installed. In Firefox>Preferences>Applications, PDFs are supposed to be handled by the PDF Browser 2.4.4 plug-in for Preview. However, when I try to view a PDF in Firefox, I get this:

"We are sorry, but Adobe Reader is unable to show documents in this browser configuration.

"Please use your browser to download this file and open it in Adobe Reader or Adobe Acrobat.

"To avoid this message in the future, many browsers provide a way to turn off certain add-ons, and some are able to show this document natively. Please contact your browser vendor for more details."

Why is Adobe Reader trying to open the PDF when Preview is the default? How do I disable Adobe Reader from doing anything in Firefox?

Isisombululo esikhethiwe

Try to disable the Adobe Reader plugin in Firefox (Tools > Add-ons > Plugins) and use the external Adobe Reader application or Preview application instead.

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 33

All Replies (5)

more options

If it is a plugin taking over, then you cannot control which one will be used. You could set up Preview as a helper application instead, and load the .pdf file into it to read it.

more options

Hello romad, try to Reset download actions by deleting mimeTypes.rdf in profile folder, then install Schubert|it plug in (it is specialy for mac) from : http://www.schubert-it.com/pluginpdf/

see : PDF files are blank and can't be downloaded on Mac


thank you

more options

finitarry,

It already is set up that way: "PDFs are supposed to be handled by the PDF Browser 2.4.4 plug-in for Preview."

ideato,

BTDT, no joy.

Okulungisiwe ngu romad

more options

Isisombululo Esikhethiwe

Try to disable the Adobe Reader plugin in Firefox (Tools > Add-ons > Plugins) and use the external Adobe Reader application or Preview application instead.

  • Firefox > Preferences > Applications > Adobe PDF document : Use Adobe Reader
more options

cor-el, you nailed it.

There was a plug-in called "Adobe Acrobat NPAPI". With that disabled and the PDF Browser Plugin 2.4.4 enabled, I can now open PDFs in Firefox.