Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

When Firefox opens, why are my bookmarks being restored?

  • 12 uphendule
  • 4 zinale nkinga
  • 37 views
  • Igcine ukuphendulwa ngu cor-el

more options

It used to be that - unless my Firefox process crashed - when I opened my browser it would open on my designated home page. That's what's in my options. But with the most recent version it restores all of the tabs that were open at the end of the last session. That's not the desired behavior and not the way I have my options set.

All Replies (12)

more options

What did you do last before opening up Firefox again? Or what did it do?

more options

Nothing that was out of the ordinary. I watch Netflix, check out espn.com now and then. I'll have four or five tabs open. I did nothing with the various options. In fact, my tab options are still set the same as they have been for what seems like years. But a couple of days ago, Firefox just started opening with whatever tabs had been open when I last shut it down. No crashes... just normal shutdown. When I fire it up, all of the tabs appear automatically... no pop-ups asking if that's what I want to do (which is what usually happens when there's a crash of some sort). That's about all I can tell you.

more options

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).

more options

Thanks cor-el. Gave that a try but no joy. My browser is still opening up with the tabs that were open at the end of the last session. I don't suppose this is a "feature" of the latest release, is it?

more options

Do you have any other applications open?

more options

Make sure that Firefox closes properly if sessions restore opens the tabs from the previous session.

Use "Firefox/File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit") to close Firefox if you are currently doing that by clicking the close X on the title bar.

See also:

more options

pstonier: Sometimes yes... sometimes no. Most of the time, Firefox is the last application to be closed before I shut down the computer.

Okulungisiwe ngu edwindrood

more options

cor-el: It's closing out properly. I made sure I closed using FILE/EXIT from the main menu. That didn't do any good. I also made sure that there weren't any hanging processes using the task manager. Nothing there that I could see. Firefox is behaving perfectly well in every way except this one. The product is behaving as if it's supposed to be doing this.

Okulungisiwe ngu edwindrood

more options

Tools->(Firefox button)-> Options->General->"Show my windows and tabs from last time"

To make sure, this is not selected right?

more options

james: That was the first thing I checked. That option is set to 'Show my home page'. I may have found a workaround. The product seems to lose my previous session's tabs if I go to Options\Privacy and check the 'Clear history when Firefox closes' check box.

more options

What Extensions do you have listed in Tools->Add-ons->Extension?

more options

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.