Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

After updating Firefox to version 16.0.1, it no longer works in conjunction with "Proxifier"...

  • 5 uphendule
  • 7 zinale nkinga
  • Igcine ukuphendulwa ngu sjshannon

more options


I'm using Firefox on Windows XP professional x64 SP2. I also use a program called "Proxifier" which directs all traffic from my computer to the Internet and vice versa through a proxy server and does the name resolution through proxy DNS not system DNS. Before updating my Firefox to v. 16.0.1, everything was working fine: Firefox connections were made through "Proxifier" and all the connections made by Firefox were shown in Proxifier's window.

But after updating Firefox, traffic from Firefox does not pass through Proxifier and in other words Firefox opens websites if I disable Proxifier. THIS IS NOT THE CASE WITH Internet Explorer which works fine and its traffic is directed through Proxifier as usual.

I did an extensive search through Google for a solution, and most relevant results suggest that it may have something to do with messed up LSP_CATEGORIES: link: and

Anyway, I tried uninstalling and reinstalling Firefox and Proxifier, resetting Firefox, resetting winsocks catalog (netsh int ip reset - netsh winsock reset) several times and tried the relevant suggestions in this link:

Also tried installing previous versions of Firefox such as v. 13 or 3.6.28 but the problem exists with these versions as well.

Unfortunately nothing has worked so far. I'm really puzzled since Internet Explorer is working fine with Proxifier and this problem with Firefox appeared only after updating it.

Can anyone suggest a solution?


Okulungisiwe ngu __Mick__

All Replies (5)

more options

hello, you probably have to set-up firefox to use a proxy to connect to the web:

more options

Thanks for the reply but unfortunately this is not the case, I have tested several times with "no proxy" , "system proxy" and "automatically detect proxy" settings in connection tab, problem still exists.

For using Proxifier there is no need to setup a proxy in Firefox, and everything was working fine before updating Firefox without setting up a proxy in Firefox. Even if I wanted to set up a proxy in Firefox it is not possible since my proxy server requires authentication (user, pass) which is only handled by Proxifier. As I mentioned earlier Internet Explorer is working fine without setting up a proxy and its traffic passes through Proxifier as expected.

The main thing is that Firefox traffic is not even passing through Proxifier which is very strange.

Okulungisiwe ngu __Mick__

more options

I am able to reproduce a similar problem as the original poster; the issue seems to stem from https traffic.

Scenario: FF v16.0.1

 Tools -> Advanced -> Network - Connection Settings
    Manual proxy configuration
       HTTP Proxy: Port 8080
       SSL Proxy: Port 8080

Proxy: Zed Attack Proxy (ZAP) v1.3.4


You will be prompted due to an invalid certificate for Accepting this certificate will allow all requests (http/https) to

However, any requests outside of that domain that are over HTTPS, such as css or js inclusions, you will not be prompted due to the invalid certificate and therefore your request will never be serviced.

You can clearly see within the proxy, only requests to http(s):// are proxied, but requests for css or js from or will not appear in the browser.

You can verify that the requests are made via the FireBug plugin, but FF isn't allowing the end-user to accept the invalid certificate.

more options


Thanks for the reply,

So what does this mean overall? Firefox bug? or any solution?

more options

I don't have any good workaround a for this as of right now...well, other than I turned off auto-updates as this bug effects my job since I use FF through a proxy most days...