Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 16.0.1 opens with a blank page even though my homepage has been set as default

more options

I upgraded to 16 and now the browser opens with a new page even though I have set the default to My homepage. I have tried several times to reset to the homepage but all without success.

Isisombululo esikhethiwe

See:

You can try to reset (power off/on) the router.


A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

It is possible that there is a problem with the files sessionstore.js and sessionstore.bak in the Firefox Profile Folder.

Delete the sessionstore.js file and possible sessionstore-##.js files with a number and sessionstore.bak in the Firefox Profile Folder.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost, so you will have to create them again (make a note or bookmark them).


You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

more options

Actually, this did not solve the problem. It did however, present another facet that I was not aware. The hyperlink sent me to a blank page as well. Still haven't figured the darn thing out. Thanks

more options

I'm having the exact problems as mentioned above. All setting were correct.

Homepage is set to my preferred website. However, when starting up Firefox, it just present a blank tab. When I click the HOME button, the homepage opens.

If I set my homepage to default, which is the simple Firefox search page that redirect go Google search, it opens fine.

The only thing is not working is when I set a preferred homepage. It does not open upon Firefox start up.

Done the suggestion above, but it did not solved the problem.

Any more suggestion?

more options

Isisombululo Esikhethiwe

See:

You can try to reset (power off/on) the router.


A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

more options

I don't have any firewalls, even the windows firewall is disabled. I even tried to exclude Firefox in my NOD32 antivirus but the same problem happen.

Tried to disabled the antivirus, but no changes.