Search Support

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

I cannot remove the "save as deal finder" pop ups

  • 4 uphendule
  • 54 zinale nkinga
  • 29846 views
  • Igcine ukuphendulwa ngu KayeMenner

more options

When I go to shopping sites such as Amazon, Ebay etc, and when I hover over a picture a "save as deal finder" pop up appears and I cannot remove this. I have searched on the net and cannot find any threads for this issue.

Isisombululo esikhethiwe

Try the following:

Scan for Malware

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try some of the following programs to scan for malware:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Reset Firefox

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 4

All Replies (4)

more options

Isisombululo Esikhethiwe

Try the following:

Scan for Malware

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try some of the following programs to scan for malware:

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Reset Firefox

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
more options

Go to Firefox - Add ons - Extensions then remove the one called 'save as'

more options

Thank you Tylerdowner for your Solution to remove "Save as Deal Finder". I ran Malwarebytes which detected it, but did not remove it, so I then went to your next step and Reset Firefox. Glad to say this worked and "Save as Deal Finder" has gone!