Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

The Awesome Bar stays on 'Go to a Web Site' on every page

  • 2 uphendule
  • 1 inale nkinga
  • 30 views
  • Igcine ukuphendulwa ngu cor-el

more options

I have Facebook as my first tab, pinned as an app tab, and Google as my homepage on the second tab. Whenever I start up Firefox, I can search Google and every other site, but the URL does not change in the Awesome Bar, just remains on 'Go to a Web Site', so it does not track my history, and does not allow me to go backward/forward through pages. All other tabs work just fine. Also the tab will not be closed sometimes, or Firefox will act like the tab doesn't exist when I scroll through them. Have tried some add-on disabling and I cant find the root of the problem.

Any help appreciated

All Replies (2)

more options

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

You can check for problems with the localstore.rdf file.


Try to remove the Firefox plist file (org.mozilla.firefox.plist).

Go to "~/Library/Preferences" and remove the plist file for Firefox (org.mozilla.firefox.plist)