Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Can't restore Firefox version 14.0.1 bookmarks on a version 15.0.1 browser

  • 3 uphendule
  • 2 zinale nkinga
  • 30 views
  • Igcine ukuphendulwa ngu cor-el

more options

Using Sync on my v15.0.1 Firefox browser wiped my bookmarks completely even on the Sync server. So I had an old laptop with the v14.0.1 browser that has a slightly old version of my bookmarks. I saved those bookmarks as a JSON and an HTML backup but neither is able to be loaded on my v15.0.1 browser. I disconnected the v15 browser from Sync and am now just trying to get my bookmarks read from one of those file formats.

When I try the reading in from the Library > Import and Backup > Restore > Choose File menu item I see the 'this will replace all of your bookmarks' warning then a dialog that says "unable to process the backup file". If I try Library > Import and Backup > Import Bookmarks from HTML I see no error dialog but no bookmarks appear either.

How do you get bookmarks read from a file into a v15.0.1 browser?

All Replies (3)

more options

Sorry to hear about Sync. I think the service sometimes is not clear on which direction is the one you want to sync in, but I haven't used it for a few months, so I'm not aware of any changes that may have occurred since my test.

When you import from HTML, typically a new folder is added to the Bookmarks menu with the imported items. This might begin with the word Imported.

On your old laptop, did you find a bookmarkbackups folder? Those are in the JSON format and hopefully could be imported successfully. From Firefox, open Help > Troubleshooting Information > "Show Folder" to launch your profile folder in Windows Explorer. Then navigate into bookmarkbackups and copy from there.

more options

Thanks for the info but still not working. I transfered the JSON file over and the bookmarks Library window remains empty as well as the Bookmarks toolbar.

I am beginning to think there is something damaged about the bookmarks or web browser on the v15.0.1 system. Things I tried:

  • tried to restore v14.0.1 JSON bookmarks to the v15 pc -> bookmarks are empty
  • tried to restore v14 HTML bookmarks to the v15 pc -> bookmarks are empty
  • tried to restore the v15 JSON bookmarks to the v14 PC -> bookmarks are empty
  • tried restoring the v14 JSON bookmarks to the v14 PC -> bookmarks ok

It would seem there is either an incompatibility or corruption of the v15 bookmarks or the v15 Firefox configuration (maybe a bad plugin?). I'm inclined to remove the v15 Firefox then re-install it with no addons to see if this changes the equation. Does that sound like a reasonable approach?

Okulungisiwe ngu nlyons408

more options