Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Command-left, command-right keyboard shortcuts not working in Gmail on Mac

  • 3 uphendule
  • 9 zinale nkinga
  • Igcine ukuphendulwa ngu jscher2000

more options

Command-left, command-right keyboard shortcuts for moving to the end and beginning (home) of each line does not work.

This feature works in Safari, Opera, Chrome and every other configuration, but not Firefox.

It also works in other text editors, such as Facebook, but not Gmail. This is pretty irritating, and means I have to use another browser before I go crazy trying to write emails.

This has been detailed extensively in another thread here, and was marked as solved, even though it is quite clearly not solved. Help is appreciated.

All Replies (3)

more options

You have researched this well. A bug has been filed for this, as I think you may have noticed (just guessing from your username): Bug 341886 – Cmd/Command+Left/Right does not move caret at Gmail in rich formatting mode.

You might be able to override Google's script, but then because a rich editor is not actually a form control, Firefox probably would navigate back one page. You might need to edit the key bindings, too. I think the technique for that was mentioned in the bug or the other thread. It also was discussed in this one: Making the Home/End keys work on Mac like they do on Windows/Linux.

more options

Thanks for the help. Upon researching it led me again to the Macworld article here:

I tried again the method of unpacking the omni.ja file in the, as detailed there, but had to unzip using:

unzip omni.ja -d /a directory of your choosing

…replaced the platformHTMLBindings.xml file with the one from Macworld, and then I rejar-red using:

jar cvf omni.ja /a directory of your choosing

but when replaced this new file in it crashed on load, so I don't know where the problem is.

more options

That article is 5 years old now. You might have better luck just looking for specific bindings to change. I'm a Windows user, so can't test very well.