Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Cannot put item in Cart on Amazon site

  • 9 uphendule
  • 3 zinale nkinga
  • 8151 views
  • Igcine ukuphendulwa ngu cor-el

more options

In Firefox (15), Safari, but not Opera I cannot put an item in the shopping cart on the Amazon website. This problem occurs ONLY when buying an item in Clothing and Accessories, where it is necessary to specify a size. If I search and select such an item, like a pair of trousers, the section where the item is put into the cart is dimmed, and there is an instruction to select a size. I select a size and then move the cursor to the point where I can Add to Cart. But this section remains dim instead of turning bright. I cannot add the item to the cart. EXCEPT if I order a belt! A belt has a size, you must specify it, and you can put it in the cart. I DID NOT HAVE THIS PROBLEM UNTIL ABOUT A WEEK AGO, after downloading a Software Update that contained an HP printer driver. That issue got fixed by an HP tech working remotely. I have talked to Apple several times, they cannot figure out what is wrong with the Amazon site. I do NOT have this problem on a MacBookPro running 10.6.8. I only have it on a MacPro desktop machine also running 10.6.8. I reinstalled 10.6.3 on the desktop Mac from the Snow Leopard DVD and updated that to 10.6.8 (not including the HP driver on the chance that that might have triggered all of this. The inability to move "sized" items to the cart still persists, as described. Note again, I have the same problem in Safari, but no problem in Opera. I am allowing cookies and third party cookies. I have tried restarting with add-ons disabled. I have deleted Amazon's cookies and then allowed Amazon to re-install them. There is no firewall up. The desktop machine is around 6-8 years old. There are no apparent hardware problems although I only have 1GB of RAM. Could this be a firmware problem? Of course I have the workaround of using Opera or the laptop if I want to buy some socks, but it's annoying to have this inconsistency. Any advice would be appreciated. Thanks. Gene

Okulungisiwe ngu genehammel

Isisombululo esikhethiwe

If clearing cookies doesn't work then it is possible that the file cookies.sqlite that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 2

All Replies (9)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

more options

Isisombululo Esikhethiwe

If clearing cookies doesn't work then it is possible that the file cookies.sqlite that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

more options

Thanks cor-el. There's a problem

/Users/gene/Library/Application Support/Firefox/Profiles [Roo:Application Support/Firefox/Profiles] gene% ls cookies* ls: No match. [Roo:Application Support/Firefox/Profiles] gene% ls -lt total 0 drwx------ 39 gene admin 1326 Aug 30 10:05 e9rx5b5a.Default User drwx------ 41 gene admin 1394 May 14 12:49 l9jlh3b8.default

Should I delete this: l9jlh3b8.default ?

more options

Thanks, all, for your help. I don't know which fix worked, but I did all of them and a few other tricks, and the problem has disappeared.

more options

No, that is the Firefox Profile Folder and you lose all your personal data in Firefox.

Did you look in that folder to see if there is a file cookies.sqlite?

You can use this button to go to the Firefox profile folder:

more options

Dear cor-el,

Thanks again for your help. I now have the same problem in Safari. The options seem to be different for Safari. I did reset Safari but that did no good. I would be grateful for any advice on how to fix this.

Gene

more options

Did you find the cookies.sqlite file and removed the file?

Are your cookie settings the default to accept at least all normal cookies from websites and do not block cookies via a block exception?

Do you have any security software that may be blocking cookies as it happens in more that one browser?


Create a new profile as a test to check if your current profile is causing the problems.

See "Basic Troubleshooting: Make a new profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

more options

Thanks for your note. Firefox is working OK. This is a Safari problem.

There are no files with the name cookies* or *.sqlite on the machine, per a spotlight search. The only files with “cookies” in the name are in Adobe apps.

All the options in Safari Preferences are checked except the blocking of pop-up windows, which is not checked. Cookies are always accepted. Third party cookies are not blocked.

Do you believe the expiration dates on the cookies? The Date&Time info on the Mac is OK, 2012. The dates on the cookies are like 01/01/36. I was unable to upload a pdf or tiff of the relevant scrrenshot with "Add Images".

Gene

more options

If you only have a problem with Safari left then it is best to take this to an Apple or Safari oriented forum.