Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

my homepage setting ignored

  • 7 uphendule
  • 2 zinale nkinga
  • 316 views
  • Igcine ukuphendulwa ngu Tregarth

more options

I have tried to set the BBC News page as my home page but whenever I start I see the Google page. I have tried dragging the BBC icon (on the BBC URL line) onto the house icon on the extreme right of the screen and seen a message "Do you want this document...page", clicked Yes, closed FF, restarted and seen the Google page.

Similarly I have started the BBC News page gone into Tools, Options, set the home page to "Use Current page", clicked OK, closed, restarted and seen the Google page again.

I have run Malwarebytes (Free) and repeated the above processes but still have the Google page.

I am currently running FF v12.0 with Win 7 HP on my laptop.

Why is Google my default page and how can I remove it?

Thank you,

Tregarth

Isisombululo esikhethiwe

Did you not do the Firefox Reset like I said above? Do that, and see if you can set your home page.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (7)

more options

Please see this article and see if it helps you: How to fix preferences that won't save

--Tobbi

more options

Also, as a side note, make sure you update to Firefox 14.0.1 to receive the most recent stability fixes and security enhancements :)

more options

Thank you both for your help.

I have installed version 14.0.1 and tried to save the BBC site as my home page. Still back to Google.

I went to the website "How to fix..." and tried to follow the section "Specific preference are not saving". I do not have any of the programs listed so I went to "User.js file overriding preferences".

The first line mentions a FireFox button, I don't have one of these on my screen so i went to Help/Trouble Shooting info. There is no "Open Containg folder" button so I tried the Profiles Flder / Show Folder button. There is no FireFox button so I stopped this approach.

Instead I used Win Explorer to search for User.js file which is in my C directory. I dragged this into Notepad and saw the following code. I have no idea what Babylon is so I have decided to stop.

Any help or advice would be greatly appreciated,

Thank you,

Tregarth

more options

Ok, so you are infected by Babylon Toolbar, which is a malicious Extension that will take over your home page, Search Engine, etc. Let's do this:

Click your Start button, go to the Control Panel, then to Uninstall a Program. Remove Babylon. Restart your PC.

Download and Install MalwareBytes Anti-Malware, run a full Scan. http://www.malwarebytes.org/. This helps check that there are no viruses on your computer causing issues. You can uninstall this program after you clean off any infections.

Then, start Firefox up. Reset Firefox Refresh Firefox - reset add-ons and settings

Now you should be able to set your homepage to whatever you want :)

more options

Thank you for your patience.

I thought I had already removed the Babylon software previously. I have looked in Programs & Features, Babylon does not show. But when I searched my C drive for Babylon using Win explorer I saw a whole load of files. Please see image.

I have already run MalwareBytes (Free) but only run a quick scan. I have now run a long scan which has not found any malware items.

Simultaneously my AVG Antivirus (Free) has started. This produced the following report (see image). I have searched my C drive again and taken another screen grab. (The images run from left to right.) Nothing seems to have changed, babylon is still present.

Can I just search the C drive, find the files and delete them?

Thank you again,

Tregarth

more options

Isisombululo Esikhethiwe

Did you not do the Firefox Reset like I said above? Do that, and see if you can set your home page.

more options

Thank you very much indeed for your help and patience. It is not my fault if I am stupid.

I have now follwed your instructions and reset FF.

All is now OK.

Best regards, I am very grateful,

Tregarth