X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Awesome bar autocomplete suddenly sorting alphabetically

Kuphostiwe

In the last few days (I believe since the installation of the latest Firefox), my awesome bar has started delivering autocomplete suggestions in alphabetical order, instead of delivering the most frequently used site first. Since I use the awesome bar for most of my navigation, this is a significant hitch. How do I switch the settings for awesome bar autocomplete back to relevant rather than alphabetical?

In the last few days (I believe since the installation of the latest Firefox), my awesome bar has started delivering autocomplete suggestions in alphabetical order, instead of delivering the most frequently used site first. Since I use the awesome bar for most of my navigation, this is a significant hitch. How do I switch the settings for awesome bar autocomplete back to relevant rather than alphabetical?

Okulungisiwe ngu ejg25

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Version 3.2.4.8431
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Shockwave Flash 11.3 r300
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Office Live Update v1.0
  • 5.0.61118.0
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Web based SlingPlayer for streaming from Slingbox
  • npmnqmp 071505000006
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • iPhoto6
  • RealPlayer Plugin

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1

Eminye Imininingwane

ideato 893 izisombululo 6250 izimpendulo
Kuphostiwe

Impendulo Ewusizo

It is new in firefox 14.0.1 see how to disable it, jcanth reply :

https://support.mozilla.org/en-US/questions/932466

then : go to About:config type browser.urlbar.default.behavior and change the value to 1.

see also for info : Changing autocomplete behavior - Firefox


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.

It is new in firefox 14.0.1 see how to disable it, '''jcanth''' reply : https://support.mozilla.org/en-US/questions/932466 '''then''' : go to [http://kb.mozillazine.org/About:config About:config] type [http://kb.mozillazine.org/Browser.urlbar.default.behavior browser.urlbar.default.behavior] and change the value to '''1'''. see also for info : [http://kb.mozillazine.org/Disabling_autocomplete_%28Firefox%29 Changing autocomplete behavior - Firefox] thank you Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.
jscher2000
  • Top 10 Contributor
8838 izisombululo 72245 izimpendulo
Kuphostiwe

Whether you enable autoFill in the URL bar or not, the drop-down list itself should still be in "frecency" order rather than alphabetical. If the order of your list changes, that sounds like a bug.

Whether you enable autoFill in the URL bar or not, the drop-down list itself should still be in "frecency" order rather than alphabetical. If the order of your list changes, that sounds like a bug.

Umnikazi wombuzo

After I changed that setting, it did switch to relevance/frequency sorting. My guess is that this setting has three options: 0, 1 and 2?

After I changed that setting, it did switch to relevance/frequency sorting. My guess is that this setting has three options: 0, 1 and 2?
jscher2000
  • Top 10 Contributor
8838 izisombululo 72245 izimpendulo
Kuphostiwe

Oh, I was thinking of the browser.urlbar.autoFill = true/false change from the other thread. I don't think that one should change the order of the autocomplete drop-down. Mine doesn't change in some limited testing.

Oh, I was thinking of the browser.urlbar.autoFill = true/false change from the other thread. I don't think that one should change the order of the autocomplete drop-down. Mine doesn't change in some limited testing.

Umnikazi wombuzo

I think I was wrong... changing that setting did alter my search results somewhat, but they are still sorting alphabetically rather than by frequency. It's really irritating. No matter which setting I select, it's alphabetical.

I think I was wrong... changing that setting did alter my search results somewhat, but they are still sorting alphabetically rather than by frequency. It's really irritating. No matter which setting I select, it's alphabetical.
cor-el
  • Top 10 Contributor
  • Moderator
17696 izisombululo 160119 izimpendulo
Kuphostiwe

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Umnikazi wombuzo

Tried that. Same behavior.

I'm honestly not sure what's happening with the autocomplete. I'm no longer sure that it's alphabetical... just that it's not by frequency. The first one or two suggestions are sites I visited once, instead of the ones I visit every day.

The one thing I'm sure of is that it started with the installation of the Firefox update a month ago.

Tried that. Same behavior. I'm honestly not sure what's happening with the autocomplete. I'm no longer sure that it's alphabetical... just that it's not by frequency. The first one or two suggestions are sites I visited once, instead of the ones I visit every day. The one thing I'm sure of is that it started with the installation of the Firefox update a month ago.

Okulungisiwe ngu ejg25

jscher2000
  • Top 10 Contributor
8838 izisombululo 72245 izimpendulo
Kuphostiwe

I wonder whether there is a problem with the visit counts in your places.sqlite (history and bookmarks) database file. Do you have the Most Visited "smart bookmark folder" (has the blue search folder icon)? Do the sites there appear to be in roughly the correct order?

I wonder whether there is a problem with the visit counts in your places.sqlite (history and bookmarks) database file. Do you have the Most Visited "smart bookmark folder" (has the blue search folder icon)? Do the sites there appear to be in roughly the correct order?

Umnikazi wombuzo

I don't know where to find that database file. I searched for it in Spotlight using hidden files set to Yes, and it didn't show up.

I don't know where to find that database file. I searched for it in Spotlight using hidden files set to Yes, and it didn't show up.
jscher2000
  • Top 10 Contributor
8838 izisombululo 72245 izimpendulo
Kuphostiwe

You can't edit the database manually. There are some third party tools you can use to poke around in it if you wish. For example: https://addons.mozilla.org/en-US/firefox/addon/sqlite-manager/

However, I suggest as the first test to check the results of the Most Visited search, which are listed in the corresponding "smart bookmark folder."

You can't edit the database manually. There are some third party tools you can use to poke around in it if you wish. For example: https://addons.mozilla.org/en-US/firefox/addon/sqlite-manager/ However, I suggest as the first test to check the results of the Most Visited search, which are listed in the corresponding "smart bookmark folder."

Umnikazi wombuzo

Yes, they're sorted correctly in the Most Visited folder.

Yes, they're sorted correctly in the Most Visited folder.
jscher2000
  • Top 10 Contributor
8838 izisombululo 72245 izimpendulo
Kuphostiwe

Could you check for any non-default values (they appear bolded) here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste frec and pause while the list is filtered to the list of "frecency" preferences. You can right-click and Reset to return any modified values to their defaults.

(3) In the filter box, type or paste urlbar and pause while the list is filtered. You can right-click and Reset to return any modified values to their defaults if they appear to be relevant to this issue.

Possibly interesting reading, although it might need a bit of editing: https://developer.mozilla.org/en-US/docs/The_Places_frecency_algorithm

Could you check for any non-default values (they appear bolded) here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''frec''' and pause while the list is filtered to the list of "frecency" preferences. You can right-click and Reset to return any modified values to their defaults. (3) In the filter box, type or paste '''urlbar''' and pause while the list is filtered. You can right-click and Reset to return any modified values to their defaults if they appear to be relevant to this issue. Possibly interesting reading, although it might need a bit of editing: https://developer.mozilla.org/en-US/docs/The_Places_frecency_algorithm

Umnikazi wombuzo

I checked, and they're all at default. Furthermore, this is happening on both my work and home computers since that Firefox update (unrelated installs, and the two copies of Firefox are not synced to each other). I don't think this is due to my settings... it's a bug that started with that update. Before that the by-frequency results worked.

I checked, and they're all at default. Furthermore, this is happening on both my work and home computers since that Firefox update (unrelated installs, and the two copies of Firefox are not synced to each other). I don't think this is due to my settings... it's a bug that started with that update. Before that the by-frequency results worked.
jscher2000
  • Top 10 Contributor
8838 izisombululo 72245 izimpendulo
Kuphostiwe

I think what is happening is that the location of the matching text in the URL is influencing the order. When I type moz I get pages on www.mozilla.org and wiki.mozilla.org before I get pages on support.mozilla.org. That's backwards from alphabetical, but something other than frecency definitely is going on there.

I am using the new stylesheet and can't find the attach button to upload screen shots. I'll create a new account to post my research results on the old template. Stay tuned...

I think what is happening is that the location of the matching text in the URL is influencing the order. When I type moz I get pages on www.mozilla.org and wiki.mozilla.org before I get pages on support.mozilla.org. That's backwards from alphabetical, but something other than frecency definitely is going on there. I am using the new stylesheet and can't find the attach button to upload screen shots. I'll create a new account to post my research results on the old template. Stay tuned...
Jefferson Scher 0 izisombululo 1 izimpendulo
Kuphostiwe

Screen shots showing results for moz with autofill on and off, and comparing the frecency scores in the places.sqlite database.

Screen shots showing results for moz with autofill on and off, and comparing the frecency scores in the places.sqlite database.