Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Change default color of Firefox when opening links in a new tab

  • 5 uphendule
  • 7 zinale nkinga
  • 6289 views
  • Igcine ukuphendulwa ngu alirezanoori

more options

I'm using Stylish addon for Firefox with a default dark css. I also have changed the default Window colors in Windows registry. This has changed the about:blank page's color to a dark one. But when I open a link on a new tab, before the page loads, Firefox is showing a blank page with white background. I wonder how can I change this white color to a different one.

Isisombululo esikhethiwe

See also the discussion in this old MozillaZine forum thread.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Try to style the about:newtab page with this selector.


@-moz-document url(about:newtab){
#newtab-scrollbox { background-image: none !important; background-color: #ffc !important; }
}

Okulungisiwe ngu cor-el

more options

Sorry to say, but it didn't help. My new tab page already has a dark background. What I what is to change the "White" color when I "Ctrl+Click" on a link or select to open it in new tab and immediately switch to it before it loads. When I add a new tab, it has a dark background.

more options

One way you can do that if you are using a third party theme is to add this line into the browser.css file in the browser subdirectory in the .jar file.

browser {background: blue;}

Change the colour to whatever you like, then put the revised browser.css file back into the archive and reinstall the theme.

more options

Isisombululo Esikhethiwe

See also the discussion in this old MozillaZine forum thread.

more options

I created a folder named "Chrome" in this location: C:\Users\[user]\AppData\Roaming\Mozilla\Firefox\Profiles\[profile]\

and created an empty userChrome.css file with this line:

browser { background-color: #373739 !important; }

It worked fine. Thanks for the replies.

Okulungisiwe ngu alirezanoori