Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

My Start Incredibar extensions

  • 29 uphendule
  • 102 zinale nkinga
  • Igcine ukuphendulwa ngu JD

more options

Like a lot of others, I have had terrible problems with this damn incredibar thing that has somehow gotten onto my laptop. Thanks to the other threads in the forums I have managed to get Firefox back to what I originally had, (remove webassistent, check about:config etc...) but I still have one concern. When I search for incredibar in about:config, I still get a whole load of extensions.incredibar results. I am not very technically literate when it comes to these things but is there anyway I can remove these or are they just remnants that I am better off leaving alone? The incredibar extension doesn't seem to come up in the list under the Firefox Tab. Any help would be appreciated. Thanks.

Isisombululo esikhethiwe

Here's a really detailed guide on how to remove Incredibar (complete w/ screenshots!):

This should fully get rid of Incredibar. This is definitely one of those annoying & difficult ones to get rid of.

Those extensions.incredibar results should be safe to remove. They only are active when the extension is installed. If it's uninstalled, then those settings can't affect anything. Also those kinds of settings get left behind from all kinds of add-ons because there isn't a way to auto remove those settings when a add-on is uninstalled. Hopefully this problem is fixed one day by the Firefox devs.

To erase those settings:

  • In the url bar, type about:config and press Enter. If you see the "This might void your warranty!" warning, just click the I'll be careful, I promise! button to continue.
  • Type extensions.incredibar into the Search box. Then right-click on each setting that appears in the results below and choose Reset. That will erase the settings from Firefox after you shutdown Firefox.
  • You can also do nothing. They are just left behind remnants that don't do anything.

Example screenshot:
About:config Reset menu option

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 15

All Replies (9)

more options

If you removed Firefox and did not pick to remove everything, it kept your favorites and all your Firefox preferences even installing from scratch. You can go to Help, Troubleshooting Information and click on Reset Firefox. It will leave your favorites but reset everything else to a clean install.

more options

Try for Firefox removals, this page seems to be updated more often than others, I've been infected with this malware a few times, and its not only firefox that it can infect, its annoying that Google still ranks sites that embed this software into their installs.

more options

Bah... It came back! I think I got a process running.

Okulungisiwe ngu TommyLick

more options

Download Spybot - Search & Destroy then update it. I would then run the app twice, it did not pick it up on the first scan for some reason.

more options

I just went ahead and deleted Firefox and everything associated with it. I became weary of trying to get rid of that stupid thing.

more options

Spam removed by moderator

Okulungisiwe ngu NoahSUMO

more options

I found the following prevented Incredibar items from reappearing in about:config after I had cleared it, and from hijacking new tabs:

1. Click Troubleshooting Information under Help.

2. Click Show Folder.

3. In the folder shown, rename the new user.js file to something else for the moment (to delete it later) and rename the user.js.old file that is still there user.js.

4. Next go to the parent folder ...\Firefox\Profiles.

5. If there is a .ini file in that folder, named the same as the profile folder you were just in, and created on the day your problem started, delete it.

This was enough to stop Incredibar from coming back. But to do the job properly, it is probably safest to ...

6. Go to Start > Run > Regedit and search for any Incredibar or Mystart items, and delete any you find.

7. Restart computer and restart Firefox, go to about:config and check if there are any remaining or reappearing Incredibar or Mystart items.

Should be gone now.

Okulungisiwe ngu aklb

more options

Thank you. Good information and it worked. Sorry I was so long in replying. Happy Thanksgiving!!!!

more options

After going thru and executing most of the suggested solutions below, there was still one area which I could not conquer - the mid-screen search bar was still coming up with the "" in the location bar. Today, I ran Spybot freeware. It fixed lots of problems but not this one. Then, I thought there was one more process that I had not tried - running Firefox in Safe mode and resetting Firefox to default settings. Well, I am proud to let you know that this procedure killed it. I now have my normal Google search bar back as the mid-screen search bar. Just in time for Christmas !!!!

  1. 1
  2. 2