Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why won't Links open from e-mail if Firefox is default browser

  • 24 uphendule
  • 13 zinale nkinga
  • 31447 views
  • Igcine ukuphendulwa ngu cor-el

more options

I still have this problem and now it is starting to affect the browsers functionality and useability. When Firefox is my default browser any link outside of Firefox (like in my e-mail) won't open which is becoming a nuisance. I am running Windows 7 which may be the cause of the problem via a setting but I can't locate the needle in the haystack or it may have happened at a Firefox update. Firefox has been my favorite and only browser since Netscape 1.0 but if I can't resolve this problem I will have to switch to another which I really don't want to do. Help!!!

Isisombululo esikhethiwe

Tip: If you feel adventurous, try downloading FireFox 13.0.1 from:

ftp://ftp.osuosl.org/pub/mozilla.org/firefox/releases/13.0.1/win32/en-US/

This site is an official Mozilla Mirror, and has the GpG signature file in the folder with the executable.

I had to revert to 13.0.1 to get my links to open correctly.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

koehlerle;

Unfortunately, we will have until the Great Gods at Mozilla decide this is not a "Feature" and fix their bug.

Hopefully, they will have a 14.0.2 out in a few days and fix all of the bugs I am reading about on this forum. (Maybe 14.2.7 or 47.92.381... Who Knows!)

more options

I've had the same problem and others too, like Twitter and Gmail not loading. I've messed about with the settings a number of times as suggested by others here, the problem seems to resolve itself but then comes back. It's incredibly annoying, even when using another browser to use hyperlinks.

I followed the advice and down-graded to Firefox 13.1 and the problem has gone, along with renewed access to Twitter and g-mail. It is obviously a problem with the update and when this gets fixed is anyone's guess. I've had to turn off automatic updates and have to live with Firefox saying I'm using an 'Insecure version'. In the meantime I have configured Google Chrome to look like my Firefox screen with RSS feeds etc and will probably switch for good if I can get my Bookmarks in the right place. It's a real shame as I've used FF for ever now and I hate all the others but enough is enough. It's been a really frustrating few weeks.

more options

Thank you for your response but I have cured my problem but as of right now I am not sure what I did to fix it as the problem came back a couple of times and each had a different solution. Thanks again and this thread could end here from my point of view and maybe this reply will do it.

more options

Locking this thread because the owner has indicated that the problem is solved.

Please start a new thread for your question if you have this problem.

  1. 1
  2. 2