Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Amazon https does not load properly

  • 27 uphendule
  • 79 zinale nkinga
  • Igcine ukuphendulwa ngu MurphySquint

more options

I cannot access my Amazon account (using https) with Firefox.

Images do not load when using https. As the "Continue" button is an image, it does not appear on the page. This only happens with Amazon (.com, and .fr) and no other secure website.

To access my Amazon account, I have to use IETab, IE9 or Chrome, as the problem only exists with Firefox.

I have restarted with all add-ons disabled: no change. I have updated all the plugins: no change. I do not use any "https-only" add-on.

This problem used to happen very occasionally and would disappear, but it is now permanent.

I see other Firefox users have been reporting the same problem for at least a year now, so this is not unique to me.

Any suggestion welcome...

All Replies (7)

more options

Well that solves the problem in an instant - thank you. That's the sort of solution I like!

I had a feeling it was something like that but I'm not sure why I didn't get the usual 'Accept/reject certificate' (which happens fairly often). I usually accept COMODO certs anyway. Also some other cert. issuers aren't always accepted but appear trustable.

And of course it fixed it for Amazon/Javari/Audible in one go. Has anybody told Amazon?

Many thanks griwol,

more options

Have told it to Amazon, here my mail in german:

Sehr geehrte Damen und Herrn,

viele User im Internet klagen über Darstellungesprobleme Ihrer Webseite (Bilder und Grafiken im Text fehlen komplett) sobald mit dem aktuellen Firefox Browser eine SSL Verbindung aufgebaut wird (https im Bereich 'Meine Bestellungen'). Bisher hatte niemand eine Lösung. Wie ich jetzt herausgefunden habe, liegt das Problem an einem ungültigen Sicherheitszertifikat von COMODO auf Ihrem Images-Servers Auf Ihren SSL-Seiten wird aufgrund dieses Zertifikatsfehlers ein Javascript-Fehler in Firefox geworfen: 'fwcim is not defined Quelldatei: Zeile: 902'. fwcim ist eine Funktion/Objekt welches in einer externen Javascriptdatei liegt. Diese soll per von Ihrem Images-Server geladen werden. Aufgrund des Zertifikatsfehlers wird die Datei jedoch nicht geladen und somit funktioniert auch Ihre Seite nicht.

Mit einem Trick läßt sich dieser Fehler umgehen: Aufruf der Javascriptdatei direkt im Firefox in der Adresszeile. Hierdurch meldet Firefox, daß es ein Problem mit der Seite gibt. Anschließend kann eine Sicherheitsausnahmeregel für Ihre Webseite in Firfox eingetragen werden und künftig funktioniert eine SSL-verbindung zu bzw. zu Ihrem Images-Server.

Die ist keine Lösung für einen Standarduser. Der Fehler sollte dringend beseitigt werden.

more options

There is no problem with the certificate from, so it shouldn't be necessary to make an exception or install that intermediate certificate manually.

You can inspect the certificate chain via a site like this:

more options

'shouldn't be necessary to make an exception'

I find that Firefox encounters problems with certificates now and then (i.e. not infrequently), and this was one of them.

If there is a broader question as to why Firefox often doesn't accept apparently valid certificates, when IE does, let's look at that as a separate issue. The work-round fixed my current problem however.

Vielen Danke griwol - can you tell us what Amazon say in response.

more options

Just perfect. After many hours to look for a solution, it's THE SOLUTION. Thanks so much, Pierre

more options

Thank you very much griwol, that has fixed the problem. I would never have found the solution in a month of sundays.

more options

Had this same problem for about 3 months. Someone said to check Firefox Add-ons. Which is where I finally found the problem and fixed it.

An Extension called wxDfast 1.0 was causing the problem.

I found it by going to Tools on Firefox, then Add-ons, then Extensions. There I disabled wxDfast 1.0. Which fixed the access problem to Amazon.

I found the solution by disabling each item I found in Add-ons and then checking Amazon. Process of elimination.

Hope this helps someone.

  1. 1
  2. 2