Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox is assuming that a 'localhost' internal server address is an external search address and redirects to the external address

  • 13 uphendule
  • 62 zinale nkinga
  • Igcine ukuphendulwa ngu ivankruss

more options

I am presently re-establishing a consultancy business that I ran a few years ago and consequently, am building a WordPress-based website. As I am in a very preliminary stage of development, I set up a local host on wamp server so I could play around with my website project.

On the day this wamp server set up was completed, I was able to activate the WordPress platform, and imported and installed the Weaver II theme. I then switched off my computer for the night. However, on switching on the next morning, I ran into a curious technical problem.

I use Firefox 12 as my browser and every time I entered 'localhost', or 'localhost/wp-admin.php', or any localhost-based word combination, I get automatically redirected to an AltaVista search result (the address that appears in my URL box replacing ‘localhost’ is:

Is there a reason for this? Do you think I did something wrong in my installation, although everything seemed to be working apparently normally the night before?

From my layman’s viewpoint, it seems to me that Firefox is confusing the ‘localhost’ request to open an internal file with an external search request for an item called ‘localhost’.

Any suggestions, advice to fix this?


Graham Segal

All Replies (13)

more options

see this article -> Search the web from the address bar

What i think is happening is that is set as your default search engine and when you type something (keywords) and press Enter, it searches those keywords on the search engine and displays the search results.

Perform the suggestions mentioned in the above mentioned article. Check and tell if its working.

more options


Thank you very much for taking the trouble to consider my problem. I followed the suggestions to modify the about:config files but none of the changes worked. I changed the keyword.enabled, the fixup and the browser.alternate.suffix (with that latter file, I tried changing the .com to .php and when that didn't work I tried deleting the .com entirely, leaving the box blank).

I have now reset the changes I made.

I have one query from your comments. I don't recall ever making Yahoo my default search engine. I don't know how to check this. I looked in the Options tab, but could not see any reference to Yahoo or the setting up of a default search engine. I have had experience in downloading some programs from cnet,com where the download process asks if I want to install a particular company's search toolbar or make a particular search engine my default. I always refuse these requests but I know that some of these vendors are a bit shifty and insert commands clandestinely or surreptitiously.

Could this be a sources of the problem?



more options

To restore your default search engine, see this article -> Diagnose Firefox issues using Troubleshoot Mode

  • place checkmark on "Restore Default Search Engines" and click "Make changes & Restart" button

Check and tell if its working.

Okulungisiwe ngu Hasan

more options


I'm still not having much luck! I went into safe mode and deleted a number of search engines, including Yahoo, eBay, Amazon and a couple more that I had never heard of and didn't know were in my computer. Now, I only have Google & Bing as active search engines.

Unfortunately, this action did not fix the 'localhost' difficulty. I am still being diverted to the AltaVista search results site, despite the fact that Yahoo has been deleted as an included search engine.

have you any other ideas?


more options

Perform the suggestions mentioned in the following article:

Also see these articles:

Check and tell if its working.

more options

hello, have you tried resetting (righ-click it > reset) the keyword.url prference in about:config to the default too& could you get the site to show up while you where in safemode?

maybe as a workaround you can access the local wp-blog via ...

more options

mha007, madperson,

Your suggestions are greatly appreciated. unfortunately, i still have not been able to resolve the difficulty.

i have noticed in the 'about:config' file that there are a number of possibly relevant entries in the ' ...' section. I would like to send you a screenshot of this but I am not sure how to do that in this forum site. Essentially, there are references to Yahoo in this section, notwithstanding that I took action yesterday to delete Yahoo as an installed search engine.

There is also a reference to a 'MyStart' search engine that I have not come across before.

Some examples:

1.>user set>string>Yahoo


3.>user set>string>MyStart Search

Do these entries in 'about:config' provide any clues?

signing off in hope with a couple of extra grey hairs,


more options

-> Start Firefox in -> Diagnose Firefox issues using Troubleshoot Mode to check if your add-ons/extensions are causing the problems.

Check and tell if its working normally while using Firefox in Diagnose Firefox issues using Troubleshoot Mode.

more options

you can also install the searchreset extension that will revert the settings back to the default:

more options

Hey chiron34,

what happens when you enter http://localhost/ as written here, with protocol and slash at the end? Does Firefox's keyword search still kick in?

Also, what does Help > Troubleshooting information say?


more options

mha007, madperson, tobbi

About 4hours ago, I was in Firefox safe mode. I was checking the half dozen installed plugins for their status to see if any required updating, as suggested by mha007. One did: Adobe Flash. After downloading the update file, I began checking the other plug-ins.

Then disaster struck. My suburb here in Brisbane experienced a sudden and unexpected electricity supply blackout. This is a rare occurrence here and when it occurs, it's usually because some construction worker with a trench digger digs into the ground and cuts the electrical distribution cable.

When the power eventually came on about half an hour ago, I opened Firefox with some trepidation that the sudden close-down in safe mode may have caused some damage. So you can imagine my surprise when I began checking URL entries as suggested by Tobbi to find that the problem has quite miraculously disappeared, as if by magic! I have no logical explanation for this.

I will not completely sign off on this problem, in case the problem returns in the next couple of days.

May I express my appreciation to the three of you stalwarts for taking the trouble to think about this problem and offer some help. I am not skilled in this area and being 70 years old, I was not brought up in a technological age when I was young. If you ever need some help or advice that relates to, or concerns, Australia, please don't hesitate to email me so I can return the favour.



more options

Hello to all of You awesome people ready to help others. I have pretty much the same problem with only few differences . I have a Xampp installed on my Windows 7 machine, 64bit, and I am building a website using Joomla on my localhost. Firefox is 15.01

  When I use the website I am working on, everything functions just perfectly except for this 'little' annoying problem. Here are few things I noticed in addition to what chiron34 already mentioned. 
  1. When I put the mouse over the links in the menu they show as this in the status bar of Firefox (down left) :


  instead of :

"http://http://localhost/joo_dev/Mamma%20Mia/test-site/index.php?option=com_virtuemart&view=category&virtuemart_category_id=4" .

  And when I click on the links everything functions right. I get to the requested webpage.

2. If I would to change something in the parameters of the URL, for example put a "0" instead of the "4" at the end of the previous example (which is btw exactly how I found out about this issue),, then I would get redirected to : google.comlocalhost/joo_dev/Mamma Mia/test-site/index.php?option=com_virtuemart&view=category&virtuemart_category_id=0 and it would actually show up like this - "google.comlocalhost%2fjoo_dev%2fmamma+mia%2ftest-site%2findex.php%3foption%3dcom_virtuemart%26view%3dcategory%2 6virtuemart_category_id%3d0/"

in the address bar.

I hope that this info might supply You with a little more material to work with. I am not sure if that helps, but I sure hope so. For now I can work around this, but its annoying and if You guys would be able to help out with this- it would greatly appreciated. Thank You. ivankruss

PS: is my home website in firefox.

more options

Also, if I would put the "http://" in front of the URL, then everything functions as expected and I land on my local webpage.